Beiträge von Harzer

    Nun bin ich wieder ausgeschlafen. Und werde folgendes erledigen:


    1) Den Admin-Bereich von 2.5.9 lokal wieder herstellen. Das ist kein Problem.
    2) Joomla 3.4.3 installieren.
    3) Benötigte Plugins u. Erweiterungen installieren
    4) Alle benötigten Mediendaten (Fotos, Filme, Sound) mittels FTP in die benötigten Strukturen kopieren. (Das müsste sogar mittels FTP direkt auf dem Server kopierbar sein.)
    5) Über den alten Adminbereich nachschauen was es für alte Strukturen wie Kategorien gibt und diese in 3.x erzeugen. Beiträge etc danach dann mittels Kopie und Paste in den Editor des 3.x kopieren und mit den gewünschten Eigenschaften speichern.


    Damit ist sichergestellt das die Strukturen des 3.4.3 in Ordnung bleiben, das alle internen Links etc in Ordnung sind. Das wird jetzt ein langes WE, aber besser als nichts tun und sich ärgern.


    6) Das automatische Update abschalten. Denn beim manuellen Modus wäre das nicht passiert. Siehe Eingangstext. Denn was hätte es gekostet beim Klicken des Installbuttons noch zu fragen: "Update installieren?". Ein paar Bytes. Denn dann wäre höchstwahrscheinlich keine versehentliche Installation angelaufen.
    Wenn dann alles läuft werde ich in Ruhe überlegen welches System für die Zukunft das für mich geeignete ist, wie es weiter geht. Ich bin selbst Informatiker und habe schon einen Background. Und weiß dass es nicht immer glatt geht.


    Danke allen für die Tipps. Hat nicht sollen sein. Vielleicht hätte es noch eine Lösung gegeben, doch ein manueller Neuaufbau geht zeitlich schneller. Vom Zeitpunkt her gesehen.

    Nöhhh.... Ich mag nicht mehr. Joomla fällt bei mit nun raus.


    Aktion:
    Neuen Webspace definiert. 2.5.9 downgeloaded. Die Daten der Full-Version kopiert. Die URL aufgerufen und wollt für eine Testinstallation (Welche unter xampp nicht lief)
    Die URL aufgerufen und was passiert?


    Die ersten Zeilen im Kopf des Browsers lauten:
    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /homepages/25/d13552193/htdocs/siptenfelde/libraries/joomla/filter/input.php on line 652Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /homepages/25/d13552193/htdocs/siptenfelde/libraries/joomla/filter/input.php on line 654Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /homepages/25/d13552193/htdocs/siptenfelde/libraries/joomla/filter/input.php:652) in/homepages/25/d13552193/htdocs/siptenfelde/libraries/joomla/session/session.php on line 532


    Danach kommt dann das Installbild "Joomla! 2.5.9 Installation" mit Auswahl der Sprache. Und es kommen 2 Wiederholungsmeldungen:


    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /homepages/25/d13552193/htdocs/siptenfelde/libraries/joomla/filter/input.php on line 652Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /homepages/25/d13552193/htdocs/siptenfelde/libraries/joomla/filter/input.php on line 654


    Wenn ich nun auf "Weiter" klicke sehe ich einfach nur noch den animierten Kreis..... Und das war es dann. Hier kommt das Script nicht mehr zurück... Ich kann nur den Browser schließen...


    Es sind nun viele Stunden vergangen. Ohne Ergebnis, aber mit viel Frust. Ähnliches hatte ich vor Jahren beim Wechsel von 1.5 nach 2.x. Ich mag nicht mehr.

    Parallel zum Upload installiere ich gerade xampp. Und werde diese 2.5.9 - Joomla mit der 3.4.3 DB lokal installieren. Da lufen Korrekturen schneller da ich nur ein 2,3 MBit - Leitung habe


    Da habe ich dann ja die neue DB.


    Wenn das nicht funktioniert werde ich versuchen in einer weiteren DB dann die 2.5.9 Datenbank manuell "zurück zu installieren. Damit ich erst mal ein wieder lauffähiges CMS bekomme. Sollte mir das gelingen bin erstmal wieder froh.

    Bevor ich gestern Abend das alles nochmals durchlaufen ließ habe ich die Ratschläge befolgt.


    Denn in der Version 2.5.x hatte ich die letzte gültige Version. 2.5.9.


    Ich werde heute Nachmittag nochmals den Zustand welcher sich nach der ersten misslungenen Upgrade - Aktion ergab. Und dann nochmals in Ruhe alle Schritte durchgehen.



    Fragen:
    Ist es ein Unterschied ob die Migration manuell angestoßen wird statt dem Automatismus?


    Würde es etwas bringen die Joomla Version 2.5.9 neu mit einer neuen Datenbank zu installieren? Und dann nur die Daten ohne Strukturen aus der 3.4.3 -DB mittels SQL in die dann neuen Tabellen der Version 2.56.9 zu übertragen?

    Gesagt... Getan...


    Die HP selbst bringt nach wie vor den Fehler:
    /libraries/joomla/error/error.php on line 797


    Beim Versuch den Admin-Bereich auf zu rufen kommt folgende Meldung:
    No configuration file found and no installation code available. Exiting...

    Tja....


    Ergebnis im Adminbereich:


    Table 'db423082261.sipten_postinstall_messages' doesn't exist SQL=SHOW FULL COLUMNS FROM `sipten_postinstall_messages`
    Es werden nur noch die Links angezeigt. Folge ich einen ergibt sich diese Fehlermeldung:
    Fatal error: Call to a member function set() on a non-object in /homepages/25/d13552193/htdocs/siptenfelde/administrator/components/com_login/controller.php on line 36
    Also wieder zerschossen. Denn außer dieser Fehlermeldung kommt nichts mehr.


    * Special treatment is required for this component, as this view may be called
    * after a session timeout. We must reset the view and layout prior to display
    * otherwise an error will occur.
    */
    35 $this->input->set('view', 'login');
    36 $this->input->set('layout', 'default');




    Im Backend:
    Fatal error: Call to undefined method RuntimeException::get() in /homepages/25/d13552193/htdocs/siptenfelde/libraries/joomla/error/error.php on line 797
    Zeile 797 im Code: $document->setTitle(JText::_('Error') . ': ' . $error->get('code'));


    Vielleicht sollte ich alles einstampfen....


    Da scheint mir beim SQL etwas schief zu laufen.

    Das es mit dem neuen Hochladen der HP-Dateien nicht gehen kann ist schon klar. Aber: Ich habe erst mal wieder einen voll funktionsfähigen Adminbereich.




    Es sind 4 Aktualisierungen verfügbar UND dann das Joomla-Update auf 3.4.3


    1)
    AllVideosAktualisierungPlugin4.7.0content Sitehttp://www.joomlaworks.net/updates/jw_allvideos.xml
    http://www.joomlaworks.net/for…th,-2015-allvideos-v4-7-0


    2)
    GermanAktualisierungPaket2.5.28.1UnbekanntSitehttp://update.joomla.org/language/details/de-DE_details.xml


    3)
    JCE EditorAktualisierungKomponente2.5.2UnbekanntAdministratorhttps://www.joomlacontenteditor.net/index.php?option=com_updates&view=update&format=xml&id=1&file=extension.xml
    http://www.joomlacontenteditor…ews/item/jce-252-released


    4)
    JoomGalleryAktualisierungKomponente2.1.6UnbekanntAdministratorhttp://www.en.joomgallery.net/components/com_newversion/xml/extensions2/joomgallery.xml



    Um nun das Joomla-Update neu laufen zu lassen:
    Sollten diese angezeigten 4 Aktualisierungen gestartet werden ODER diese Erweiterungen/Module deaktivieren (Sofern möglich)?


    Datenbank,
    Hier wird folgendes gezeigt:
    Die Datenbankaktualisierungsversion (3.4.3) passt nicht zur CMS-Version (2.5.9).


    (Das ist klar. Geht nun ja nicht anders)



    Die Spalte 'title_alias' vom Typ 'VARCHAR(255)' ist nicht in Tabelle 'sipten_content' enthalten. (Von Datei: 1.7.3-2011-10-15.sql.)
    Die Spalte 'title_alias' vom Typ 'VARCHAR(255)' ist nicht in Tabelle 'sipten_content' enthalten. (Von Datei: 1.7.4-2011-11-23.sql.)


    Da diese beiden SQL-Statements so aussehen als ob sie zu einer Installation gehören...



    --------------


    Ich selbst würde nun so vorgehen (Bitte um Kommentare falls ich falsch liege)


    1. Die DB in jetzigem Zustand sichern
    2. Die Erweiterung "AllVideos" deaktivieren
    3. das fehlende Feld 'title_alias' vom Typ 'VARCHAR(255)' ist nicht in Tabelle 'sipten_content' in genannter Tabelle ergänzen.
    4. Für das Joomla-Update unter Optionen auf "Kurzzeit.-Suppot" ändern
    5. Das automatische Joomla-Update laufen lassen
    (Installierte Joomla!-Version2.5.9. Aktuellste Joomla!-Version3.4.3)


    Alternativ könnte natürlich die Erweiterung von Punkt 2 aktualisiert werden. Vielleicht ergibt ja genau diese auch das fehlende Feld?
    Oder alle Aktualisierungen vor dem Joomla-Update laufen lassen

    Hallo zusammen,


    mir ist etwas dummes passiert:


    Ich war im Adminbereich und sah das die automatische zu installierende neu Version verfügbar war. Es blinkte so schön....


    Doch ich hatte ja noch kein Backup meiner Files. Daher machte ich einen Download der Homepage. Denn diese möchte ich eh unter xampp lokal installieren. Denn da ist ist einfacher mal eben etwas auszuprobieren.


    Nach dem Download war ich wieder im Adminbereich. Und hatte den Button Update starten vor mir. Doch die Optionen auf kurzfristigen Support mussten noch gesetzt werden und ich musste noch einen SQL-Export machen. Der PHP My Admin war schon gestartet und ich suchte die korrekte DB.


    Tja, und dann passierte es. Hier klingelte es an der Haustür. Ich schob Maus und Tastatur zur Seite, stand auf und schaute wer da an der Tür war.
    Als ich nach 20 Minuten zurückkam kam war ich etwas böse überrascht: Stand da doch das das Update als finalise fehlerhaft war. Ich muss da beim Aufstehen um zur Tür zu gehen, den Button aktiviert haben. Ohne es zu bemerken.



    Aktuell habe ich einen Status wo ich nicht mal mehr in den Admin-Bereich gelange. Daher lasse ich gerade ein Upload der Homepage in einen neuen und frischen Bereich auf dem Server laufen.
    Ich hoffe das ich dann zumindest in den Adminbereich hinein komme.


    Der aktuelle Zustand wäre dann:
    Homepage Stand wieder 2.5x. SQL: Stand nach fehlerhaftem Update. Da die Datensicherung noch Ausstand. Wie ja beschrieben.


    Frage nun:
    Sollte ich nach dem Upload der Homepage den Updatemodus neu durchlaufen lassen? Und dann die SQL-Dateien mittels PHP myAdmin manuell ausführen? Wenn ja: Wo genau finde ich die für die Version 3.4 benötigten SQL-Anweisungen?


    Oder ist diese Idee der Reparatur grundsätzlich falsch`? Wenn ja: Was kann ich sonst machen?