Beiträge von deepblue2000

    Re:Later

    laut Artisteer Forum muss es genau anders rum

    die "&" waren drin. hab die nun rausgenommen. und die fehler sind weg:

    http://www.artisteer.com/?post…&p=forum_post&forum_id=20



    Vielen Dank euch allen !

    Ich bin froh das es jetzt lokal mit XAMPP schonmal fehlerfrei läuft.

    Das, das Template von Aristeer für Joomla zu alt ist, hab ich ja auch schon gelesen. Aber davon

    hab ich auch noch keine Ahnung und muss mich erstmal in alles reinlesen wie das funktioniert.

    PHP ist nicht meins.(oder auch webdesign)

    ok sorry, da hatte ich wohl nen tippfehler drin.


    Phoca Gallery war doch installiert (uraltversion), hab das nun aktualisiert

    und siehe da die seite geht schon mal etwas mehr.


    (hatte eben das Phoca Gallery Plugin installiert, was nicht installiert war)


    seitenaufbau kommt, oben kommt dann das:

    Code
    1. Warning: Parameter 2 to modChrome_artblock() expected to be a reference, value given in X:\XAMPP\htdocs\jupgrade\templates\ghnrw1\html\modules.php on line 36
    2. Warning: Parameter 3 to modChrome_artblock() expected to be a reference, value given in X:\XAMPP\htdocs\jupgrade\templates\ghnrw1\html\modules.php on line 36
    3. Deprecated: Non-static method modGTranslateHelper::getParams() should not be called statically in X:\XAMPP\htdocs\jupgrade\modules\mod_gtranslate\mod_gtranslate.php on line 13
    4. Notice: Only variables should be assigned by reference in X:\XAMPP\htdocs\jupgrade\modules\mod_gtranslate\tmpl\default.php on line 115
    5. Notice: Only variables should be assigned by reference in X:\XAMPP\htdocs\jupgrade\modules\mod_gtranslate\tmpl\default.php on line 130


    Code
    1. Warning: Parameter 2 to modChrome_artblock() expected to be a reference, value given in X:\XAMPP\htdocs\jupgrade\templates\ghnrw1\html\modules.php on line 36
    2. Warning: Parameter 3 to modChrome_artblock() expected to be a reference, value given in X:\XAMPP\htdocs\jupgrade\templates\ghnrw1\html\modules.php on line 36


    Code
    1. Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in X:\XAMPP\htdocs\jupgrade\templates\ghnrw1\functions.php on line 188




    Vielen Dank schonmal für die Hilfe !


    werde heute nicht weiter dran arbeiten und hier antworten.


    Hab jetzt keine Zeit mehr. Werde morgen weiter gucken

    Fehler:

    so nach einigen Wochen Pause (und wenig Lust).... hab ich mich jetzt nochmal dran gesetzt,


    per XAMPP hab ich das alte Joomla 2.5.24 auf 3.9.15 lokal updated bekommen und bekomme im CMS auch nirgends mehr

    einen Fehler, alles scheint bis hier her zu laufen inkl. neusten PHP7.4.1 und der MySQL DB

    Jedoch funktioniert scheinbar das "Template" nicht mehr, was der Ersteller vor 6 Jahren gemacht hat.

    Laut php wurde das Template mit "Artisteer" erstellt. (das kannte ich bis letztens garnicht)


    Wenn ich jetzt eine Vorschau von der Website aufrufen will, kommt dieser Fehler: "0 - Using $this when not in object context"


    Jetzt hab ich danach auch schon seit tagen googled, es ist wohl ein Fehler von "Artisteer Template" welches mit dem neuen PHP nicht umgehen kann.


    Das hab ich schon probiert: https://github.com/joomla/joomla-cms/issues/21258

    (die einträge gibts nicht in meiner index.php (template)


    auch das hier hat mir keinen Erfolg gebracht.

    http://www.artisteer.com/?post…&p=forum_post&forum_id=20



    Jemand vielleicht noch einen Tipp oder IDee ? ?

    ich hab mal alles reverted...


    in jupgrade liegen alle dateien, auch bilder/videos von der webseite...

    /joomla_01 gibt die version im strato panel an... jedoch egal was ich mit dem verzeichniss mache,

    funktioniert alles ganz normal... (auch mit cleared browser cache usw)


    mich verwirren die joomla versions angaben.

    Pest das sagt sich so einfach ;)

    ich hab keinen plan von css....


    zumal ich das chaos nicht verstehe, was der exfreund da bei strato angerichtet hat bei der joomla installation.

    die Datenbank ist auf /joomla_01 angelegt, selbst wenn ich das verzeichnis auf dem server test-halber umbenenne läuft alles

    normal weiter, denn die sachen liegen alle auf dem server in /jupgrade , nur das verzeichniss bei Strato nirgends angelegt.


    und mit XAMPP kenn ich mich auch gar nicht aus....


    das muss erstmal alles so weiterlaufen, entweder muss ich mich da einlesen/einarbeiten oder wer anders muss das übernehmen.

    Hallo,


    kurze Vorgeschichte, Freundin hat eine Website bei Strato mit Joomla, leider noch mit einer UraltVersion 2.5.24.

    Das nächste Übel, auf der Website läuft noch php5.

    (Das hat damals alles ihr Ex-Freund eingerichtet und gemacht)


    Da Strato aber 5,33 Euro / Monat für den PHP5 Extended Support verlangt, wollte ich jetzt von PhP5 auf 7.x umstellen,

    was so gesehen auch klappt, aber dann funktioniert die Seite nicht mehr richtig, da Joomla scheinbar zu alt ist.


    Also hab ich mich die letzten Tage an dem Joomla Update versucht.... (Erstmal alles auf den PC gesichert vom Server... was schon 2x nützlich war ;) )


    Über die Erweiterungen / Installieren kann man kein aktuelles Joomla3 upgraden, das hab ich schon herrausgefunden. Ein Upgrade auf 2.5.28 über diesen

    Weg klappt aber, soweit bin ich. Ich bekomm jetzt aber kein Upgrade von v2.5.28 auf v3.x.x hin, da es über die Erweiterungen nicht funkioniert, es kommt dann immer ein

    XML fehler. In der Joomla Hilfe steht, das man über "Komponenten -> Joomla Update" machen kann, diesen Punkt gibt es aber bei mir garnicht.


    Ein manuelles Upgrade via .zip entpacken und per ftp übertragen scheint auch nicht zu klappen, danach ist die ganze Seite nicht mehr erreichbar.


    Hab daraufhin wieder das Backup per FTP einspielen müssen.


    Ich hab leider von Joomla überhaupt keine Ahnung.


    Könnt ihr mir ein paar kleine Hinweise geben, was zu tun ist, damit ich Joomla aktuell bekomme und damit auf PHP7 umstellen kann ?



    gruss und vielen Dank schonmal