Beiträge von Juergen

    Hi,

    hat jemand eine Idee wie ich eine der beiden Überschriften "Weitere Informationen" weiter unten im Formular wegbekomme?

    Im Menü-Punkt, in der Konfiguration und im Kontakt selbst kann man "weitere Informationen" anzeigen oder verbergen. Bei "anzeigen" oder "global(anzeigen)" erscheinen dann beide Überschriften.


    Mit Overrides habe ich noch keine Erfahrung. Habe es versucht, aber nicht hinbekommen.

    Vielen Dank.

    Hallo,


    ich bin nun seit mehreren Tag am verzweifeln. Habe auch ChatGPT nach dem richtigem Code / Lösung gefragt - geht aber nicht.

    Es soll auf dem Smartphone nur eine Spalte mit einer Card und auf einem iPad und größere Auflösung 3 Spalten mit Cards nebeneinander dargestellt werden. Den Code habe ich von kopiert:

    Hat jemand eine Lösung? Das Ändern der Klasse in

    Code
    "row row-cols-1 row-cols-md-3 g-4"

    hat auch nichts gebracht? Das Problem tritt bei einem 10 Jahre altem und einem 4 Jahre altem iPad Air auf ... ??

    Danke.

    Da fehlt noch der Ordner "mod_custom". Die Datei muss im Ordner "templates/dein-template/html/mod_custom" liegen.


    Also "templates/dein-template/html/mod_custom/carousel.php", dann sollte sie auswählbar sein

    Danke. Jetzt funktioniert es.


    Eine Frage noch: wo gibt es eine Anleitung zum Code schreiben für Overrides? Das ist doch ein Override, oder?

    Danke. Ich habe den Code in eine Datei mod_custom.php kopiert und im Verzeichnis des Child-Templates gespeichert - siehe Screenshot.

    Im Modul kann ich die Datei nicht nicht unter "Erweitert > Layout" auswählen ...?

    Hallo,

    ich versuche seit Tagen das Carousel von Bootstrap 5.3 in Cassiopeia zum Sliden zu bekommen.


    Dazu habe ich den Beispielcode von https://getbootstrap.com/docs/5.3/components/carousel/ in ein 'eigenes Modul' kopiert und nur bei scr=" ..." den Pfad zum Bild eingegeben (3x).

    Die Schaltenfläache sind wie in der Demo auf https://getbootstrap.com/docs/5.3/components/carousel/ vorhanden, aber wenn man draufklickt, passiert nichts.


    Code
    <div id="carouselExampleIndicators" class="carousel slide">
    <div class="carousel-indicators"><button type="button" data-bs-target="#carouselExampleIndicators" data-bs-slide-to="0" class="active" aria-current="true" aria-label="Slide 1"></button> <button type="button" data-bs-target="#carouselExampleIndicators" data-bs-slide-to="1" aria-label="Slide 2"></button> <button type="button" data-bs-target="#carouselExampleIndicators" data-bs-slide-to="2" aria-label="Slide 3"></button></div>
    <div class="carousel-inner">
    <div class="carousel-item active"><img src="images/fotos/slider_header/BAI_002191.JPG" class="d-block w-100" alt="..."></div>
    <div class="carousel-item"><img src="images/fotos/slider_header/BAI_002191.JPG" class="d-block w-100" alt="..."></div>
    <div class="carousel-item"><img src="images/fotos/slider_header/BAI_002191.JPG" class="d-block w-100" alt="..."></div>
    </div>
    <button class="carousel-control-prev" type="button" data-bs-target="#carouselExampleIndicators" data-bs-slide="prev"> <span class="carousel-control-prev-icon" aria-hidden="true"></span> <span class="visually-hidden">Previous</span> </button> <button class="carousel-control-next" type="button" data-bs-target="#carouselExampleIndicators" data-bs-slide="next"> <span class="carousel-control-next-icon" aria-hidden="true"></span> <span class="visually-hidden">Next</span> </button></div>


    Hat jemand eine Idee?
    Vielen Dank.

    Es könnte beispielsweise sein, dass die Seite, deren URL du verwendest, die Darstellung in einem IFrame verbietet. Siehe X-Frame-Options!

    Das solltest du über F12 im Browser ermitteln können! Sonst nenne einfach mal die URL!

    Die URL ist:

    Externer Inhalt www.youtube.com
    Inhalte von externen Seiten werden ohne Ihre Zustimmung nicht automatisch geladen und angezeigt.
    Durch die Aktivierung der externen Inhalte erklären Sie sich damit einverstanden, dass personenbezogene Daten an Drittplattformen übermittelt werden. Mehr Informationen dazu haben wir in unserer Datenschutzerklärung zur Verfügung gestellt.

    Teste über reines HTML, ob das iFrame überhaupt geladen wird. Gehts in einer statischen HTML-Datei?
    Iframes lade ich immer über ein eigenes leeres Modul per HTML.

    Ich habe an anderer Stelle mal versucht ein iframe zu integrieren. Irgendwie hat das mit den Editor-Einstellungen nicht geklappt. Deswegen hoffte ich, dass das Problem mit dem Wrapper-Modul nicht auftritt.


    Kann das evtl. etwas mit http security headers zu tun haben?

    Desweiteren:

    Hast du {loadmoduleid....} an der richtigen Stelle eingetragen (Editor-Text)?
    Stimmt die ID des Moduls?

    Funktioniert eine der anderen Varianten: https://docs.joomla.org/How_do…e_inside_an_article%3F/de

    Wird rein garnichts angezeigt oder vielleicht doch der Text {loadmoduleid....}?

    Die {loadmoduleid} ist an der richtigen Stelle. Ich lade in dem Artikel mehrere Module. Alle Inhalte werden angezeigt, außer vom Modul Wrapper.

    Hi,


    ich habe ein Modul vom Typ Wrapper erstellt und unter URL die komplette URL angegeben und dann das Modul über {loadmoduleid ...} in einen Artikel eingebunden.

    Es wird nichts angezeigt.

    Muss man bei diesem Modul etwas IFRAME-spezifisches beachten?

    Danke für Eure Tipps.

    Ich habe eine Lösung gefunden. Für den Fall, dass jemand das gleiche Problem hat:

    1. kleine SVG-Datei anlegen und per FTP hochladen
    2. unter SYSTEM > MEDIEN an folgenden Stellen diese Einträge ergänzen:
      a) zulässige Erweiterungen: svg
      b) gültige Bilddateiendungen (Dateitypen): svg
      c) gültige Dateitypen: image/svg+xml
    3. im Template-Stil unter Logo das hochgeladene SVG-Logo auswählen
    4. in die Datei user.css folgenden Code eintragen:
    Code
    /* Logo in Desktopansicht größer skalieren  */
    @media (min-width: 992px) {
    .brand-logo img{
    width: 15rem;
    }

    Mit rem steuert man, wie groß das Logo skalieren soll. Einfach verschiedene Werte ausprobieren.

    Hallo,

    ich bin dabei Cassiopeia für meine Zwecke anzupassen.

    Habe ein Logo (svg) hochgeladen und es sieht beim Desktop gut aus. Auf dem Smartphone, wie iPhone 12, ist es zu groß.

    Was muss ich machen, damit es auf dem Smartphone automatisch kleiner wird?

    Danke.

    Hallo,

    ich bin dabei Cassiopeia anzupassen und hätte gern, dass die Navigation beim runterscrollen verschwindet und beim hochscrollen erscheint. Ich habe hier

    den Code dazu gefunden:

    Navigation beim Runterscrollen verstecken, beim Hochscrollen anzeigen
    Eine Navigation, die beim Runterscrollen versteckt und beim Hochscrollen anzeigt wird, ist sehr beliebt. Mit JavaScript (jQuery) kann die Scrollrichtung…
    kulturbanause.de


    Wo muss ich den Code bei Cassiopeia ablegen?


    Danke.

    Hallo,


    ich habe das Joomshaper Template und den SP SpageBuilder gelöscht, da ich Cassiopeia nutzen und selbst anpassen möchte.

    Vom Cassiopeia Template habe ich ein Child Template angelegt und entsprechend Stile. Siehe Screenshots.


    Ich bekomme nun die Fehlermeldung "Error 500" und habe den Debug-Modus eingeschaltet, der anzeigt, dass das Template cassiopeia_iwfa nicht gefunden wurde. Siehe Screenshot. Hat jemand eine Idee? Danke.

    Hallo,


    ich hatte vor ein paar Jahren beim Aufbau der Website 4 Sprachen (DE - EN - FR - PT) angedacht und es so eingerichtet. PT (Portugiesisch) wurde jedoch nie gebraucht. Es gab also nie einen Artikel und eine Seite in Portugiesisch.


    Der Screenshot zeigt die Fehlermeldung und die anderen 2 die Einstellungen. Wie bekomme ich PT komplett weg?

    Danke.

    Hallo,


    ich hatte vor ein paar Jahren beim Aufbau der Website 4 Sprachen (DE - EN - FR - PT) angedacht und es so eingerichtet. PT (Portugiesisch) wurde jedoch nie gebraucht. Es gab also nie einen Artikel und eine Seite in Portugiesisch.


    Der Screenshot zeigt die Fehlermeldung und die anderen 2 die Einstellungen. Wie bekomme ich PT komplett weg?

    Danke.