Beiträge von saumhuhn

    Herzlichen Dank für die Ratschläge an Elwood und JoomlaWunder. Parallel zu euren Antworten bin ich auch schon auf FTP gekommen. Damit kriege ich die Datei natürlich hoch. Bin jetzt dabei den genauen Link einzugeben (Groß-Kleinschreibung!) dann sollte es klappen. Frage: Wenn hier was aufkommt in dem Forum, kriegen das die Entwickler von Joomla gesteckt? Z.B. dass die Möglichkeit bestehen sollte "mit Bordmitteln" MP3 hochzuladen?

    Schönen Tag wünsche ich!


    Ich möchte diverse MP3-Dateien auf meiner Website abspielen. Dazu gibt es im TinyMCE-Editor den Button "Medien". Da kann man tatsächlich eine MP3-Datei eintragen. Ich habe probeweise folgendes gemacht: Als Datei eine Datei auf meinem Desktop angegeben. Auf der Website erscheint dann ein kleiner, sehr netter Player, aber natürlich spielt er nicht meine Datei ab, denn er hat in den Link vorneweg selbsttätig https://sumeria.at/ eingetragen. Ihr kommt gleich drauf, warum ich das so gemacht habe. Jedenfalls wäre es leicht mögllich, hier einen Link auf ein Joomla-Medienverzeichnis einzugeben - theoretisch! Praktisch ist es aber so, dass unter "Medien" beim Versuch, eine MP3-Datei hochzuladen die Fehlermeldung kommt "Ungültiger Dateityp". Aha, dachte ich, dann ergänze ich halt in den Einstellungen die Dateitypen mit "MP3,mp3". Leider hat das keine Auswirkung - MP3 ist für Joomla immer noch ein ungültiger Dateityp. Was mache ich jetzt?


    Freundliche Grüße

    Saumhuhn

    Ich habe jetzt eine neue Installation "drübergebügelt!". Es hat aber nichts geholfen. Vermutllich wurden auch jetzt die vom Quelltext geforderten Verzeichnisse und Dateien nicht übertragen. Ist das jetzt ein echteer Fehler in BreezingForms?

    Danke. Das war verständlich. Aber was JohannesK gesagt hat, verstehe ich nicht: Warum soll ich Impressum/Datenschutz einbinden? Ich habe doch mein eigenes Impressum / meine eigene Datenschutzerklärung.

    ANstelle dessen, was Du schreibst, habe ich ein Ticket bei meinem Provider aufgemacht. Der hat es untersucht und schreibt mir:


    Sehr geehrter Herr W...,


    das Problem liegt nicht am PHP sonder an einer fehlerhaften Installation. Es kann einfach eine Datei nicht gefunden werden, da diese im entsprechenden Directory nicht existiert.

    siehe u.a.


    mfg

    Michael Böttger


    PS: in Ihrem Hosting unter Protokolle, können Sie diese Fehlermedung ebenfalls finden



    require_once(/var/www/vhosts/sumeria.at/httpdocs/components/com_breezingforms/images/captcha/../../../..//libraries/joomla/factory.php):
    failed to open stream:
    No such file or directory



    ==> logs/error_log <==

    [Mon Mar 23 18:33:25 2020] [warn] [client 91.141.1.131] mod_fcgid: stderr: PHP Warning: require_once(/var/www/vhosts/sumeria.at/httpdocs/components/com_breezingforms/images/captcha/../../../..//libraries/joomla/factory.php): failed to open stream: No such file or directory in /var/www/vhosts/sumeria.at/httpdocs/components/com_breezingforms/images/captcha/securimage_show.php on line 55, referer: https://sumeria.at/index.php/home/kontaktformular

    [Mon Mar 23 18:33:25 2020] [warn] [client 91.141.1.131] mod_fcgid: stderr: PHP Fatal error: require_once(): Failed opening required '/var/www/vhosts/sumeria.at/httpdocs/components/com_breezingforms/images/captcha/../../../..//libraries/joomla/factory.php' (include_path='.:/opt/plesk/php/7.3/share/pear') in /var/www/vhosts/sumeria.at/httpdocs/components/com_breezingforms/images/captcha/securimage_show.php on line 55, referer: https://sumeria.at/index.php/home/kontaktformular


    Kann jemand damit was anfangen? Wie kann eine Installation mangelhaft sein, wenn sie doch automatisch (vor 3 Tagen) geschieht?



    Gruß

    saumhuhn

    Ich hab schon was probiert in der Art. Meine eigene Lösung - so sie denn funktionieren würde - würde ich jedoch vorziehen. Es müsste doch (vielleicht mittels eines scripts?) möglich sein, meine Variable "spendenbetrag" mit dem PP-Button zu verbinden (wie oben beschrieben). Kann mir denn niemand dazu einen Tip geben?

    Ich habe mir die Konfiguration des Captchas in BreezingForms sehr genau angesehen. Da gibt es nicht viel einzustellen. Ich lasse jetzt nur noch von meinem Provider prüfen, ob die PHP-Installation die TTF-Unterstützung bietet, die man lt. Crosstech dazu braucht. Wenn es daran nicht liegt, geht es halt nicht. Aber auf Protostar möchte ich nicht umsteigen. Ich habe schon etliche Formulare mit BreezingForms gemacht.


    Trotzdem: Falls noch jemandem was einfällt, woran es noch haken könnte - ich bin für Hinweise dankbar.


    Freundlichen Gruß

    saumhuhn

    Also: Ich habe es versucht - keine Reaktion. ABER: Ich habe jetzt Crosstec's ENGLISCHE Anleitung gelesen. Und da ist die Sache ganz anders. Da steht nichts davon, dass man ein Betragsfeld mit dem Paypalknopf verbinden kann und dazu den Elementnamen benutzen soll. Dort steht sinngemäß: "Wenn Sie einen HTML5-Upload machen wollen..." Das dürfte was ganz anderes sein. Und deshalb dürfte das, was ich will, NIEMALS funktionieren. Seh' ich's richtig?


    Es ist zu blöd! In der Konfiguration hat der PP-Knopf eine Variable mit Namen "Amount". Da kann man den exakten Betrag, der an PP übermittelt werden soll, eintragen. Blöd nur, dass der User dann natürlich keinen eigenen Betrag bestimmen kann - wie ich es mit meiner Variablen "Spendenbetrag" vorgesehen hatte. Ich müsste also meine Variable auf die Variabel "Amount" übertragen - aber geht das???


    (Ich will eigentlich nicht immer mehr Erweiterungen implementieren. Aber wenn ich hier keine Lösung finde, muss ich mich doch nach einer Paypal-Spendenlösung umschauen, die flexibler ist. Ist eine als wirklich gut bekannt und dennoch kostenlos?)

    Ich habe mit BreezingForms ein Kontaktformular generiert. Das Captcha wird nicht angezeigt. Der Crosstec-Support führt zum Thema (den mich garantiert nicht betreffenden Teil lasse ich hier weg) aus: "Der häufigste Fehler ist aber das Fehlen von "True Type Font" (TTF) unterstützung mit Ihrer PHP Installation."


    Hört sich nett an. Ich dachte, alles, was gebraucht wird, ist bereits in Joomla "eingebaut". Jetzt untersuche ich meinen Rechner und finde überhaupt keine "PHP-Installation". Dann denke ich: Toll. Du als alter Programmierhase (SAP, Basic, EBUS) hast keine PHP-Installation. Lieschen Müller - als meine künftige Website-Benutzerin - wird dann auch keine haben und das Captcha auch nicht sehen können, oder? Komisch ist aber: Die Captchas auf den Crosstech-Seiten kann ich sehr wohl sehen - auch ohne PHP-Installation.


    Vielleicht bin ich ja irgendwie total auf dem Holzweg. Deswegen wäre ich um etwas Hilfe dankbar.


    Freundliche Grüße

    saumhuhn

    BreezingForms ist vermutlich eine Erweiterung, die nicht so selten benutzt wird. Deshalb hoffe ich, hier eine Lösung zu finden.

    Ich habe einen Paypal-Button eingebunden, hat auch zunächst funktioniert. Dann habe ich ein Feld über den PayPal-Button eingefügt vom Typ "select from list" und dem Namen "spendenbetrag". Der vom User dort ausgewählte Spendenbeitrag soll mit Klick auf den PayPal-Button an Paypal mit übergeben werden. Dazu schreibt Crosstec in holprigem Deutsch:


    "Wenn ihrer Formular einen Datei Element Typ hat, machen sie das folgendes:

    Stattdessen ff_validate_submit für den PayPal Knopf, benutzen Sie ein Spezialen Skript als ACTION CLICK mit diesem Code:


    ff_elementName_action(element, action)

    {

    switch (action) {

    case 'click':

    bfDoFlashUpload()

    break;

    default:;

    } // switch

    } // ff_elementName_action


    Machen sie sicher, dass die 'elementName' das gleiche als diese Elemente Name ist."


    Entsprechend bin ich so verfahren:


    Beim PayPal-Button (nicht beim Feld "spendenbetrag"!) habe ich "Type" auf "Custom" eingestellt. Bei "Create code framework" habe ich folgendes eingegeben:


    ff_spendenbetrag_action(element, action)

    {

    switch (action) {

    case 'click':

    bfDoFlashUpload()

    break;

    default:;

    } // switch

    } // ff_spendenbetrag_action


    Ich habe also genau nach Anleitung den Literalteil "elementName" zweimal durch "spendenbetrag" ersetzt. Ergebnis: Der Button funktioniert nicht. Und zwar egal. ob ich "Actions click" mit Häkchen belege oder nicht. Habe ich da etwas falsch verstanden? Wahrscheinlich liegt es daran, dass ich diese Programmiersprache (HTML? CSS? Javascript?) nicht beherrsche. Ich komme aus der SAP-Programmierung. Aber vielleicht geht jemand anderem sofort ein Licht auf, wie das gemeint sein könnte.


    Freundlichen GRuß

    saumhuhn

    Überraschung: Jetzt sind tatsächlich die Menüzuordnungen unten sichtbar. Ich habe alle Häkchen weggemacht und gespeichert. Ergebnis: Jetzt ist im Frontend der braune Balken nur noch sichtbar, wenn "Therapie" angeklickt wird. Ich hätte aber gern, dass der braune Balken überall besteht...


    Gruss

    Saumhuhn

    Danke für die anschauliche Führung. Bei mir (deutsche Version) sind die "Menüzugehörigkeiten" unter einem anderen Reiter. Aber es sind die gleichen Felder. Ich habe alle Häkchen herausgenommen. Geändert hat sich leider nichts im Frontend.