Beiträge von Ikke Selber

    Moin,


    ich will ja nicht die ganze Site so übernehmen, nur die Dateien unter "Kolumnensammlung". Das der Code nix taugt, ist mir auch klar. Diese alten Kolumnen werden aucgh so gut wie nie aufgerufen, sie sollen nur der Vollständigkeit halber "erreichbar" sein, falls doch mal Jemand eine alte Kolumne sucht. Daher wäre mir das Erscheinungsbild auch egal.


    Zitat

    Na ja, händisch halt. In jedem Editor hast Du doch die Möglichkeit, Links einzugeben.

    Ich kann Links auf Beiträge und Bilder setzen. Aber wie kann ich eine beliebige andere Datei verlinken?



    Gruß


    Norbert

    Moin,

    tja, der Verein hat ja nicht mal 20 Mitglieder. Das ist ein Archiv-Verein, der einen Schriftsteller, Kolumnisten und Wissenschaftler "begleitet". Eigentlich nur eine Handvoll "Fans" des Typen (bin ja auch so einer davon, kenne ihn halt schon seit Ewigkeiten, und wenn ich dann gefragt werde, bin ich mal wieder zu gutmütig, um NEIN zu sagen).

    Die alte Site ist die hier:

    Unter "Kolumnenarchiv" findet man die Kolumnen, um die es geht. Die ersten 35 hab ich schon manuell "umgebaut". Das ist auch durchaus machbar, aber die dem Menschen (und besonders mir) angeborene Faulheit sucht halt nach einem Weg, die "Fleissaktion" zu vermeiden. Und da dachte ich, Fragen kostet ja nix...

    Mir wäre es im Grunde auch egal, wenn ich die alten html-Dateien einfach intern verlinken und als, z.B. Liste anzeigen lassen könnte. Wer sich für die alten Sachen interessiert, soll sie sich dann eben im alten Design anschauen. Normalerweise werden eh hauptsächlich die aktuellen Kolumnen angeschaut. Und die werden ja "modern" eingepflegt.

    Es würde mir also auch schon reichen, eine Möglichkeit zu haben, solche html-Dateien in einer Liste darzustellen, und wer will, kann sich eine der Dateien anzeigen lassen. Aber selbst das hab ich bisher noch nicht hinbekommen (ist meine erste Site, die ich "so richtig" mit Joomla baue).


    Gruß


    Norbert

    Moin,

    Ich baue gerade eine fast 20 Jahre alte, statische Website in Joomla neu.

    Nun enthält die alte Site fast 400 Dateien, die im Grunde nur Text sind (sind Zeitungskolumnen). Diese möchte ich gern in Joomla-Beiträge umwandeln, ohne jede einzelne zu öffnen, den Text via Zwischenablage in einen neuen Beitrag ziehen und dann manuell abspeichern zu müssen.

    Gibt es Joomla-Erweiterungen, die so etwas halbwegs automatisiert bewerkstelligen können?

    Das einzige, was ich gefunden hab, ist "HTML 2 Articles". Allerdings ist das nicht kostenlos. Und der Verein, für den ich die Website baue, hat kein Budget für solche Tools... Abgesehen davon weiß ich ja auch im Voraus nicht, ob das das Richtige dafür wäre.

    Falls Jemand eine Idee hat, wäre ich sehr dankbar.


    Gruß


    Norbert

    Moin,

    jetzt hat sich ein neuer Fehler ergeben...

    Durch die geänderte Zeile 272 erhalte ich jetzt folgende Fehlermeldung (s.u.):


    Auch das hat keinerlei Einfluss auf die Funktionalität - stört doch aber ganz schön. Vor allem, wenn mal nicht ich, sondern sich einer meiner Editoren anmeldet, um Beiträge zu bearbeiten. Da seh ich jetzt schon die Panik-Anfragen vor mir, was er oder sie denn nun wieder falsch gemacht hat... ;-)



    Gruß

    Norbert






    Notice: Undefined property: ContentViewCategory::$item in C:\xampp\htdocs\TEST\plugins\system\t3\base-bs3\html\com_content\category\default_articles.php on line 272



    Notice: Trying to get property 'params' of non-object in C:\xampp\htdocs\TEST\plugins\system\t3\base-bs3\html\com_content\category\default_articles.php on line 272

    Moin,

    wie im Titel schon angedeutet, habe ich folgendes Problem:

    Wenn ich in einem Menü einen neuen Menüpunkt anlege und als Menüeintragstyp "Kategorieliste" wähle, wird mir im Frontend folgende Warnung angezeigt:


    Warning: Creating default object from empty value in C:\xampp\htdocs\TEST\plugins\system\t3\base-bs3\html\com_content\category\default_articles.php on line 17


    Auf die Funktion hat das keinen Einfluss, lediglich diese doofe Warnmeldung nervt.

    Hat Jemand eine Idee, was das sein könnte und viel wichtiger: Wie kriege ich das weg?

    Ach ja, das Problem tritt nicht auf, wenn ich die Website auf meinem Tablet laufen lasse, auf dem ein 32bit Windows läuft, nur beim PC mit 64bit (keine Ahnung, ob das eine was mit dem andren zu tun hat...).

    Wenn ich ein anderes Template nehme (z.B. Protostar), tritt das Problem ebenfalls nicht auf.



    Gruß


    Norbert


    (Falls ich im falschen Bereich gelandet bin, bitte verschieben).

    Mmh.... auch nicht hier: /xampp/mysql/data/...

    Moin,

    tja.... wenn man sich bei der Eingabe einer Suche vertippt....

    Ich hab die Datei gefunden - hilft aber nix.

    Und da ich ja keinerlei Veränderungen vorgenommen hatte, bevor plötzlich nichts mehr funktionierte, muss ich wohl davon ausgehen, daß ich irgendwie eine oder mehrere Datein gecrashed habe - wie auch immer das passieren konnte.

    Ich werde also wohl oder übel von vorne anfangen müssen.

    Trotzdem danke an alle, die versucht haben, mir zu helfen.


    Gruß


    Norbert

    Moin,

    ich hänge mich mal an diesen Threat dran, ich habe nämlich die gleiche Fehlermeldung wie Silke.

    Allerdings habe ich keinerlei Änderungen vorgenommen. Am vorherigen Tag lief alles. Am nächsten Tag wollte ich weitermachen.... und nix ging mehr.

    Den Tip von Dudlhofer bzgl. der configuration.php hab ich schon probiert - alle Pfade und DB-Einträge sind korrekt.

    Danach hab ich versucht, einen älteren Datenstand zu benutzen (einen vorher komplett gesicherten htdocs-Ordner) - die gleiche Fehlermeldung.

    Wenn ich in dieser xampp-Installation eine neue Test-Website installiere, funktioniert die einwandfrei.

    Langsam weiß ich nicht mehr, wo der Fehler liegen soll....


    Gruß


    Norbert