Beiträge von Tomolino

    Hallo,


    vielleicht kann mir bitte jemand helfen:

    Ich habe das Menü meiner Homepage https://tbo-computerservice.de geändert. Wie man sehen kann, gibt es (nun) den Menü-Punkt "Service-Leistungen", welcher aufklappbar ist und weitere Menü-Punkte anzeigt.

    Im Grunde funktioniert es so wie es soll.


    ABER: Wenn ich im Untermenü eine Seite anklicke, z.B. "Drucker-Service", dann lautet die URL "https://tbo-computerservice.de/leistungen/drucker-service".

    Ich möchte jedoch das "leistungen" aus der URL raushaben und kann einfach nicht rausfinden, wie ich das erreichen kann.


    Der Menü-Punkt "Service-Leistungen" mit dem Alias "Leistungen" ist im Hauptmenü nur eine Menü-Überschrift (siehe Screenshot) und mit keiner eigenen Seite verknüpft. Den Alias kann ich nicht löschen, lediglich abändern bzw. kürzen, was ich ja schon getan habe.

    Was kann ich tun, um den Alias ganz aus der URL rauszubekommen? Oder habe ich einen Denkfehler beim Aufbau des Menüs?


    Danke schonmal im Voraus!!

    Ich habe eine Grafik für einen Anruf-Button in meiner Seite drin, der (sinnvollerweise) nur in der mobilen Ansicht bzw. auf dem Handy sichtbar ist.

    Den habe ich nach einer Anleitung implementiert, die ich irgendwo im Internet aufgestöbert hatte. Es war also kein einfaches "Bild reinsetzen". Jedenfalls habe ich mit der Seite https://www.seobility.net/de/seocheck/ herausfinden können, dass es eben diese Grafik war, bei der der Tag fehlt.

    Da bin ich in den Page-Builder und habe im HTML noch den tag-Code angefügt. Ich kann es ehrlich gesagt schlecht erklären. Aber der Code lautet jetzt z.B. für den Anruf-Button auf der Startseite


    <p style="text-align: center;"><a href="tel:08920325700"><img src="images/anrufen.jpg" alt="tbo-computerservice anrufen" /></a></p>


    Ich hoffe es ist so verständlich bzw. nachvollziehbar.

    Ich bin gelassen! Aber unter "konstruktiver Kritik" verstehe ich etwas anderes! Wir sind hier im Joomla-Forum und nicht bei der Unternehmensberatung, oder?!

    Außerdem bin ich auch auf deine Ratschläge nicht im Geringsten angewiesen! Deinen Kommentar hättest du dir also getrost sparen können. Wieder mal nur noch mehr unnötiger (Foren-)Müll!


    P.S.: Außerdem stelle ich hier keine Fragen oder bitte um Hilfe, um mir daraufhin irgendwelche "konstruktive Kritik" anhören zu müssen, die mit der eigentlichen Fragestellung bzw. Thematik überhaupt nichts zu tun hat! Und ich denke mal, dass ich diesen Thread hier mit freundlichen Worten und einer freundlichen Bitte gestartet habe.

    Schade, solch sinnlose Diskussionen führen zu "müssen", wo es doch eigentlich und ursprünglich um ein ganz anderes Thema ging (siehe Überschrift).


    @ time4mambo:

    "Die Rechtsklicksperre schränkt die Usability stark ein. Das wiederum kann zu Ärger bei Besuchern der Website führen."

    Antwort: Das mag bei vielen Websites der Fall sein. Bei meiner sehe ich das nicht so! Zumindest wird die Usability nicht stark eingeschränkt! Meine Site lässt sich ohne weiteres mit Linksklick "bedienen"... Und das reicht! Übrigens: Ich selber benutze auch Mausgesten. Und wenn die mal auf irgendeiner Website nicht funktionieren, dann ist es eben so.


    "Es gibt auch gerade im barrierefreien Bereich Dinge, die mit der rechten Maustaste gemacht werden und wo du einen nicht geringen Prozentsatz User ausschließt."

    Antwort: Dieser Prozentsatz interessiert mich nicht!


    "Das solltest du - als guter Webentwickler - deinen Kunden auch mitteilen, wenn du sowas einbaust!"

    Antwort: Erstens habe ich nie behauptet, ein "guter Webentwickler" zu sein (wäre ich das, dann müsste ich wohl kaum solche Fragen wie hier im Thread bzgl. ALT-Attribut u.ä. stellen), und zweitens muss ich dem Kunden gar nichts mitteilen! Der Seiten-Besucher wird es schon merken, dass der Rechtsklick nicht funktioniert...


    "... aber für dich solltest du das einfach mal abprüfen und dich informieren, was du da eigentlich genau machst. Denn heutzutage izählt jeder Kunde!"

    Antwort: Ich habe das "abgeprüft" und mich informiert. Und nein: Für mich zählt (zum Glück) nicht jeder Kunde! Gott sei Dank bin ich in der "komfortablen Zone", sagen zu können, dass ich eben nicht auf jeden Kunden angewiesen bin!


    "Wenn der Browser die Site aufruft, wird das Bild automatisch in den Browser-Cache geladen . Das Bild liegt also in jedem Fall beim Besucher auf der Festplatte und somit ist die Rechtssperre völlig sinnlos. Und Text klauen... Welchen Text? Warum sollte den jemand übernehmen wollen?"

    Antwort: Anscheinend hast du meinen Post direkt über deinem nicht vollständig gelesen?! Darin steht: " Es geht einzig und allein darum, das einfache und schnelle "mal eben das Bild abspeichern" oder "mal kurzer Hand den Text rauskopieren" zu verhindern. Dass es letztlich immer eine Möglichkeit gibt, trotzdem den Text oder Bilder rauszukopieren, ist mir schon klar!" Und was den Text angeht: Es gibt einige Gründe, den rauskopieren zu wollen. Aber das muss ich dir nicht erklären.


    @ anka:

    "Na ja, die Webseite wird bei deaktiviertem JS des Browsers auch nicht angezeigt, da kann man die rechte Maustaste ruhig auch gleich sperren"

    Antwort: Ganz genau diese Leute, die JS in ihrem Browser deaktivieren, genau die will ich erst gar nicht als Kunden haben! Die sind mir ein Graus, weil das die (ich nenne sie so) Paranoia-Kunden sind! Die, die so viel in Ihrem System und im Browser deaktivieren, dass nichts mehr richtig funktioniert. Für mich die allerschlimmsten Kunden! Denen weine ich keine einzige Träne nach bzw. bin sogar froh, wenn sie von meiner Website wieder abspringen!!


    Und übrigens kann man sich auch solche Bemerkungen wie "Ist das ein Schweizer Unternehmen? hmm:D" sparen! Tut nämlich hier in Bezug auf die urspüngliche Thematik gar nichts zur Sache!


    So, noch irgendwelche Fragen? Oder ist der Thread jetzt genug zugemüllt?

    Vielen Dank für die Hinweise bzw. Erklärungen im ersten Absatz deiner Antwort!


    Zum 2. Absatz: Menschen, die sich über die Deaktivierung von Rechtsklick auf meiner Website "ärgern" oder dies als Schikane empfinden, können mir als Kunde gestohlen bleiben! Es geht einzig und allein darum, das einfache und schnelle "mal eben das Bild abspeichern" oder "mal kurzer Hand den Text rauskopieren" zu verhindern.

    Dass es letztlich immer eine Möglichkeit gibt, trotzdem den Text oder Bilder rauszukopieren, ist mir schon klar! Aber willst du wirklich mit mir darüber diskutieren?

    Meine Homepage ist in erster Linie für meine (zukünftigen) Kunden da, und nicht primär für Webmaster oder SEO-Experten, die meine Seite überprüfen wollen!


    Natürlich deaktiviere ich hier gerne solche Plugins, wenn es angebracht bzw. notwendig ist, um, wie hier, mal was zu analysieren. Ansonsten bleibt es bei der Rechtsklick-Sperre! Vielen Dank für dein Verständnis :)

    Hallo,


    ich bräuchte bitte noch mal eure Hilfe:

    Beim Durchsuchen meiner Homepage https://tbo-computerservice.de z.B. mit dem SEO-Analysator von bing bekomme ich die Meldung

    "Für das <img>-Tag wurde kein ALT-Attribut definiert."


    Dabei kann es sich eigentlich wohl nur um die Grafik im Header handeln. Da gehe ich jedenfalls von aus, denn im eigentlichen Content habe ich jeder Grafik ALT-Attribute zugeordnet (was auch im Pagebuilder Quix kein Problem ist).


    Jetzt habe ich alles durchsucht, um der Header-Grafik ein ALT-Attribut hinzuzufügen. Das kann ich jedoch in meinem Template (Astroid Framework von JoomDev) anscheinend nicht - zumindest nicht so ohne weiteres.

    Wäre bitte jemand so freundlich, und würde sich das mal auf meiner Seite anschauen und mir einen Tipp geben, wo da das ALT-Attribut fehlt und wie und wo ich das hinzufügen kann?


    Vielen Dank schon mal für eure Hilfe!!

    Oh, da legt man sich gerade mal ein Stündchen auf's Ohr, und dann sind hier schon 4 Antworten :-)


    Vielen Dank erst mal!

    Ich hab jetzt mal Firebug in meinen Fuchs installiert und (tatsächlich) der zeigt mir sogar "de-de" mit Gänsefüßchen an (siehe Screenshot). Und das auch auf allen Unterseiten.


    Heißt also mit anderen Worten, dass ich mir da keinen weiteren Kopf drum machen brauche, oder? Was soll ich da jetzt noch suchen und testen. Google wird es wohl richtig erkennen, denke ich.


    Auch folgende Aussage werde ich wohl ignorieren können: "Leiten Sie Anfragen mit und ohne www. auf die gleiche Seite per HTTP 301 Redirect weiter." Oder was meint die Fachwelt hier?

    Denn ich komme mit und ohne www immer auf meine Seite...


    Vielen Dank noch mal für eure Hilfe!


    Edit: Ich sehe gerade, dass die Sache in Google Chrome auch mit "de-de" angezeigt wird (siehe 2. Screenshot). Allerdings anders, sodass wohl sogar mehrfach die Sprache angegeben ist?!

    Hallo allerseits,


    nachdem ich meine neue Seite nun annähernd fertiggestellt habe, habe ich sie mal einem Online-SEO-Test unterzogen.

    Einige Dinge habe ich schon optimiert, einige muss ich noch...


    So wird mir z.B. (u.a.) angezeigt, dass die Sprache der Seite nicht erkannt wird. Genauer: "Die Sprache ist nicht im HTML Markup angegeben."


    Also meine Seite ist die hier: http://www.tbo-computerservice.de

    Die Seite mit der ich sie getestet bzw. analysiert habe, ist diese: https://www.seobility.net/de/seocheck/


    Dazu gibt es auch einen Tipp, was man diesbezüglich machen soll. Aber ich komm da nicht weiter. Hab schon gegoogelt und ausprobiert ohne Ende.

    Ich benutze das Template Astroid Framework von JOOMDEV und den Pagebuilder Quix von ThemeXpert (da will und werde ich auch nichts dran ändern).


    Könnte mir bitte jemand sagen, wie und wo ich da den HTML-Code, so wie hier beschrieben

    https://www.seobility.net/de/wiki/Sprache_einer_HTML_Seite

    einfügen kann? In Joomla selber habe ich alles auf Deutsch stehen und finde auch keine weitere Einstell-Möglichkeit.


    Vielen Dank in Voraus!

    P.S.: Ich habe die Sache übrigens noch weiter vereinfacht, indem ich den Ordner fontawesome (mit Fonts-Datei-Unterordner und css-Unterordner) direkt in das Stammverzeichnis gelegt habe. Somit ist der Pfad in der index.php meines Templates nur noch


    <link href="fontawesome/CSS/all.css" rel="stylesheet">

    Danke für den Tipp. Allerdings verstehe ich nicht, wo der Vorteil sein soll.

    Wenn ich weiß, wo die Fonts- und die CSS-Datei(en) liegen, dann ist ein direkter Pfad doch besser für das System. Warum sollte ich es bei jedem Seitenaufruf erst danach "suchen" lassen?

    So, hab's geschafft. Nach dieser Anleitung, die eigentlich für Wordpress ist: https://www.marjeta-prah-moses…-und-ueber-css-verwenden/


    Den dort angebenen Beispielpfad

    Code
    1. <link href="https://deinedomain.de/wp-content/themes/Divi-child/fonts/fontawesome/css/fontawesome-all.css" rel="stylesheet">

    musste ich in meiner Xampp-Installation in


    <link href="http://localhost/tbo_computerservice/templates/astroid_template_zero/fonts/fontawesome/css/all.css" rel="stylesheet">


    abwandeln und wieder in Zeile 41 der index.php einfügen (also da, wo die ursprüngliche Verlinkung zur Font Awesome-Homepage war. Jetzt werden alle Icons perfekt dargestellt.


    Danke nochmal!