Beiträge von jooforfun

    1. Du musst in jedem Fall das "RewriteEngine on" in der .htaccess haben und zwar in der Reihenfolge, wie es auch in der htaccess.txt steht.

    Ok. Es sei an dieser Stelle noch erwähnt, daß bei Aktivierung der SEO "Suchmaschinenfreundliche URL" OHNE "URL-Rewrite nutzen", die Beiträge schon nicht richtig aufgerufen werden. Es erscheint dann 404 Error. Ich komme aber wenigstens auf meine AdminSeite. Es ist besser sich erst darum zu kümmern?

    2. Ich gehe davon aus, dass deine Seite mit deiner originalen .htaccess (wie du sie bezeichnest) läuft

    Die Seite läuft mit den weiter oben gepostenen Inhalt. Auch dann, wenn ich in der Datei alles raus lösche, also eine leere .htaccess-Datei benutze.


    Globale und lokale PHP-Version dürfen beispielsweise nicht auf dem gleichen Wert stehen.

    Ich habe bisher nirgends eine Option gesehen bei der man einen Wert auswählen kann. Meinst du eine spezielle Konfigurationsdatei?

    Was passiert, wenn du diese Einträge alle mal entfernst?

    Ich bereits erwähnt, läuft die Webseite selbst mit leerer .htaccess Datei

    3. Hast du mittlerweile überprüft, ob mod_rewrite überhaupt funktioniert?

    Ich habe die von Dir vorgeschlagene Methode benutzt. Also genauso wie es dort beschrieben wird. Das Ergebnis ist dass die Homepage normal geladen wird, es gibt also kein "activated" .

    Du könntest auch in der configuration.php den Wert 'rewrite' auf '0' setzen, vielleicht klappt es ja:

    Gerade einmal nachgeschaut. Der Wert 'rewrite' ist bereits auf '0'


    RewriteBase sollte aber eigentlich keinen 500er erzeugen, sondern führt eher dazu, dass man beim Aufrufen von Menüpunkte einen 404 erhält.

    Ich hatte mir gedacht, ob es nicht sinnvoll wäre nur einen Teil der htaccess.txt in die .htaccess zu übernehmen. Also etwa nur den folgenden Bereich und den anderen Teil, der laut Kommentar nur common exploits behandelt, außen vorläßt. Ergebnis: 500er Error


    # RewriteBase /


    ## Begin - Joomla! core SEF Section.

    #

    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    #

    # If the requested path and file is not /index.php and the request

    # has not already been internally rewritten to the index.php script

    RewriteCond %{REQUEST_URI} !^/index\.php

    # and the requested path and file doesn't directly match a physical file

    RewriteCond %{REQUEST_FILENAME} !-f

    # and the requested path and file doesn't directly match a physical folder

    RewriteCond %{REQUEST_FILENAME} !-d

    # internally rewrite the request to the index.php script

    RewriteRule .* index.php [L]

    #

    ## End - Joomla! core SEF Section.

    Aufgrund der Warnung bei der Option "URL-Rewrite nutzen" habe ich mich strikt nach Vorgabe gehalten. Denn dort steht für Apache Server erst die .htaccess Datei modifizieren und dann im Backend "URL-rewrite nutzen" aktivieren. Nur leider komme ich nicht mehr ein meine Admin Seite nachdem ich meine .htaccess modifiziert habe, es kommt sofort die oben erwähnte Fehlermeldung.

    Erstmal herzlichen Dank für Eure schnellen Antworten.

    Ist denn mod_rewrite überhaupt in der PHP bzw Serverumgebung installiert und aktiv?

    Ich dachte allein schon mit Erstellung der .htaccess Daei wird mod_rewrite aktiviert. In den Systeminformationen -> php-Informationen kann ich keine Erwähnung von mod_rewrite finden. Nach einigen googlen gibt es noch die Idee mod_rewrite per folgenden Befehl zu aktivieren, weiß aber nicht wie sinnvoll das ist:


    a2enmod rewrite


    und dann Apache Server neustarten mit


    /etc/init.d/apache2 restart


    Setze die Zeile mit DirectoryIndex mal als Kommentar, also mit # davor!

    Wozu soll die dienen?


    EDIT: Und für welche Joomla-Version benötigst du PHP 5.6?


    Habe die entsprechende Zeile auskommentiert und das Laden der Seite läuft trotzdem problemlos. Also daran kann es nicht liegen.

    Ich habe einen ApacheServer mit der Version 2.2.34 und eine PHP Version 5.6.39

    Bei den Versionen bin ich immer von Synology abhängig, da nur Synology verzögert Updates herausbringt.


    Gerade eben habe ich noch versucht hinter RewriteBase /{den Pfad meiner Joomla Installation} einzufügen, aber ohne Erfolg.


    Also wie folgt:


    RewriteBase /volume1/web/joomla

    Hallo liebe Joomla Gemeinde,


    Ich stehe vor einem Problem und komme einfache nicht weiter. Ich habe schon vieles ausprobiert, aber ich komme zu keiner Lösung. Es geht um die Erstellung von Suchmaschinenfreundlichen URLs auf meiner Homepage. Zentraler Dreh- und Angelpunkt ist wohl die htaccess Datei. Wenn ich ein mein Joomla Verzeichnis wechsele sind aber von Beginn an zwei Dateien vorhanden


    - htaccess.txt

    -.htaccess


    Deshalb habe ich den Inhalt der .htaccess mit dem Inhalt txt-Datei ergänzt. Sobald ich die Datei abspeichere kann ich nicht mehr auf die Administrator Seite und eine Fehlermeldung (500 Internal Server Error). Wenn man sich die .htaccess-Datei ansieht, dann ist als zusätzliche Zeile DirectoryIndex index.htm angegeben. Alle anderen Zeilen finden sich auch in der htaccess-Datei.


    Bisher habe zwei Varianten durchgetestet.


    # RewriteBase / (Kommentarzeichen entfernt)

    Options +FollowSymlinks (auskommentieren)


    Beides ohne Erfolg. Hat jemand eine Idee?



    Der Inhalt meiner originalen .htaccess-Datei lautet:


    # Synology PHP

    AddHandler default-handler .htm .html .shtml

    AddHandler php-fastcgi .php

    AddType text/html .php

    Action php-fastcgi /php56-fpm-handler.fcgi

    # Synology PHP

    DirectoryIndex index.htm <<<<<<<<<<<<<< zusätzliche Zeile!






    Der Inhalt meiner originalen htaccess.txt Datei lautet:


    So, jetzt akzeptiert der Editor den Code und wird auch geladen so wie es sein soll. Es lassen sich sogar mehrere Iframes nebeneinander anordnen. Endlich. Letztendlich lag es an den Browsereinstellungen meines Firefox. Also unter Einstellungen -> Datenschutz und Sicherheit -> Standard auswählen. Außerdem müssen bei Laden der Webseite auch die Cookies akzeptiert werden.

    Vielen herzlichen Dank für Eure Bemühungen :)

    Ich habe mich per SuperUser angemeldet und dort ist die Textfilterung auf "Aus" gestellt. Dann habe ich den Schalter "Joomla-Textfilter auf "ja" umgestellt und nun sollte nichts mehr gefiltert werden. Das Problem bleibt aber weiterhin bestehen. Im Editor ist auch ein iframe erkennbar, leider ist die Verbindung zum Amazon Server unterbrochen. Es erscheint dann die Nachricht (innerhalb des iframe):


    Überprüfen sie die Verbindung zum Server http://ws-eu.amazon-adsystem.com/

    Moin,

    nein, die Modul Variante habe nicht genutzt, sondern ich habe ganz normal den html Code in den Beitrag eingefügt. Den Dummy Text habe ich bei den verbotenen Elementen auch beachtet. Der einzufügene Code lautet wie folgt:


    <iframe style="width:120px;height:240px;" marginwidth="0" marginheight="0" scrolling="no" frameborder="0" src="//ws-eu.amazon-adsystem.com/widgets/q?ServiceVersion=20070822&OneJS=1&Operation=GetAdHtml&MarketPlace=DE&source=ac&ref=qf_sp_asin_til&ad_type=product_link&tracking_id=..............................................................................................................................................................................................&show_border=false&link_opens_in_new_window=false&price_color=333333&title_color=0066c0&bg_color=ffffff">

    </iframe>


    Was auch noch erwähnenswert ist, daß ich über das Backend die Joomla Server nicht erreiche kann, wenn ich beispielsweise eine Erweiterung über den Webkatalog installieren will. Meine Joomla Installtion läuft über eine Synology. Liegt des daran?

    Moin,

    ich habe Joomla nun soweit gebracht, daß der Editor iframes akzepiert. Voraussetzung war


    1. unter Erweiterungen -> Plugins -> Editor TinyMCE -> Voreinstellung 0 -> Verbotene Elemente -> alles löschen

    2. System -> Konfiguration -> Textfilter -> Administrator/Super Users -> auf keine FIlterung setzen


    Im Moment liegt der Fehler noch beim Laden der Elemente im Iframe, der Editor kann also keine Verbindung zum Server von Amazon aufbauen. Hat jemand noch eine Idee?

    Moin,

    ich bin soweit gekommen dass der Editor nur bestimmten, einfachen Code akzeptiert. Aber einen komplexeren Code wird von Editor abgewiesen. Der Grund dafür könnte sein, daß es sich um einen Iframe handelt. Ich meine ich hätte gelesen, daß man diesen erst noch erlauben muss. Habe aber bisher keine Schaltfläche dafür gefunden. Wie kann ich denn den Code bereinigen? Der Wechsel zu einem anderen Editor brachte übrigens nichts.

    Moin erstmal,

    Danke für Deine so schnelle Antwort. Leider hat das nicht geklappt den Code einzufügen. Auch über den Menüpunkt Werzeuge -> Quelltext einfügen scheint der Editor nicht zu akzeptieren. Bei "Codebeispiel einfügen" macht er zwar Syntax Highlithting aber beläßt es beim Text und lädt nichts nach.

    Ich habe gehört dass man den Standardeditor wählen kann, hilft das etwa? Momentan nutze ich den TinyMCE.

    Hallo liebe Joomla Gemeinde,

    vor Kurzem habe ich mich beim Amazon Partnerprogramm angemeldet, um Werbung auf meiner Webseite schalten zu können. Leider weiß ich nicht, wie man den zur Verfügung gestellten Link/html Code in meinen Beitrag in Joomla einfügen kann, so daß dort der entsprechende Link mit Produktbild erscheint. Hätte da jemand eine Idee?