Beiträge von rimsail

    Hallo,

    habe jetzt einiges ausprobiert, aber leider keinen Erfolg.


    Zuerst der Tipp von JoomlaWunder.
    xampp/mysql/bin/mysqld --skip-grant-tbale ausgeführt. Funktioniert.
    mysql gestartet: ERROR 2002 (HY000): Can't connect to MySQL server 'localhost' (10061)
    Das beschriebene Fenster wird deshalb nicht geöffnet.


    Dann alle möglichen Varianten von xampp-control.exe als Administrator (der ich sowieso bin) ausgeführt.
    Befehl wird ausgeführt, aber MySQL produziert gleichen Fehler wie vorher.


    Dann XAMPP in VM installiert, Hoffnung, dass die Registry in der VM "rein" ist.
    Bei Startversuch von MySQL haargenau die gleiche Fehlermeldung erhalten wie im Host.


    Ich weiß nicht weiter.
    Dann halt kein Testsystem.


    Gruß
    rimsail

    Hallo,

    Ich habe jetzt leider ein neues Fehlerbild: MySQL bricht ab!
    habe den Rechner ein paar mal aus- und wieder eingeschaltet (!) und dabei auch denApache und MySQL gestartet und gestoppt.
    Und dabei hat sich folgende Fehlermeldung ergeben die ich jetzt immer erhalte wenn ich MySQL starten will:

    ---------------------------------------------------------------

    22:20:50 [main] Initialisere Control Panel

    22:20:50 [main] Windows Version: Enterprise 64-bit

    22:20:50 [main] XAMPP Version: 7.4.8

    22:20:50 [main] Control Panel Version: 3.2.4 [ Compiled: Jun 5th 2019 ]

    22:20:50 [main] Dein Benutzerprofil besitzt keine Administratorenrechte! Das reicht aus für die meisten

    22:20:50 [main] Anwendungsfunktionen, aber wann immer du etwas mit Windows-Diensten tun möchtest,

    22:20:50 [main] wird eine Sicherheitsabfrage erscheinen oder etwas wird garnicht erst funktionieren!

    22:20:50 [main] Also denke daran diese Anwendung mit Administratorrechten zu starten!

    22:20:50 [main] XAMPP Installationsverzeichnis: "c:\xampp\"

    22:20:50 [main] Voraussetzungen werden geprüft

    22:20:51 [main] Alle Voraussetzungen sind erfüllt

    22:20:51 [main] Initialisiere Module

    22:20:51 [main] Starte Check-Timer

    22:20:51 [main] Control Panel bereit

    22:23:00 [Apache] Versuche Apache zu starten...

    22:23:00 [Apache] Statusänderung erkannt: gestartet

    22:23:03 [mysql] Versuche MySQL zu starten...

    22:23:03 [mysql] Statusänderung erkannt: gestartet

    22:23:08 [mysql] Statusänderung erkannt: gestoppt

    22:23:08 [mysql] Fehler: MySQL wurde unerwartet beendet

    22:23:08 [mysql] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,

    22:23:08 [mysql] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.

    22:23:08 [mysql] Drücke den Logs Button um error logs zu sehen und prüfe

    22:23:08 [mysql] im Windows Event Viewer für weitere Hinweise

    22:23:08 [mysql] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters

    22:23:08 [mysql] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.

    -----------------------------------------------------------------

    Es würde mich sehr freuen, wenn jemand dazu einen Tipp geben kann

    Viele Grüße
    rimsail

    Hallo,

    ich habe inzwischen
    1. XAMPP über "Programme deinstallieren" komplett gelöscht
    2. Alle backups gelöscht (bzw. auf eine USB-Platte ausgelagert)
    3. XAMPP mittels Installer auf c: neu installiert
    4. mit akeeba kickstart joomla 3.9.19, das vorher auf STRATO lief, restored
    So jetzt läuft wieder alles.
    Nach meinen bisherigen Erfahrungen warte ich mal ab, ob das auch in ein paar Tagen bzw. nach Neustarts von WIN10 immernoch läuft.

    Aber jetzt erst mal vielen Dank an alle Supporter.

    Herzliche Grüße

    rimsail

    Hallo JoomlaWunder,

    schon mal vielen Dank für Deine Antwort.
    ich verwende XAMPP-windows-x64-7.4.6-0-VC15.

    Ich habe zwei virtuelle Festplatten, Laufwerk c: und d:.
    Das Problem ist das erste Mal aufgetreten, nachdem ich xampp zusätzlich auf dem Laufwerk D: zusammen mit joomla installiert hatte.
    Das habe ich inzwischen rückgängig gemacht und alle wieder auf c: installiert.
    Aber vielleicht gibt es irgendwo "Reste" dieser Installation. Keine Ahnung ob das weiter führt.
    Werde derweil mal eine neue Installation aufsetzen.

    Herzliche Grüße
    Reinhold

    Hallo,
    ich habe Joomla 3.9 unter XAMPP auf Win10 Pro mittels akeeba kickstart aus einer vorherigen Installation unter Win7 restored.
    Nachdem der restor erfolgreich ablief und ich joomla problemlos benutzen konnte, bekomme ich nach "einiger Zeit", also nachdem ich den PC nach Tagen mehrfach hoch und runter fahren lies, folgende Fehlermeldung:

    Warning: session_start(): Failed to read session data: user (path: C:\xampp\tmp) in C:\xampp\htdocs\joomla1\libraries\joomla\session\handler\native.php on line 260
    Error: Failed to start application: Failed to start the session

    Ich habe joomla jetzt schon mehrfach restored. Immer lief es ein paar Tage und dann, aus nicht erkennbarem Grund, erhalte ich die Fehlermeldung.
    Ich benötige die Installation unter XAMPP als Testumgebung für meine Vereinswebsite.

    Ich hoffe, jemand kann mir einen Hinweis geben, wie ich joomla mit XAMPP unter WIN10 zuverlässig zum Laufen bekomme.

    Mit freundlichen Grüßen
    Reinhold