Beiträge von gindi35510

    Danke für den LInk. Das ist mir bekannt. Ich komme ja auch dauerhaft ins backend rein wenn ich vorher in der Datenbank das gleiche Passwort mit MD5 speichere. Es scheint nur an der Art zu liegen wie das Passwort gespeichert wird.

    Um zu klären ob das an meinem Computer oder an Joomla liegt habe ich das Joomla 4.0.3 Installationsprogramm auf meinen Laptop heruntergeladen und installiert. Die Betriebssysteme auf beiden Computern sind identisch und auf dem gleichen Aktualisierungsstand und auf Beiden läuft LAMP.

    Die erste Installation war erfolgreich, ohne Fehlermeldung. Im Loginpanel war aber mein Username mit Passwort voreingestellt. Nachdem ich den Usernamen und das Passwort vom Admin eingetragen habe, hatte ich Zugang zum Backend und habe die deutsche Sprache installiert.

    Das gleiche passierte bei der zweiten Installation. Hier habe ich die deutsche Sprache nicht installiert.

    Bei der dritten Installation habe ich auf der ersten Seite die Installationssprache auf englisch gelassen. Nachdem ich die voreingestellten Userdaten im Loginpanel auf auf die Admindaten geändert habe, kam die Meldung "Username and password do not match or you do not have an account yet".

    In der configutation.php von allen drei Installationen ist mir aufgefallen, daß die Custom Message dort in deutsch gestanden hat, egal ob deutsch installiert war oder nicht.

    Auf welche Daten greift Joomla bei der Installation zu?

    Gruß gindi

    Das migrieren und updaten meiner Website von Joomla 3.9.28 über Joomla 3.10.2 zu Joomla 4.0.3 auf meinem localhost funktioniert ohne Probleme.

    Jetzt will ich die Website mit Joomla 4.0.3 auf dem localhost neu aufsetzen und habe dazu Joomla 4.0.3 Stable Full Package von der Joomla Website herunter geladen und installiert.

    Nach der erfolgreichen Installation wollte ich ins Backend gehen und habe im Loginpanel den Usernamen vom Superadmin und das Passwort eingegeben.

    Dann kommt die Meldung:

    Warning

    Username and password do not match or you do not have an account yet.

    Ich habe mehrfach die Installation und die Datenbank-Einträge gelöscht und alles von vorne neu gemacht. Immer mit der gleichen Fehlermeldung.

    Ich bekomme nur Zugang zum Backend wenn ich in der Datenbank den Superadmin bearbeite und das gleiche Passwort wie bei der Installation mit MD5 im Klartext eingebe und speichere.

    Danach komme ich problemlos ins Backend.

    Liegt es an meiner localhost Installation oder gibt es einen versteckten Fehler in Jooma 4.0.3?

    Mein Webserver:

    • Apache
    • Datenbank-Client Version: libmysql - mysqlnd 7.4.24
    • PHP-Version: 7.4.24

    Mein Datenbank-Server:

    • Server: Localhost via UNIX socket
    • Server-Typ: MariaDB
    • Server-Verbindung: SSL wird nicht verwendet Dokumentation
    • Server-Version: 10.5.12-MariaDB - MariaDB package
    • Protokoll-Version: 10
    • Server-Zeichensatz: UTF-8 Unicode (utf8mb4)

    Scheinbar hat noch niemand das gleiche Problem gehabt.

    Gruß gindi