Beiträge von deltapapa

    Moin Moin,

    da ich aus all meinen Seiten das Google ReCaptcha ausbaue, wollte ich mal fragen, was ihr als alternative für das J! Frontend Login so nutzt.

    Ich habe im Moment die ECC+ Erweiterung von Viktor Vogel eingebaut, mit einer Mathe - Prüfung. Funzt soweit ganz gut (bis auf die Einstellung "Input verschlüsseln), das klappt leider nicht), aber ist von der Anwendung natürlich nicht ganz so komfortabel.

    In JSN Uniform wird das Recaptcha über Secure Image umgesetzt, was mir vom UX her etwas besser gefällt.

    Ich habe nun das Plugin SecurImage Captcha Plugin von idealextensions.com endeckt, für die 7$ ja ein Schnäppchen, 100 % DSGVO konform (laut Entwickler -Forum).

    Hat das jemand im Einsatz? Kann vllt jemand von Euch Erfahrungen von der Erweiterung / dem Developer schildern.

    Ich tue mich halt immer schwer, noch eine zusätzliches Plugin zu installieren.

    Und bei den Anwendungen von Viktor weiß ich halt, wo es her kommt. Vllt könnten wir uns auch zusammen tuen, und Viktor baut und die Funktion Secure Image in das ECC mit ein? :saint:


    WBR,

    deltapapa

    Moin,
    ich bin auch exakt von dem Problem betroffen, das die Liste der immer selben angemeldeten User wird immer länger. Auch kommt es zu Problemen beim Anmelden im BAckend.
    Wenn ich auf Session -> PHP gehe ist das Prob augenscheinlich gelöst.
    Aber ist das zu empfehlen? Oder ist es besser das auf Datenbank zu lassen und den Hoster zu bitten auf
    session.gc_probability = 1
    umzustellen.
    Es gibt ja auch ein Plugin von Viktor Vogel für diese Problematik, hat jemand von euch das evtl im Einsatz: https://joomla-extensions.kubi…y-session-killer/joomla-3
    Und wie sieht es bei euch mit der Performance aus?


    Vielen Dank und viele Grüße,
    Dirk

    Moin Moin,
    sorry das die Rückmeldung so lange gedauert hat.
    Nach meinem Post hier gingen zeitgleich die Zugriffe fast gegen 0, nichts in den Server Logs und auch nichts in den Admin Tools Logs.
    Daher habe ich erst einmal abgewartet, aber es bleibt auch im Moment sehr ruhig.
    Kurze Frage Christiane, wie kann ich das als Umleitungsregel definieren? Ich habe darüber irgendwie nichts gefunden. Ich hätte jetzt gedacht vllt in etwas so:
    /wp-admin* auf zB blöd.de umleiten oder sowas.


    Viele Grüße,
    Dirk

    Moin,
    erst mal vielen dank für die Infos. Ich habe noch einmal nachgeschaut, es sieht so aus:

    also wp-admin bzw wp-Content.
    So sieht es in der Übersicht aus:


    Und es sind sehr viele verschiedene URLs aus allen Ländern der Welt....
    Wie setze ich so eine fail2ban Regel? Kann ich sowas auch in Plesk machen?


    Viele Grüße,
    deltapapa

    Moin Moin,
    ich habe auf einer Seite sehr viele Zugriffe (seid Jahresbeginn über 2000) mit immer demselben Schema. Ich bekomme eine Meldung von den Admin Tools / myjoomla, das versucht wurde ein Datei hochzuladen, und das eben geblockt wurde (UploadShield)
    Es kommt dabei immer von unterschiedliche IP, und sehr viel verschiedenen. Die Versuche haben allerdings immer eins gemeinsam: Es wird immer versucht, bestimmte URLs aufzurufen, praktisch als Luckypunsch mit sehr viel verschieden (WP) Komponenten. Die Domain hat immer ein /wp-login/ dazwischen.
    Kann ich das irgendwie von vornherein unterbinden, bzw alle URLs mit dem Inhalt wp-Login ausschließen?
    Geo Blocking in den Admin Tools hat nichts gebracht.


    Vielen Dank und viele Grüße,
    deltapapa

    Hi,
    das ist genau mein Problem: Meinem Modul - Menü die Klasse zuweisen okay, aber wie sage ich joomla das es die css Klasse vom Uikit z.B. für den aktiven Menüpunkt nehmen soll.

    Lol, da scheint ja überall der gleiche Trend im kommen! Ich war jetzt viele Jahre mit den Joomlashine Templates sehr zufrieden, das Preis / Leistungsverhältnis ist überragend (wenn man sich einmal im Sale das Dev Paket zugelegt hat) und man bekommt sehr schnell gute und flexible Ergebnisse. Jedoch sind die Jungs mit ihrem neuen SUN Framework völlig an den Bedürfnissen der Anwender vorbei developed! Es ist ja toll, einen Pagebuilder im Template zu integrieren, aber nicht ein altes Template lässt sich sorgenfrei migrieren, die neuen Templates sind extrem buggy und der support ist extrem langsam geworden. Beispiel: Es gibt mindestens 4 Stellen, an denen sich die Schrift anpassen lässt, die Grundeinstellung der Fonts ist aber nach über 8 Versionen noch immer ohne Funktion. Seid über 3 Wochen komme ich nicht mehr im BE in die Template Einstellung etc.
    Ich habe wirklich viele dutzende Bugs gemeldet, und meist wird dann erstmal in einem völlig anderen Zusammenhang nach irgend etwas anderem gefragt, der Thread nur überfolgen. Und dann läuft es immer darauf hinaus, das man die Zugangsdaten rausrücken soll. Leider installieren die Jungs dann auch mal gerne komische Sachen, die dann in einer produktiven Seite wirklich nichts zu suchen haben.
    Also JSN ist im Moment überhaupt keine Empfehlung, leider.
    Ich bin jetzt angefangen, eigene Templates zu erstellen, aber eigentlich ist das nicht für nebenbei, die Möglichkeiten sind einfach zu komplex.
    Klar, mit ein bisschen Lektüre und dem einen oder anderen Tutorial (das bei Video2Brain gefällt mir sehr gut) kommt schon was raus, aber ist die Zeit für vernünftige Ergebnisse sehr lange.
    Ich fand die Idee, ein eigenes Template zu basteln, und das mit Uikit dann zu pimpen ganz gut, nur leider gibts überhaupt keine Doku um z.B. damit ein schönes Menü zu erstellen.
    Schade. Da muss ich sagen gefällt mir WP ein Tick besser, da gibts zumindest jedes Jahr ein neues Template (ja, auch wenn die alle gleich aussehen :)

    Moin Moin zusammen,
    ich versuche, mich in die Template Erstellung einzuarbeiten. Dazu möchte ich gerne das Uikit Framework in mein Template integrieren.
    Bei meinen ersten versuchen habe ich css Dateien folgendermaßen eingebunden:

    PHP
    <?php JFactory::getDocument()->addStyleSheet($this->baseurl . '/templates/' . $this->template . '/css/dpcustom.css'); ?>


    In der Uikit Docs steht es aber nur so beschrieben:

    Code
    <link rel="stylesheet" href="css/uikit.min.css" />
            <script src="js/jquery.js"></script>
            <script src="js/uikit.min.js"></script>
            <script src="js/uikit-icons.min.js"></script>


    Das in den head Bereich und fertig. macht ihr das auch so? Und könnte ich nicht den PHP Code von meinem ersten Beispiel nehmen und das auf die Uikit css Dateien abändern? Dann ist natürlich die Frage, wie ich das bei den js Dateien mache.
    Vielleicht kann mir da jemand auf die Sprünge helfen,


    vielen Dank,
    deltapapa

    Hi Lars und willkommen im Forum.
    Ich würde als erstes die Seite vom Netz nehmen, am besten mit einem htaccess Schutz auf das ganze Verzeichnis.
    In deinem Joomla schlummert eine sehr schwere Sicherheitslücke, die es jedem ermöglicht der ein wenig Englisch kann, diese auszunutzen und die Kontrolle über dein System zu übernehmen. (http://www.joomla.de/news/28-j…um-das-update-wichtig-ist)
    Dann das Update machen ;)
    Zu dem Fehler: Hast du es mal mit einem neuem Download versucht? Da ist irgendwie das Update - Archiv kaputt.


    Cheers,
    deltapapa

    Hi,
    auch das muß andere Gründe haben. Also, Joomla! out of the box speichert Content in einer Datenbank. Dieser Content wird dann zur Anzeige gebracht. Verschieden Tools wie der JCE überprüfen vor dem speichern, ob das was da rein geschrieben werden soll, auch den Rechten des Users entspricht, bzw ob dieser Text / Code zuläassig ist. Diese Einstellungen sind unter Erweiterungen/JCE Editor/Editor Profiles/Default/Plugin Parameters/Media Support sehr gut versteckt.
    Ich glaube der TinyMC hat das in den Plugin Einstellungen.
    Auch Joomla selber filtert diese Eingaben nochmal, zu finden unter System / Konfiguration / Textfilter.


    Wie hast du die index.php editiert? In Joomla! selber oder via FTP auf deinem Rechner?
    BTW, ich würde aich nicht unbedingt den Code Hard codiert ins Template schreiben, der ist nach einem Update dann nämlich wieder weg ;)


    Viel Erfolg,
    deltapapa

    Hi,
    habe ich das richtig gelesen in dem Screenshot, das du da ein paar TB über den Server schaufelst?
    Das schheint mir dann doch recht viel.
    Wie sind denn deine Zugriffszahlen, wieviel Power hat dein Server?
    Im Firebug hast du gleich zu Anfang eine sehr lange get Anfrage, über 4 Sekunden. Das ist defenitiv langsam, bei mir liegen die im Schnitt so zwischen 0,6 und 1 sec.
    Wie groß ist den die Datenbank?
    Wie cache du das ganze und ist gzip aktiviert?