Beiträge von BG_hhh

    Bei mir funktionierts jetzt, ich bin nicht sicher woran es lag, das mit den Übersetzungen war bei mir auch passiert, dass dann überall die Variablennamen zu lesen waren.


    Ich vermute, dass meine Einstellungen unter <Menü> nicht richtig waren. Der Menüeintrag zum Plugin "Veranstaltung erstellen" hatte fehlerbehaftete Optionen. Ich kann nur nicht 100%ig sagen ob das tatsächlich die Fehlerursache war. Vielleich ist das bei dir aber ja auch der Fall, Olly.


    Danke für alle eure Hilfen!!

    Ich weiß ehrlich gesagt nicht genau welche Sprachdateien du genau meinst...


    Ich gehe davon aus, dass ich das alles richtig habe... aber wenn du mir sagen könntest welche Dateien du damit genau meinst (eventuell mit Screenshot) dann überprüfe ich das.


    Ich habe mein Problem auch an DigitalPeaks weitergeleitet.

    Ok endlich habe ich herausfinden können, dass dieses Problem der deutschen Spracheinstellung entspringt. Sobald ich die Standard-Sprache auf Englisch stelle, tritt dieses Problem nicht mehr auf.


    Es wäre ärgerlich wenn das ganze nicht mit der deutschen Sprache kompatibel wäre.


    Ich nutze übrigens die kostenlose Version.


    Mich würde jetzt ernsthaft interessieren ob dieses Problem auch bei anderen auftritt, falls jemand das mal ausprobieren möchte...


    Wenn dieses Problem tatsächlich nicht an mir liegt, würde ich DigitalPeaks darauf aufmerksam machen, eventuell sind die ja an BUG fixes interessiert.



    Ich hatte eigentlich nicht vor Englisch als Standardsprache zu nutzen.

    Sorry dass ich mich erst jetzt wieder melde...


    Jetzt wird es echt seltsam... ich habe DPC komplett deinstalliert (JEDE Erweiterung) und es wurden dadurch auch alle Tabellen in der Datenbank gelöscht, die mit DPCalendar zu tun haben. (Ich wollte die nach der Deinstallation der Erweiterungen löschen, habe dann aber festgestellt, dass alle gelöscht wurden, nach der Neuinstallation waren die Tabellen dann wieder da.)
    Dennoch tritt nachwievor das gleiche Problem auf. Ich habe keine einzige Einstellung verändert bevor ich es versuchte.


    Ich möchte hier nochmal auf das doppelte 'Y' bei "Februaryy"; "Januaryy" aufmerksam machen. Wo kommt das her? hmm
    Veranstaltungen im März lassen sich erstellen, sobald Start oder Ende einer Veranstaltung im Januar oder Febrauar liegen erscheint dieser Fehler.


    Ich frage mich wieso sonst keiner dieses Problem hat (zumindest finde ich nirgendwo etwas darüber). Es scheint mir schon so als würde da irgendwas im Hintergrund schieflaufen, oder ich soll einfach an keine Veranstaltungen im Januar und Februar erinnert werden. :D

    So sehen meine Einstellungen grade aus:
    Reiter Kalender:


    Reiter Veranstaltung:


    Reiter Veranstaltungsformular:


    Ich habe bei den Reitern Veranstaltungsformular auch das Datumsformat "d.m.Y" versucht.
    Ich habe auch bei dem Reiter Kalender das Format "F j, Y" getestet, auch dann der gleiche Fehler.


    Ich habe auch versucht die Felder Datumsformat und Zeitformat unter den beiden Reitern Veranstaltung & -sformular frei zu lassen, dann stellt er auf "m.d.Y" bzw. "g:i a" um, funktionieren tut es jedoch auch dann nicht.


    Alles ist auf dem aktuellen Stand (joomla, DPC, php)

    Danke schonmal für die schnelle Reaktion!


    hmm, also irgendwie scheint der die Einstellung des Veranstaltungsformulars einfach nicht zu übernehmen. Ich habe mein Datumsformat überall auf d.m.Y und mein Zeitformat auf H:i gestellt, dennoch wird es falsch im Formular angezeigt und wenn ich es richtig eingebe, versucht er es ins andere Format zu konvertieren.


    Gibt es irgendwo einen Button "Einstellungen zurücksetzen" oder so? :D


    Was ich gerade auch nicht kann, ist zwischen den Monaten hin- und herwechseln, meine Ansicht steht auf Monat und ich kann nur den aktuellen Monat sehen. Gibt es dazu irgendwo eine Einstellung die ich nicht finde? oder resultiert das aus meinen anderen fehlerhaften Einstellungen?


    Es geht um die Felder "Startdatum" und "Enddatum"


    Hallo,


    wenn ich eine Veranstaltung erstellen will und das vorgeschlagene (default-wert) Datum verändern will, erscheint folgende Fehlermeldung nachdem man auf speichern geklickt hat:

    Wenn man die Werte unverändert lässt, funktioniert es. Das doppelte 'y' bei Februaryy kommt mir seltsam vor, das gleiche tritt im Januar auf (Januaryy).


    Weiß jemand wie das zu beheben ist?


    Danke!

    Sooo ich habe das Problem lösen können.


    In der Template.css habe ich folgenden code gefunden:

    Code
    1. .navigation .nav-child li > a:hover,.navigation .nav-child li > a:focus,.navigation .nav-child:hover > a { text-decoration: none; color: #fff; background-color: #005e8d; background-color: #005783; background-image: -moz-linear-gradient(top,#005e8d,#004d74); background-image: -webkit-gradient(linear,0 0,0 100%,from(#005e8d),to(#004d74)); background-image: -webkit-linear-gradient(top,#005e8d,#004d74); background-image: -o-linear-gradient(top,#005e8d,#004d74); background-image: linear-gradient(to bottom,#005e8d,#004d74); background-repeat: repeat-x; filter: progid:DXImageTransform.Microsoft.gradient(startColorstr='#ff005e8d', endColorstr='#ff004c73', GradientType=0);}


    dann habe ich in der user.css den code eingefügt und tada! es gibt keinen sichtbaren hover effekt mehr bei dem element.:


    ich bin die template.css einfach nach allen ":hover" elementen durchgegangen thinking und habe bei den möglichen elementen getestet ob ein effekt auftritt wenn ich die farbe mit einer anderen ersetze. In Zeile 7469-7483 hatte ich dann endlich Erfolg! :D


    Danke für eure Hilfestellungen! beer

    Danke für die Antwort Axel, ich habe schon zuvor dort hineingeschaut, allerdings kann ich da nichts finden, was mit meinem Problem zutun haben könnte.


    Code
    1. <li class="item-179 deeper parent"><a href="#"><img src="/joomla30/images/icons8-settings.png" alt="Settings"></a><ul class="nav-child unstyled small"><li class="item-182"><a href="#">&nbsp;</a></li>


    Dieses Element:


    Die Zeile "background-color: #fff;" ändert nur die dauerhafte Hintergrundfarbe, allerdings nicht die, die durch den hover-effekt genutzt wird.


    In welcher Datei werden denn die Klassen "item-182" und "nav-child unstyled small" definiert? Ich denke dort werde ich die Lösung finden.

    Vielen Dank für eure Antworten, vorallem das mit der user.css ist sehr hilfreich!


    Ich habe einen Weg gefunden, in der user.css habe ich nun folgendes css:


    Code
    1. .item-182 a:before {
    2. content: url("http://intranet/images/bild.png");
    3. display: block;
    4. }


    (item-182 ist der Menü-Eintrag mit dem Bild)


    Jetzt würde ich noch gerne, wenn man mit der Maus über das Bild fährt den Wechsel der Hintergrundfarbe ausschalten oder auf die gleiche Farbe wechseln lassen.
    Im Anhang dazu ein Bild. Der Blaue Rahmen nervt.


    Das sollte natürlich nur für diesen Eintrag überschrieben werden, bei den anderen Menü-Einträgen sollte der Wechsel der Hintergrundfarbe bestehen bleiben.


    Ist nicht das wichtigste, möchte allerdings jetzt einfach wissen wie ich das ändern kann.


    In der template.css habe ich jede menge dazu gefunden, was dort theoretisch (aus meiner Sicht) mit reinspielen könnte, quasi von Zeile 2060 bis 2071 und 2975 bis 3120 und bei 7473. Aber wie spreche ich denn nun genau nur das eine Item an und nicht alle Menüeinträge gleichzeitig?


    Mir fehlen da wohl einfach auch ein bisschen die CSS fähigkeiten.. pardon


    Danke!

    "Einen Link zur Seite kann ich nicht liefern, da es sich um ein Intranet handelt."


    Ich verwende das Template protostar.


    Wenn ihr irgendwas bestimmtes braucht kann ich versuchen euch das zu liefern. Die Seite allerdings wie gesagt nicht.

    Moin,


    ich habe folgendes gemacht:


    Details:
    Menüeintragstyp: URL
    Link: #


    Linktyp:
    Bild zum Link: xyz.png
    Menütitel hinzufügen: Nein
    Im Menü anzeigen: Ja


    Der Eintrag ist ein Untereintrag eines Haupteintrags. Verwendet wird ein hover Menü, wenn man mit der Maus über den Haupteintrag fährt, (tut es ihm weh :D ) und es das Untermenü mit dem oben beschriebenen Eintrag wird angezeigt.


    Das Problem ist jetzt, dass das Bild zu klein angezeigt wird und man es daher nicht erkennen kann. Wie kann ich die größe festlegen? Egal welche Auflösung das Bild hat, es wird immer auf die gleiche Größe reduziert. Kann man da schon etwas in den Optionen des Menüeintrags definieren? Evtl unter CSS-Bildstil? Meine Vermutung wäre sonst die template.css.


    Einen Link zur Seite kann ich nicht liefern, da es sich um ein Intranet handelt.


    Bin dankbar für jede Hilfe!


    Freundliche Grüße


    hhh

    Hat sich bereits erledigt, ich habe eine andere Variante gefunden um den Scroll-to-Top Button einzufügen, jetzt gibt es auch keine Probleme mehr mit dem Kalender.


    Die Seite ist offline und wird ein neu aufgebautes Intranet.


    Ich benutze nun dieses Script:



    Thema ist damit abgehakt, danke für die schnellen Reaktionen!

    Das hat alles super geklappt!


    Jetzt habe ich allerdings einen Scroll-to-Top-Button eingefügt mit folgendem Code:


    Code
    1. <script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.3/jquery.min.js"></script>
    2. <script type="text/javascript" src="http://arrow.scrolltotop.com/arrow59.js"></script>
    3. <noscript>Not seeing a <a href="http://www.scrolltotop.com/">Scroll to Top Button</a>? Go to our FAQ page for more info.</noscript>


    und jetzt werden mir die DPCalendar und DPCalendar Mini nicht mehr angezeigt, dort ist nur noch ein Ladesymbol...
    Die Liste mit den anstehenden Terminen funktioniert allerdings weiterhin einwandfrei..


    hatte zuvor manuell ein paar dinge in der index.php und template.css geändert, diese allerdings zu 100% wieder rückgängig gemacht und der Fehler bleibt bestehen ?(

    ahh vielen Dank für die schnelle Antwort!


    Das hab ich wohl übersehen und dort gibt es auch schon die Möglichkeit einen Filter einzustellen, sodass ich nur ausgewählte Events anzeigen kann.


    Ich melde mich wenn alles fertig ist oder ich nochmal Hilfe brauche! :)

    Privet,


    ich möchte in meinem Intranet einen öffentlichen Kalender (für alle Member zugänglich) haben,
    aus dem ich bestimmte Events/Termine auslesen kann und diese auf der Startseite in einer solchen Form (Beispiel):


    "Wichtige Termine:
    20.08.2017: Besprechung - Sowieso , 16:00 - 18:00 Uhr
    03.09.2017: Ausflug - Sowieso , Ganzer Tag"

    darstellen kann.
    Der Kalender ist vorhanden, das hat alles soweit geklappt, allerdings habe ich nicht den geringsten Plan wie ich den 2. Teil umsetze. hmm


    Gibt es da irgendwelche tools um die Daten direkt aus dem Kalender lesen zu können?


    Oder falls das nicht der Fall ist, wie ich schon vermute...


    Hat irgendjemand Ideen zur Umsetzung?


    Ich habe bisher nur diesen Link gefunden, kann allerdings noch nicht sehr viel damit anfangen...


    Ich bin erst seit kurzem in die Welt von Joomla eingetreten und würde mich freuen wenn ihr mir helfen könntet! :)


    LG hhh