Beiträge von ringo

    Hallo, ich baue mir meinen Beitrag mit Hilfe von Feldern zusammen.

    Ich finde das sehr benutzerfreundlich.


    Nun habe ich ein Feld als Contenteditor angelegt. Dort gibt es auch die Möglichkeit die Schaltflächen anzuzeigen. (unten)


    Erstelle ich später den Beitrag und möchte mir in dieses Editorfeld mit Hilfe des Buttons "Felder" ein weiters Feld reinladen

    wird die Seite ausgegraut und ich komme nur über den Zurück Button des Browsers wieder in den Editor.


    Geht das grundsätzlich nicht, dass ich ein Feld in ein Feld laden kann?

    Oder ist das ein Bug?


    Danke für eure Hilfe

    Ich möchte meinen Kategorien taggen um damit ein Stichwortverzeichniss zu bauen.

    Die Zuweisung mache ich, indem ich die Kategorie öffne und die Schlagwörter rechts eintrage.

    Gehe ich auf speichern schmeisst er aber diese Schlagwörter teilweise wieder raus.


    Warum?


    Ausserdem ist mir aufgefallen, dass dort im Pulldownmenu nicht alle Schlagwörter angezeigt werden,

    die ich in der Komponente angelegt habe.


    Ein ähnliche Problem (?) habe ich wenn ich die Beiträge in einer Katgegorie sortieren/verschieben will.

    Manchmal funktioniert dass, manchmal nicht.

    (habe es mit verschieden Browsern probiert, den Cache gelöscht ...)


    Hat jemand ähnliche Problem bzw. einen Lösung/ansatz) dafür?

    Danke Ringo

    Danke dafür, das hat super geklappt.

    Ich habe dazu noch eine weitere Frage .


    Warum wird die Email, die ich durch ein Modul einbinde nicht verschleiert?


    Habe es schon selber rausbekommen. "Inhalte vorbereiten!"

    Danke

    Ich habe mir eine Art Adressliste gebaut.

    Um die Einträge für die Editoren leichter zu machen habe ich komplett mit Feldern gearbeitet,

    und gebe den "normalen Content" quasi gar nicht aus.

    Dafür habe ich mir ein Overide erstellt - > com_content/category/blog_item.php

    Die Ausgabe erfolgt etwa so - > echo "$item->jcfields[XX]->value;"; ... )


    Die HTML Ausgabe auf der Seite - > "Name, Tel, E-Mail" klappt auch super.


    Aber die Emails werden natürlich nicht maskiert und stehen schön sauber im Quelltext.


    Wie kann ich diese verschleiern?

    Könnte ich das Joomla interne Plugin dafür benutzen?

    Gibt es dafür andere Möglichkeiten?


    Vielen Dank im Voraus für eure Ideen.

    Ringo

    Hallo ich habe einen Joomla 3 Version auf Joomla 4 angebhoben.

    Jetzt verschlagworte ich meine Kategorien und lass mit die dann anzeigen. (Liste aller Schlagwörter...)

    Die entstehende Liste soll einen Art Stichwortverzeichniss sein.


    Jetzt funktionieren aus welchem Grund auch immer - nicht alle Links? (manche ja!)

    es entstehen links wie
    "www.domain.de/?view=category&id=45&catid=9"

    diese funktionieren nicht!


    Verschieben ich die Kategorie in einen andere Kategorie funktioniert der Link super.

    Verschiebe ich sie zurück ghet der lInk wieder nicht!


    Ich verstehe das nicht!!!!!
    Danke für eure Hilfen!

    Ist das irgendein Überbleibsel aus Joomla 3?


    Das Modul wird richtig angezeigt. Hier könnte ich auch den Titel anzeigen.

    Aber darum geht es mir nicht.

    Ich habe das Modul in einen aufklapbaren Container gepackt und möchte hier

    auf den Titel des Moduls zugreifen.

    den habe ich hier mit XXX gekennzeichnet.


    <?php if ($this->countModules('test')) : ?>

    <div class="col-xs-12 ">

    <h2 class="head"><a class="collapsed"> XXX </a></h2>

    <div class="collapse col-xs-12">

    <jdoc:include type="modules" name="test" />

    </div>

    </div>

    <?php endif; ?>

    das ist ja das Kuriose!

    ich habe


    Hauptkategorie

    - Subkategorie 1

    + Beitrag A

    + Beitrag B

    - Subkategorie 2

    + Beitrag C

    + Beitrag D


    sowohl in der blog.php als auch in der blog-item.php wird

    bei echo $this->category->title;

    "Hauptkategorie" ausgegeben!


    was mache ich falsch?

    Hallo ich erstelle mit gerade ein overide in html/com_content/category/blog_item.php.

    hier zeige ich alle einträge der der kategorie die 2 sub kategorien hat.


    mit "echo $this->category->title;"

    kann ich mir die kategorie anzeigen lassen.


    Wie kann ich zusätzlich die entsprechende subkategorie ausgeben lassen?


    Danke für eure Hilfe.

    Holger

    Hallo ich habe mir ein Feld vom Typ "editor" erstellt.


    Editiere ich nun einen Beitrag und hier das zugewiesene Feld(tab) werden nach dem Abspeichern alle Formatierungen gelöscht!!!

    (Sowohl mit dem Tiny MCE als auch mit dem JCE.)


    Mach ich das ganz normal im inhalt(tab) des Beitrags klappt es.


    Ist das ein Bug?

    Habe ich hier einen Denkfehler?


    danke für eure Hilfe

    ich möchte gerne meine blog.php so überschreiben, das die beiträge wie folgt angezeigt werden.


    <h1>Hauptkategoriename</h1>

    <h2>Unterkategoriename 1</h2>

    <div com-content-category-blog__items blog-items>inhalt beitrag 1.1</div>

    <div com-content-category-blog__items blog-items>inhalt beitrag 1.2</div>

    <div com-content-category-blog__items blog-items>inhalt beitrag 1.3</div>

    <h2>Unterkategoriename 2</h2>

    <div com-content-category-blog__items blog-items>inhalt beitrag 2.1</div>

    <div com-content-category-blog__items blog-items>inhalt beitrag 2.2</div>

    <div com-content-category-blog__items blog-items>inhalt beitrag 2.3</div>


    Ich bekomme das leider nur so hin das der Unterkategoriename vor jedem Beitrag angezeigt wird.

    Ich möchte aber die Überschrift nur einmal ausgeben!


    Wer kann hier helfen?

    danke Ringo