Beiträge von Rabendoktor

    Ich traue mich ja fast schon nicht mehr, aber:


    Ich habe mit meinem Texteditor mein bislang verwendetes, modifiziertes Protostar template.css verglichen mit einem frisch heruntergeladenen Protostar-template.css und alle von mir modifizierten Anteile in eine user.css-Datei kopiert, die ich im selben Ordner abgelegt habe, wie die template.css (CHMOD 604).


    Solange ich jetzt die alte template.css nutze, sieht alles prima aus - wenn ich jetzt aber (und so war der Plan) diese umbenenne oder aus dem css-Ordner rausnehme und die Original-Protostar-template.css in den css-Ordner zu der user.css kopiere... wird die user.css völlig ignoriert. Das sehe ich daran, dass sich das Aussehen der Seite in keiner Art und Weise ändert, wenn ich dann die user.css umbenenne oder aus dem Ordner rausnehme.


    Woran kann das liegen?


    DANKE,

    herzlich,


    Steffen


    PS: http://www.impf-info.de

    Entschuldigt, dass ich mich einschalte, aber:


    warum sollen Google-Fonts nicht DSGVO-konform sein? IMHO musst Du lediglich in Deiner DSE darauf hinweisen, DASS Du Google-Fonts verwendest... . Fertich...


    Dass Deine website so aussieht, wie Du es Dir vorstellst ist ja primär erst einmal ein "berechtigtes Interesse" im Sinne der DSGVO.


    Herzlich,


    Steffen

    Danke Dir, Tom -


    ich habe aus der Episode gelernt, dass ich meine beiden Seiten auf die Original template.css-Datei umstellen werde und die von mir vorgenommenen Änderungen in eine user.css ausgliedere.


    Die erstelle ich mir aus den mit Deinen Software-Tips identifizierten Änderungen in meiner jetzigen template.css.


    Wieder einmal: Joomla ist nicht nur ein, nein, DAS Super-CMS, sondern speziell diese Community ist das Beste, was einem Möchte-gern-webdesigner wie mir passieren kann... DANKE, DANKE, DANKE!


    Schönen Tag allen Mitlesern,

    herzlich,


    Steffen

    Viel schlimmer - es fehlte nicht, es fehlte nur das Komma hinter dem 2. .nav-child.... Wie gut, dass es hier kein facepalm-emoji gibt.


    Anka, ich danke Dir, jetzt ist alles so, wie ich mir das vorstelle!


    Gibt es eine Möglichkeit, 2 CSS-Dateien schnell und übersichtlich zu vergleichen (idealerweise für Mac)?


    In jedem Fall einen schönen Abend für Dich,

    herzliche Grüße, (auch nochmal an die anderen 3 Mit-Helfer),


    Steffen

    DANKE, anka!


    - ich bin erschüttert und weiß nicht, wie das passieren konnte - die waren tatsächlich weg... ich habe jetzt alle .nav li li -CSS-Zeilen rüberkopiert (hat auch funktioniert, ich musst die Farbe wieder von blau auf grün umstellen), aber das Problem mit der fehlenden dritten Ebene ist leider geblieben...


    Ich muss mich korrigieren - die 3. Ebene erscheint jetzt!, aber erst, nachdem ich auf die 2. geklickt habe... wie kann ich es einstellen, dass die schon beim hovern auftaucht?

    Hallo, Christiane,


    DANKE für die vorsichtige Nachfrage - ja, alles ist public...


    GANZ glücklich bin ich damit auch nicht, aber die Alternative wären halt mehr Menü-Überschriften, die dann nicht mehr horizontal darstellbar sind... ich brüte da noch drüber, aber das mit der 3. Ebene verstehe ich trotzdem nicht.


    Indigo66: ist ja wenn dann mein Fehler: mit der Überschrift ist es dann ja die 3. Ebene...


    Herzliche Grüße Euch Mitdenkern und Helfern,


    Steffen

    Das verstehe ich nicht - unter macOS 10.13 (der Mauszeiger fehlt natürlich, den brauche ich für's Bildschirmfoto):


    Firefox:



    Safari:



    Ich würde doch jetzt erwarten, das rechts neben "Die Impfaufklärung" auftaucht "Juristisches" und "STIKO", oder?


    Woran kann das liegen?

    Hallo,


    derzeit "relaunche" ich meine impf-info.de - Seite und scheitere gerade an der Menüstruktur. Ich habe per nav-pills das Hauptmenü auf horziontal gestellt und dessen Aussehen angepasst, allerdings haben einige Menüpunkte noch Untermenüpunkte, die mir das template bis jetzt vorenthält.


    So müssten bei "Die Impfentscheidung"/"Impfaufklärung" eigentlich noch die Unterpunkte "Juristisches" und "STIKO" auftauchen (idealerweise im gleichen design nach rechts verschoben) - das tun sie aber nicht... warum nicht?




    DANKE für Eure Hilfe,

    herzliche Grüße,


    Steffen

    Guten Morgen, Christiane,


    nein, das war wirklich Kurzfassung im Panikmodus - die Datei heisst natürlich configuration.php... ABER: ich habe nach dieser unglücklich Aktion (Nochmal Fehler 500 - NICHT bei Strato... )tatsächlich das Problem, dass ich auf der wiederhergestellten Seite jedesmal beim Speichern der veränderten configuration.php (Cyberduck, Bearbeitung mit Smultron 4) eine Fehlermeldung bekomme "Permission denied". Berechtigungen sind 444, das ist aber bei meinen anderen joomla-sites auch so...


    Ich kann das dann zwar durch vorübergehendes Ändern der Berechtigungen lösen, es nervt aber und ich verstehe es nicht - wo liegt der Haken?


    DANKE für Eure Hilfe,

    herzlich,


    Steffen

    DANKE, anka - mit abgeschalteten SEOs funktioniert es - worauf muss ich achten bei der .htaccess, damit ich die SEOs nutzen kann?


    PS: die Pfade in der config.php waren aber auch falsch und zeigten (bei /log und /tmp) noch auf den alten Server-Ordner... ist das üblich? Welche Berechtigungen muss die config.php haben? Sie hatte 444...


    Herzliche Grüße,


    Steffen

    Hallo,


    die Vorgeschichte meines Problems finden Interessierte hier (Template kopieren funzt nicht...)


    Kurzfassung:

    • neues Template erstellt (Protostar basiert), beim Versuch, es auf einer meiner anderen Seite zu installieren diese komplett abgeschossen.
    • auf freundlichen Rat hier J 3.8.8 drüberinstalliert, keine Besserung, daher Entschluss zum Neueinspielen eines Akeeba-Backups.


    Das habe ich heute morgen getan:

    • gleicher server, neuer Ordner
    • neue DB angelegt
    • mit Kickstarter ein Backup eingespielt, dass SICHER noch vor dem crash gemacht wurde
    • alles lief glatt durch, Frontend und Backend sehen aus wie vorher.
    • Update heute morgen auf 3.8.8
    • es war möglich, einen Artikel vom Backend aus zu bearbeiten und abzuspeichern, dieser wurde auch im Frontend als zuletzt bearbeitet angezeigt


    Mehr durch Zufall habe ich gemerkt, dass das Frontend zwar prima aussieht, wenn ich einen Artikel aufrufe, kommt aber diese Fehlermeldung


    Nochmal im Backend die DB repariert (war offensichtlich nötig), lief auch gut durch, aber: keine Änderung.


    Hoster: 1&1,

    URL: http://www.impf-info.de


    Danke für Eure Hilfe,

    herzlich,


    Steffen

    Config.php funzt wieder, ich konnte die Berechtigungen ändern und wieder sichern - ändert aber nix...

    phpMyAdmin hat die DB repariert, ohne Änderung des Problems

    Werde daher wohl ein Akeeba-Backup einspielen müssen....

    Nachtrag:


    ich komme per ftp noch an die Installation heran und kann mir die config.php anschauen - die Datenbankparameter sind in Ordnung (public $host etc.).


    Ich kann aber, wenn ich in der config.php etwas ändern möchte (z.B. das error-reporting auf maximum stellen), die veränderte config.php nicht speichern "permission denied"...


    Hilft das beim Helfen?


    DANKE schon jetzt!