Joomla 3.8.1 Kategorie und Tags funktionieren nicht in Kombination mittels Navigation

  • Guten Morgen.


    Ich habe folgendes Ziel:
    Da ich Beiträge habe, die alle in dieselbe Oberkategorie passen, jedoch teilweise zwei Unterkategorien gleichzeitig zugeordnet werden müssen, kann ich nicht alles in Kategorien organisieren.


    Ein bildhaftes Beispiel mit Murmeln:
    Jede Murmel gehört in die Oberkategorie "Murmel". Jedoch haben die Murmeln unterschiedlich Farben. Manche sind zweifarbig. Darum passen einige in zwei Unterkategorie.


    Mein Ansatz:
    Ich habe eine Oberkategorie und verschiedene Tags als Ersatz für die Unterkategorien erstellt.
    In der Navigation habe ich dann einen Link als Kategorie-Blog mit der Oberkategorie erstellt.
    Unter diesem Link untergeordnet habe ich dann weitere Links als Liste mit verschlagworteten Beiträgen zu den Tags, die als Unterkategorie-Ersatz dienen erstellt.
    Oder auch nicht als Liste mit verschlagworteten Beiträgen, sondern auch als Kategorie-Blog mit Schlagwort. Das Ergebnis blieb das selbe.


    Das Ergebnis, bzw der Fehler:
    Wenn ich auf den Link der Oberkategorie klicke, dann zeigt es mir noch alle Beiträge an.
    Wenn ich danach auf die untergeordneten Links klicke und danach wieder auf die Oberkategorie, dann zeigt es mir in der Oberkategorie nur noch die Beiträge an, die ich zuletzt als Unterkategorie angeklickt habe.
    Mir ist außerdem aufgefallen, dass die Links falsch sind.
    Jeder Link zu einen Beitrag enthällt im Link immer den letzten Unterlink in der Navigation.
    Also zum Beispiel:
    - .../oberkategotie/unterkategorie2/beitrag1
    - .../oberkategotie/unterkategorie2/beitrag2
    Obwohl es lauten müsste:
    - .../oberkategotie/beitrag1
    - .../oberkategotie/beitrag2


    Ich habe das vor der Umsetzung getestet und es funktionierte.
    Dann habe ich es umgesetzt und es funktionierte nicht mehr. Nun habe ich es wieder mit Testeinträgen getestet und es will einfach nicht mehr funktionieren.
    Irgendetwas habe ich bestimmt vergessen einzustellen.


    Ich habe auch einen Work-Around gefunden:
    Wenn ich in dem Link für die Oberkategorie als Kategorieblog nicht nur die Oberkategorie auswähle, sondern zusätzlich alle Tags zu allen Unterkategorien hinzufüge, dann funktioniert es.
    Aber das kann in der Zukunft zu Fehlern führen, wenn neue Unterkategorien hinzukommen und es vergessen wird, deren Tag zum Link für die Oberkategorie hinzuzufügen.


    Ich habe es auf zwei Joomla-Systemen ohne Erfolg versucht.


    Hier ein Testsystem:
    Link: http://check.bplaced.net
    Backlink: http://check.bplaced.net/administrator


    ... firstlady: Keine Zugangsdaten in ein öffentliches forum! ...


    Ihr dürft gerne rumprobieren. BackUp vorhanden.


    Könnt Ihr mir helfen? :-)
    Vielen Dank schonmal im Vorraus.




    - Hanekawa

  • Wenn ich auf den Link der Oberkategorie klicke, dann zeigt es mir noch alle Beiträge an.
    Wenn ich danach auf die untergeordneten Links klicke und danach wieder auf die Oberkategorie, dann zeigt es mir in der Oberkategorie nur noch die Beiträge an, die ich zuletzt als Unterkategorie angeklickt habe.


    Was ist denn in dem von dir verlinkten Beispiel die Oberkategorie und was sind untergeordneten Links? Unter deinem Link werden mir im Moment gar keine Beiträge angezeigt. Klicke ich falsch oder hast du gelöscht?