Backend Site (Administrator) nicht mehr erreichbar

  • Hallo zusammen, ich hoffe jemand hier kann mir helfen!
    Ich kann mein Admin Backend Site nicht mehr erreichen, wenn ich xxx.com/administrator eingebe, bekomm ich folgende Fehlermeldung:


    ***
    You may not be able to visit this page because of:


    an out-of-date bookmark/favourite
    an engine that has an out-of-date listing for this site
    a mistyped address
    you have no access to this page
    The requested resource was not found.
    An error has occurred while processing your request.
    ****


    Programmiersprachen sind absolut nicht meine Stärke, ich bin Netzwertechniker und das einzige was ich vor hundert Jahren mal gelernt hatte war VBA ;)
    In den letzten Jahren hab ich das notwendigste über Joomla und Website Archidektur gelernt und gezwungenermassen auch ein bisschen was über Website Sicherheit. Letzte Woche hab ich im Admin Verzeichnis eine htaccess Datei angelegt, die eine zusätzliche Benutzername/Passwort Abfrage für den Adminbereich erzwingt. DAS klappt soweit auch. Allerdings hab ich wohl auch sonst noch irgendwas "verschrümmelt", denn danach war die Site komplett "weg". Ich hab sie komplett neu hochgezogen, platt gemacht Backup eingespielt und nach einigen Stunden lief alles wieder.


    Langer Rede kurzer Sinn: Als ich heute wieder ins Backend wollte, bekam ich besagte Fehlermeldung. Mitlerweise hab raus gefunden, dass es wohl was mit der htaccess Datei im Root Verzeichnis zu tun haben muss - aber ich komm nicht dahinter, wo genau, resp. was ich ändern muss:


    1. Wenn ich die htaccess Datei im Root Verzeichnis lösche (oder umbenenne) und xxx.com/administrator eingebe, komme ich wieder ins Backend.
    2. Dafür läuft die Website nicht mehr: "File not found (404 error)"
    Interessanterweise komm ich seither wieder ins Backend (mit zusätzlicher Benutzername/Passwort Abfrage), aber das liegt wohl am Cache meines Browsers. Wenn ich mit einem anderen Browser rein will, kommt wieder die "Article not found" Meldung.


    Kann ich hier die htaccess Datei hoch laden, damit mir jemand helfen kann, das Problem zu lösen?
    Ich bin mit meinem eh schon beschränkten Latein echt am Ende und wäre wirklich froh um Eure geschätzte Hilfe!!!


    (Fehlermeldungen im Angang)

  • Ich brech ab...! Funktioniert tatsächlich!
    Aber was hat denn die Suchmaschinenoptimierung damit zu tun? An der habe ich nix geändert, hab' ja nicht mal gewusst, wo die Funktion zu finden ist ;P
    Und hat das nicht zur Folge, dass die Site jetzt von Suchmaschinen nicht mehr gefunden wird?


    (es darf ruhig gelacht werden, ich bin auf dem Gebiet wirklich ein blutiger Anfänger ;) )

  • Doch, die Webseite wird auch so von Google gefunden. Der Unterschied besteht im URL. Mit aktivierter Suchmaschinenoptimierung werden lediglich die URLs umgeschrieben.


    Z.B. aus (ohne SEO):
    www.example.com/index.php?opti…yout=blog&id=8&Itemid=103


    wird (mit SEO):
    www.example.com/news.html


    Gem. SEO-Experten hat es allerdings Auswirkungen auf die Sichtbarkeit der einzelnen Seiten in den Suchergebnissen. Ich kann das nicht beurteilen, ich bin kein Experte auf diesem Gebiet ;).


    Ein wirkliches Problem tritt aber definitiv dann auf, wenn du diese Einstellung änderst, nachdem deine Seiten bereits bei Google indexiert sind. Dann liefern nämlich die bei Google bereits indexierten Seiten einen 404-Fehler. Du solltest also unbedingt wieder die ursprüngliche Einstellung verwenden.


    Wie lautet denn der richtige Link zu deiner Webseite und was steht denn in der .htaccess im Rootverzeichnis?

  • Ich denk mal nicht, dass die Site schon indiziert ist bei Google und naja... wenn ist auch nicht so schlimm *denk-mal*


    Bevor ich die Site "lahm gelegt" hatte, hatte ich sie in einem Unterordner im public Verzeichnis, beim Neu hochziehen hab ich die Site direkt im public Verzeichnis angelegt/installiert. In der der htaccess bestünde Link ins "alte" Verzeichnis noch, ist aber deaktiviert (#). Anonsten hab ich nix geändert. Aber eben, mir fehlt das KnowHow um zu verstehen, was da sonst noch steht. Kann ich dir das File irgendwie schicken?