Beiträge von Diarmiud

    Danke!

    Das mit der Subdomain könnte eine Möglichkeit sein, ich bin aber nicht sicher, ob dann noch alle Skripte in dem "Testverzeichnis" funktionieren. Das müsste ich ausprobieren.


    Leichter wäre es, wenn die beiden .htaccess-Dateien miteinander kombinierbar wären. Hast du eine Idee, wie ich Joomlas-htaccess anpassen/verändern muss, damit der Zugangsschutz funktioniert?

    Elwood: testdomain.de habe ich nur als Platzhalter gesetzt. Ich gebe ungern die richtige Domain raus, weil ja das olle Verzeichnis noch nicht geschützt ist :)

    Zitat

    Ich tippe auf deine ansicht.htm. Arbeitest du in der SEF-Einstellung in der Joomla-Konfiguration mit "Dateiendung an URL anfügen"? D.h. werden alle URLs mit Dateiendung angezeigt?

    Versuche zunächst einfach mal ein Bild im Testverzeichnis aufzurufen! Funktioniert das?

    Ja, mache ich. Und eigentlich haben alle Dateien im Testverzeichnis .php als Endung. Aber leider wird auch ein Bild nicht aufgerufen.


    Zitat

    Kannst auch mal z.B. eine Subdomain einrichten die direkt auf deinen Testverzeichnisdateiordner zeigt und dann testen ob der Fehler beim aufrufen der Subdomain weiterhin besteht.

    Habe ich probiert und siehe da: alles funktioniert. Mit test.testdomaind.de/testverzeichnis/index.php wird ganz normal die User-Passwortabfrage gestartet.


    Aber was mache ich mit dieser Erkenntnis?

    Also ... leider schaffe ich es nicht, mein Problem so auszudrücken, dass es völlig klar wird. Ich versuche es gerne noch einmal. Vielen Dank auf jeden Fall für eure bisherigen Antworten.

    Am besten schildere ich noch einmal von vorne:


    Joomla


    Testverzeichnis

    Dann habe ich auf dem Server ein Verzeichnis "testverzeichnis" mit Dateien, die NICHTS mit Joomla zu tun haben. Auch der Ordner wird nicht von Joomla erstellt, sondern wurde von mir auf dem Server per FTP erstellt. dass ich schützen möchte. Darin findet sich zum Beispiel die Seite ansicht.htm. Diesen Ordner möchte ich mit Username/Passwort schützen und nutze dafür eine eigene .htacces/.htpasswd-Kombi in dem Testverzeichnis. Also so, wie man es eigentlich macht:


    Das Problem

    Sobald ich die http://www.testdomain.de/testverzeichnis/.htaccess hochlade, ist http://www.testdomain.de/testverzeichnis/ansicht.htm nicht mehr erreichbar. Stattdessen kommt eine 404-Seite, die von Joomla generiert wurde. Im Fehlerlog von Joomla finde ich obigen Fehler. Obwohl dieses Testverzeichnis nix mit Joomla zu tun hat, dort nicht als Kategorie zu finden ist oder Ähnliches.


    Es ist einfach die Original-Joomla .htaccss (unter http://www.testdomain.de/.htaccess), die diese Anfrage nach Hochladen der Testverzeichnis-htaccess nach Joomla umleitet. Denn wenn ich die http://www.testdomain.de/.htaccess lösche, funktioniert der Passwortschutz im Testverzeichnis. Aber Joomla-SEF dann halt nicht mehr :)


    Frage also:

    Ich habe ja oben schon 2 mögliche Ansätze für Lösungen durch Änderungen der .htaccess dargestellt, die aber nicht zum Ziel geführt haben. Aber vielleicht kennt jemand noch einen weiteren Tipp?


    Vielen Dank

    Peter


    PS: Hilfreich wäre es auch zu wissen, ob das Problem auch auf anderen Servern/Hostings auftritt. Oder nur bei mir (Hoster: Domainfactory).

    Sorry, dass es ein bissel unklar ist. Ich versuche, es klarer auszudrücken:

    Und richtig, da das Verzeichnis nichts mit Joomla zu tun hat, sollte ich es schützen können. Es erscheint aber die von Joomla generierte 404. Und obige Fehlermeldung im Joomla-Log.


    Ich erkläre es mir so, dass die .htaccess von Joomla, die im Root-Verzeichnis liegt, das irgendwie auf Joomla umleitet, wenn ich die .htaccess mit dem Passwortschutz in das Testverzeichnis hochlade. Denn wenn ich die .htaccess im Root lösche, dann funktioniert der Verzeichnisschutz. im Testverzeichnis.


    Wird es so deutlicher?

    Hallo zusammen,

    ich möchte ein Verzeichnis "/testverzeichnis" per.htaccess ("/testverzeichnis/.htaccess und ... .thpasswd") schützen. Dieses Verzeichnis hat mit Joomla nichts zu tun. Im Root ist die .htaccess von Joomla aktiviert, aber auch ohne aktivierte SEF-URLs tritt das folgende Problem auf.


    Die .htaccess mit dem Zugangsschutz lautet ganz normal:

    Apache Configuration
    AuthType Basic
    AuthName "Protected 'xxxx/testverzeichnis'"
    AuthUserFile "/home/z27zoexxx/xxx/testverzeichnis/.htpasswd"
    Require valid-user

    Leider klappt es nicht. Immer, wenn ich die .htaccess in das /testverzeichnis hochlade, werden die Seiten darin nicht mehr gefunden (404-Joomla-Seite erscheint). Ohne die .htaccess-Zugangsschutz-Datei werden die Seiten ganz normal aufgerufen.


    Folgende Fehlermeldung findet sich in der everything.php

    Code
    2023-01-20T16:33:16+00:00    CRITICAL 79.238.68.175    error    Uncaught Throwable of type Joomla\CMS\Router\Exception\RouteNotFoundException thrown with message "Seite nicht gefunden". Stack trace: #0 [ROOT]/libraries/src/Application/SiteApplication.php(736): Joomla\CMS\Router\Router->parse()
    #1 [ROOT]/libraries/src/Application/SiteApplication.php(224): Joomla\CMS\Application\SiteApplication->route()
    #2 [ROOT]/libraries/src/Application/CMSApplication.php(294): Joomla\CMS\Application\SiteApplication->doExecute()
    #3 [ROOT]/includes/app.php(61): Joomla\CMS\Application\CMSApplication->execute()
    #4 [ROOT]/index.php(32): require_once('/home/z27zoeq0n...')
    #5 {main}


    Ich habe mal gehört, dass dies ein bekanntes Problem seit Joomla 4 ist. Finde aber den Thread nicht mehr. Auch die beiden Threads hier im Forum:

    führen zu keiner Lösung, hier werden ja auch "nur" Joomla-Verzeichnisse geschützt.


    Hat jemand einen Lösungsansatz?


    Vielen Dank
    Peter


    PS: Folgendes habe ich schon versucht, hat nichts gebracht:

    In der .htaccess vom Testverzeichnis RewriteEngine off reinzuschreiben.

    In der .htaccess vom Root (Joomla) nach RewriteEngine On folgenden Code: RewriteRule ^(testverzeichnis)($|/) - [L]

    Ja, manuell, ich nutze das gestrige Backup vom Server.


    Nun ist der beides von gestern zurückgesichert: Datenbank und alle Files. Trotzdem blieb das Anmelden unmöglich.


    Da habe ich eine Idee gehabt und das CDN von unserem Dienstleister Ezoic abgeschaltet. Nun läuft die Seite wieder, Login im Backend ohne Probleme möglich.


    Habe die Datenbank und die Files von heute zurückgesichert - immer noch läuft alles ...


    Ich bin nun ganz zufrieden, aber es bleibt Unsicherheit, warum und weswegen es dazu kam. Schließlich lief die Seite auf dem CDN immer schadlos. Eine andere Joomla-Seite auf dem CDN ist nicht betroffen. Alles unklar ...


    Schade auch, dass Joomla keine Fehlermeldungen produziert, die beim Auffinden helfen könnten. Es kamen überhaupt keine Fehler ...


    Und falls jemand das gleiche Problem hat: Es funktioniert nun auch bei eingeschaltetem CDN, wenn man den Bereich vom Administrator aus dem Caching rausnimmt.

    Danke euch, aber leides ist es beides nicht

    Zitat

    Ist ein Menüpunkt als 'Startseite' definiert?

    Ja, der Home-Eintrag.


    dirk: Die configuration.php hatte ich heute schon einige Male in Händen, cookie-path und -domain-Eintragungen waren immer leer.


    ... ich werde jetzt mal alle Files von gestrigen Backup rüberspielen.

    Moin,

    wie der Titel schon sagt: ich kann mich nicht mehr ins Backend einloggen. Die Seite meldet keine Fehler, der Loop geht einfach wieder zum Login zurück. Es geht um die Seite:

    Bauen-und-Heimwerken.de - Administration


    Zum Hintergrund:

    Benutzer und Passwort sind bekannt. Heute morgen ging es noch, später nicht mehr.

    In der Zwischenzeit hat ein ander User einen Artikel eingestellt, der ist mittlerweile wieder runtergenommen. Keine Änderung.

    Keinerlei Updates bei Komponenten am heutigen Tag.

    Ich war einmal beim Login versehentlich auf "Web-Authentifizierung" gekommen, aber das kann es ja eigentlich nicht sein.


    Ich habe schon einige Stunden folgendes probiert:

    • Passwort nach Doku-Anleitung zurückgesetzt.
    • Neuen User laut Doku per SQL eingespielt.
    • Alle Caches gelöscht.
    • Error-Logs angeschaut - nichts gefunden.
    • Speicherlimit Memory-Size von PHP auf 256 MB erhöht.
    • Am Ende sogar das Datenbankbackup von gestern eingespielt.

    -> Alles hat nichts geholfen.


    Könnt ihr mir helfen?

    Danke und Gruß
    Peter

    Moin zusammen,

    vielen Dank für die vielen Antworten.

    PHP-Tipp: Die Seite läuft schon länger auf PHP 8+

    Wie wurde Joomla installiert? Weiß ich nicht mehr, das ist noch eine Mambo-Installation, mit laufenden Updates zur aktuellen Joomla-Version.

    Danke auch für den Tipp mit /vendor/. Wenn es noch einmal passieren sollte, werde ich dort ansetzen.

    Hallo zusammen,

    gestern waren auf unserer Seite blueprints.de auf einmal Frontend und Backend nicht mehr zu erreichen. Stattdessen erschien folgende Meldung:

    Zitat

    Environment Setup Incomplete

    It looks like you are trying to run Joomla! from our git repository. To do so requires you complete a couple of extra steps first.

    More Details

    Siehe auch den Screenshot.

    Ich konnte das Problem durch Rücksicherung vom Vortag beheben (serverseitiges Backup). Files und Datenbanken mussten restored werden, damit die Seite wieder lief.


    Ich hatte am gestrigen Tag lediglich 2 Komponenten upgedatet, aber ich bin nicht sicher, ob das im Zusammenhang stand. Aufgefallen ist der Fehler erst deutlich später. Ausserdem habe ich dass Update nach dem Backup wiederholt und es trat keinerlei Problem auf.


    Meine Frage: Hat jemand eine Idee, woran das gelegen haben mag? Ich möchte verhindern, dass dies noch einmal auftritt.


    Danke und Gruß

    Peter

    Zu den Meta-Keywords: Ich glaube nicht, dass diese einen großen Einfluss haben, da wir noch nie Keywords eingebaut haben.


    Zum Test per Templatewechsel: Das wäre leider ein Riesenaufwand, da wir Overrides, User.CSS etc. angepasst auf Cassiopeia nutzen.


    Eine Spur könnte sein: Wir nutzen das gleiche Cookie-Constent-Tool wie in Joomla 3 (GDPR von jEXtensions). Laut Betreiber gibt es da keinen Unterschied zwischen Joomla 3 und 4. Aber wenn wir den Cookie-Zustimmungsbanner abschalten, sind wir sofort wieder bei den alten Einnahmen. Aber erklären lässt sich das nicht, zumindest nicht mit meinem Wissen/Verständnis.

    Moin!
    Man kann ja in den Artikel-Optionen die Anzeige des Introtextes (Einleitungstext) abschalten. Eine Option, die ich hin und wieder nutze, um in der Vorschau einen anderen Text anzeigen zu können.

    Nun habe ich einen Artikel-Override angelegt (Datei „‎/templates/cassiopeia/html/com_content/article/default.php“ im Template „cassiopeia“), bei dem ich Introtext und Fulltext getrennt habe, um dazwischen eine Modulposition zu integrieren.

    Statt wie in der Original-default.php

    PHP
    <?php echo $this->item->text; ?>

    lautet es bei meinem Override:

    PHP
      <?php echo $this->item->introtext; ?>
          <!-- ************* Hier das Modul *************** -->
       <?php echo $this->item->fulltext;?>

    Funktioniert alles bestens, nur dass jetzt immer der "introtext" angezeigt wird. Egal, was ich in den Optionen beim Beitrag anwähle.


    Vermutlich fehlt eine Abfrage um "echo $this->item->introtext;" herum. Kann mir jemand diese nennen? Oder einen Tip geben, wo diese zu finden sein müsste ($this->item->text wird ja irgendwo "zusammengebaut").


    Vielen Dank und Gruß

    Peter