Beiträge von kitepascal

    Code
    Du könntes mal unter Erweiterungen -> Verwalten alle mit der ID > 10 000 abschalten. Das sind normalerweise die Drittanbieter Extensions.
    Dafür absteigend nach ID sortieren.
    Dann testen, ob das Problem weiterhin besteht.

    Hast du das mal versucht?
    So kannst du das Problem eingrenzen und wärst auf jeden Fall einen Schritt weiter.

    Wenn dir das im Live Betrieb zu heiß ist, kannst du z.B. eine Kopie der Site auf einer Subdomain aufsetzen mit Akeeba Backup.

    Ja, am 15. 12. war definitiv jemand aus Indonesien in deinem Backend unterwegs und hat Dateien bearbeitet.


    Daher unbedingt den /administrator Passwortschutz umsetzen.

    Bzw. am besten direkt die gesamte verknüpfte Domain dicht machen, bis alles passt.


    Wenn du kein Feature im Hosting Panel hast, kannst du das ganz leicht hiermit machen:
    https://wissen.gn2.de/wissen/w…r-mit-passwort-schuetzen/

    Hochladen nach

    /administrator/xssen.php

    Im Browser aufrufen.. Und geführt den Passwortschutz einstellen.



    Wie gesagt - meld dich gern und wir machen aus deinem Webspace Fort Knox.

    Der aktuelle Zustand ist untragbar für die Öffentlichkeit. Du stehst in der Verantwortung, wenn jemand Schaden nimmt.


    Auf gut Glück ohne Erfahrung herumzubasteln und im Grunde alles öffentlich zugänglich zu lassen, ist eine sehr schlechte Idee.



    Gruß


    Pascal

    Hallo Robin,


    ich würde mir das gern mal im Detail, ohne Kosten, direkt anschauen.

    Gehackte Joomla Seiten sind mittlerweile absolute Einzelfälle und fast immer liegt es nicht an Joomla selbst, sondern am "Drumherum". Sehr unsichere Passwörter, vormals brach liegende WordPress Installationen o.ä..


    Wenn du ein mal, warum auch immer, ungebetene Gäste auf deinem Webspace hast, ist der Zug natürlich abgefahren und du musst erst mal alle Hinterlassenschaften (Schaddateien/Backdoors) entfernen.


    In der Log Analyse tauchen einige Dateien auf, die eigentlich nicht dort hingehören.


    20x /administrator/includes/corazon.php 200

    11x /administrator/cache/com_jcomments/wp-sys.php 200

    3x /language/nl-NL/wp-sys.php 200

    22x /language/nl-NL/includes.php 200


    Ich empfehle auch mit einer erweiterten .htaccess zu arbeiten, ähnlich der von joomla-security.de, um sämtliche Joomla Verzeichnisse abzusichern. O.g. Aufrufe sind dann gar nicht mehr möglich.

    Außerdem solltest du das /administrator Verzeichnis mit einem .htaccess Passwortschutz versehen.


    Meld dich gern, dann kriegen wir das schnell wieder in den Griff.



    Gruß


    Pascal

    Du könntes mal unter Erweiterungen -> Verwalten alle mit der ID > 10 000 abschalten. Das sind normalerweise die Drittanbieter Extensions.

    Dafür absteigend nach ID sortieren.


    Dann testen, ob das Problem weiterhin besteht.



    Ansonsten kann es natürlich auch sein, dass dein Hosting/Server einfach sehr unperformant ist. Daher wären Details dazu hilfreich inkl. Link zur Seite, wie Indigo66 schon schrieb.



    Gruß


    Pascal

    Zitat

    Vielleicht muss ich einfach mal einen Beitrag entwerfen und dabei Texte kreieren, damit ich sehe, was passiert!?

    Genau.


    Zitat


    Es gibt immer noch kein Feld "Funktionalität", welches ich auf "komplett" stellen könnte.

    Ich gehe davon aus, dass das, was hier gemeint ist, eben genau dem Modus "Erweiterte Voreinstellung" entspricht.

    Aus "Funktionalität: Komplett" wurde offenbar "Erweiterte Voreinstellung".

    Ist ja auch von der Bedeutung her sehr ähnlich.


    Das Online-Handbuch ist sicherlich in manchen Bereichen nicht ganz aktuell. Es gibt immer mal Änderungen hier und da in neueren Versionen.



    Im erweiterten Modus hast du, wenn du einen Beitrag erstellt oder editierst, nun die Menüleiste oben (im normalen Modus nicht)..
    Bearbeiten | Ansicht | Format | Tabelle | Werkzeuge..


    Über das Bearbeiten Menü (was du mit der Option "Erweiterte Voreinstellung" = "Funktionalität: komplett" aktiviert hast), steht die Funktion "Als Text einfügen" nun erst zur Verfügung.


    Die Funktion ist dafür gedacht, wenn du z.B. Texte aus Word Dokumenten kopierst per Copy/Paste, die Formatierung nicht mitkopiert wird.

    Gleiches erreichst du, wenn du formatierte Texte aus Word in einen normalen, formatierungslosen Editor (Notepad, die ganz rudimentäre Variante) zwischenkopierst und erst dann in den Joomla Editor.
    Word Formatierungen haben nämlich im Web nichts zu suchen.



    Genau wie ich, hälst du dich viel zu sehr an Kleinigkeiten auf! ;-)



    Hi,


    links oben über Bearbeiten -> Als Text einfügen findest du die angesprochene Funktion.

    Nachdem du in den Plugin Einstellungen den Organgenen Button "Erweiterte Voreinstellung" geklickt und gespeichert hast, wie abgeshootet.


    Im JCE (joomlacontenteditor.net) kannst du auch in Standardeinstellung per Rechtsklick "Paste as Plain Text" (= als unformatierter Text einfügen) wählen.


    Gruß


    Pascal

    Moin Atze,


    ich nehme an das ist gemeint (Erweiterungen -> Plugins -> TinyMCE):




    Ich persönlich komme besser mit dem https://www.joomlacontenteditor.net/ zurecht - könntest du auch mal antesten.

    Lässt sich auch direkt über den Webkatalog installieren aus dem Backend.


    Falls du den mal antesten möchtest, muss der nach Installation ggf. noch über System -> Konfiguration -> Standard Editor aktiviert/festgelegt werden.



    Gruß


    Pascal

    Du könntes mal unter Erweiterungen -> Verwalten alle mit der ID > 10 000 abschalten. Das sind normalerweise die Drittanbieter Extensions.
    Dafür absteigend nach ID sortieren.


    Dann testen, ob das Problem weiterhin besteht.

    Wenn nicht, die Erweiterungen schrittweise wieder aktivieren, zwischendurch testen.

    So kannst du das Problem eingrenzen.


    Wenn es auch ohne Drittanbieter Extensions passiert, gib uns bitte mehr Infos zu deinem Hoster, PHP Version.. Ggf. die configuration.php mit entfernten Datenbank Zugangsdaten posten - womöglich passt auch darin etwas nicht.



    Gruß


    Pascal

    Ohne entsprechende Spezialisierung/Erfahrung in der Serveradministration ist so ein Root (v)Server eine tickende Zeitbombe.


    Weniger als Hobby geeignet, vor allem wenn wichtige Seiten/Kunden darauf liegen.


    Ich bin schon länger davon ab, das selbst zu machen.

    Wenn man im Core enthaltene Standard-Templates verwendet und anpasst, muss man damit rechnen.

    WordPress macht das genauso.. Da legt man Child-Themes an für individuelle Anpassungen.


    Bei Joomla kopiert man das Standard-Template, vergibt einen eigenen Namen - daraus wird dann ein eigenes Verzeichnis, das von Updates unberührt bleibt.


    Wie von Elwood oben angeleitet.


    Gruß


    Pascal

    -> erstelle eine user.css in /templates/protigs/css/user.css


    mit dem Inhalt


    CSS
    @media print {
        a[href]:after {
            content: none !important;
        }
    }


    Falls das nicht klappt (Protostar zu alt), setze es einfach in die vorhandene /templates/protigs/css/template.css


    Gerade getestet - das klappt.

    Hi Michael,


    wie sich anhand der Zahl der Antworten schon erahnen lässt, kann man hier nur schwer helfen. Es gibt offenbar mehrere Probleme.


    Hauptproblem ist 404 - Beitrag nicht gefunden.

    Das Debugging liefert Warnings - vermutlich im Zusammenhang mit PHP 7.x - die aber der Funktion eher keinen Abbruch tun.


    Hast du evtl. eine der Kategorien unpublished, in der deine Beiträge liegen?


    Zitat

    „Aktualisierung“: Die Dateien für das Website-Verzeichnis konnten nicht kopiert werden.

    ...weißt auf Rechteprobleme im Dateisystem hin oder der Speicherplatz auf deinem Webspace ist einfach voll.


    Gern kannst du mich per Chat kontaktieren , ich schaue mir das mit vervielfachter Effizienz gratis Remote an und wir lösen das hier für die Allgemeinheit auf.


    Gruß


    Pascal

    Im print Stylesheet (bzw. für den Print style in beliebiger CSS Datei) sollte folgendes funktionieren:

    CSS
    @media print { a[href]:after { content: none !important; }
    }


    Wenn du einen Link postet, kann ich eine genauere Anleitung liefern.