Beiträge ändern in Buttonleiste Fehler

  • Einen schönen guten Tag


    Nach vielen Jahren mit Joomla habe ich mich entschlossen dem Forum beizutreten, weil Joomla mitunter bei Uploads Sachen verändert, wo ich als nicht Fachmann Probleme haben diese nachzuvollziehen.


    Mein aktuelles Problem ist vielleicht ganz simpel. Im Menü Einträge Button Leiste war es bis letztes Jahr kein Problem dem gleichen Button über Betrag leeren und über auswählen einen neuen Beitrag zu hinterlegen.


    Das geht nicht mehr. Leeren kann man, nach Klick auf auswählen kommt dann ein Pop Up mit Error 403 /administrator/index.php Forbidden! Den Betrag bearbeiten kann man aber noch und ich habe dann den neuen Beitrag


    dort rein kopiert. So weit so gut, aber dann macht die Inhaltsrubrik Beiträge keinen Sinn. Es muss also ein Fehler meinerseits vorliegen.


    Es würde mich mega freuen wenn mir jemand eine Info geben könnte.


    Vielen Dank im Voraus


    LG Sven

  • Hallöchen

    Erste einmal Danke für das Interesse an meinem Problem.


    Hier noch ein paar Facts:

    Joomla Version: Joomla! 3.9.19 Stable [ Amani ] 2-June-2020

    PHP Version: 7.3.9

    Hoster: fc Hosting

    PHP erstellt für: Linux fc-host60


    Angepasste htaccess? Da muss ich passen. Gehe aber davon aus da Linux. Wo muss ich denn suchen um den Inhalt hier zu kommunizieren.

    Über den Administratorbereich geht es wohl nicht.


    Oder hat es etwas mit dem Sicherheits Update zu tun:


    Seit Version 3.9.3 wird Joomla! mit zusätzlichen Sicherheitsmaßnahmen in den Standard htaccess.txt und web.config.txt Dateien ausgeliefert. Diese Maßnahmen deaktivieren die so genannte MIME-Sniffing-Funktion in Webbrowsern. Das Sniffing führt zu speziellen Angriffsvektoren mit denen Skripte in normalerweise harmlosen Dateiformaten (z.B. Bilder) ausgeführt werden können. Das führt zu Cross-Site-Scripting-Schwachstellen.

    Das Joomla! Sicherheitsteam (JSST) empfiehlt dringend, die notwendigen Änderungen manuell auf bestehende .htaccess oder web.config Dateien anzuwenden, da diese Dateien nicht automatisch aktualisiert werden können.


    Änderungen in der .htaccess

    'For Apache Web Servers' Folgende Zeilen einfügen vor ## Mod_rewrite in use:

    Code
    <IfModule mod_headers.c>
    Header always set X-Content-Type-Options "nosniff"
    </IfModule>
    Danke für eure Hilfe
    Gruß Sven


  • Die Frage ist zunächst: Gibt es eine Datei namens ".htaccess" in deinem Joomla-Verzeichnis (auch Joomla-Root-Verzeichnis genannt)?

    Beachte den Punkt davor. Und die Datei hat keine Dateiendung.


    1. Der Inhalt dieser Datei sollte grob mit dem Inhalt der htaccess.txt übereinstimmen.

    Es kann sein, dass hier noch ein paar zusätzliche Anweisungen für den Server drinnen stehen.

    Manchmal wird sie aber auch deutlich erweitert. Das soll eigentlich dem Schutz der Seite dienen. Manchmal werden aber auch Joomla-funktionen blockiert. Das macht sich meist erst nach Joomla-Updates bemerkbar. Diese könnte auf deine Seite zutreffen.


    Der von dir genannte 3-Zeiler sollte enthalten sein.


    Verwendest du überhaupt keine .htaccess im Joomla-Root, dann vergiss das alles!


    2. Schau auch mal ins administrator-Verzeichnis! Da könnte eine weitere .htaccess liegen, die einen anderen Zweck hat. Liegt dort eine?

  • Es gibt eine htaccess.txt, bzw wenn aktiviert, eine .htaccess im Root-Verzeichnis von Joomla.


    Und man sollte den Ordner /administrator mit einem Verzeichnisschutz versehen.

    Diese heißt dann auch .htaccess

    Dann müsste sie aber funktionieren, da du dich sonst nicht im BE einloggen könntest.


    Deshalb wäre es wichtig, ob da noch mehr drin steht, so wie Indigo66 es schon erwähnt hat.


    Du könntest aber auch den Support von fc-hosting kontaktieren.

    Dort bekommst du sehr schnelle und kompetente Hilfe!

    (Cheffe ist hier auch im Forum;))

  • Hallöchen


    Erst einmal vielen Dank für eure Hilfe


    Bitte nicht böse sein wenn ich nicht direkt reagiere, da der normale Geschäftsbetrieb mich immer sehr in Anspruch nimmt.


    Werde versuchen eure Hinweise zu checken oder Uwe mal ans Telefon zu bekommen. Ist ja auch immer voll eingespannt.


    Wenn ich die Lösung habe werde ich es hier noch posten.


    Euch einen schönen Donnerstag


    LG Sven