Beiträge von JoomlaWunder

    Zeilen wie "AddType application/x-httpd-php5 .php .php3 .php4 .php5 .php7" sind eh nur als Beispielzeilen gedacht, wie man die PHP-Version abweichend von der globalen Einstellung auf z.B. PHP7 oder PHP5 oder PHP4 oder.... einstellen kann.


    Du musst dich da schon für eine Version entscheiden und nur die gewünschte Version in der Zeile drin lassen, z.B. AddHandler application/x-httpd-php56 .php für die PHP-Version 5.6.


    Keinesfalls sollte die angegebene Zeile so in eine .htaccess eingetragen werden!

    Ich gehe davon aus, dass du Joomla 3.9.4 ganz frisch in Xampp einrichten möchtest:


    1. Lade dir das Full-Paket von Joomla auf den Rechner und entpacke es!

    2. Lege dir in /xampp/htdocs/... ein Unterverzeichnis an, z.B. mein-joomla .

    3. Schiebe die entpackten Dateien dort hinein!

    4. Lege dir mittels http://localhost/phpmadmin/ eine neue Datenbank an!

    5. Rufe die Joomla-Installation mit http://localhost/mein-joomla/installation/ auf!

    6. Befolge die Anweisungen! Hierbei sind auch die Zugangsdaten für die DB anzugeben:

    localhost, root, DB-Name, Passwort leer lassen


    An welcher Stelle genau wird der Prozess nicht weiter ausgeführt?

    Liegt Xampp ganz oben auf der Festplatte? C:/xampp


    Ich kenne deinen Rechner nicht, aber mehr als 15 Minuten sollte der gesamte Vorgang keinesfalls dauern.

    Dieses "AddType application/x-httpd-php72 .php" stellt die PHP-Version auf PHP 7.2 um. Das geht nur einwandfrei, falls global eine andere Version eingestellt ist. Falls beim Hoster bereits 7.2 eingestellt ist, dann entferne diese Zeile bzw. setze eine # davor (Kommentarfunktion)!


    Das logs befindet sich schon seit längerem unter /administrator. Stell das gleich richtig ein!

    Auf der anderen Seite macht das aber auch nichts, wenn du es noch im Joomla-Root haben solltest, solange der Pfad passend dazu angegeben wird.


    Hast du in der index.php etwas verändert? Ist diese korrekt?

    Vermutlich ein Fehler, den JEvents fixen müsste?!?


    Ich hätte vorgeschlagen, dort im Forum nachzufragen! Aber wie ich sehe, hast du das bereits gemacht. Da würde ich zunächst deren Antwort abwarten.

    Auch die Adresse für den Webspace-Pfad für tmp und log gemäß den Angaben von Strato eingestellt.


    Bekomme die Seite einfach nicht zum Laufen. Auch der Zugriff auf das Backend geht nicht.

    Seite zeigt beim Auf ruf nur error an.

    1.Gibt es eine .htaccess, die du noch an den Hoster anpassen musst?


    2. Kannst du die Login-Maske für's Backend sehen?


    3. Pfade führen zu:

    /tmp

    /administrator/logs


    4. Wurde die configurtion.php mit einem geeignetem Editor bearbeitet?


    5. Eventuell die Dateien noch mal per FTP hochladen! (möglicher Dateifehler irgendwo)

    Besser wäre natürlich ein Tool, wo man nur 1 große Datei übertragen muss.

    Grundsätzlich sollte man, wenn man an seiner Webseite rumbastelt, den Joomla-Cache in der Backend-Konfiguration ausschalten!

    Ansonsten wird die (alte) Seite immer wieder aus dem Joomla-Cache geladen (natürlich auch abhängig von der eingestellten Zeit) und die Änderungen werden nicht angezeigt.

    Selbiges beim verwendeten Browser! Manchmal reicht es, wenn man nach einer Änderung die Seite mit F5 aktualisiert und manchmal muss man den Browser-Cache leeren.

    Wenn also eine Änderung sich nicht auswirkt, leere die Caches bzw. sorge dafür, dass nichts gecacht wird.


    Einstellungen, die in der template.css stehen, können natürlich geändert werden. Man kann den geänderten Wert aber auch ans Ende der template.css setzen, so dass der erste Wert überschrieben wird. Noch besser, wenn du hierfür eine user.css / custom.css nutzt, die genau für solche Änderungen gedacht ist. Hier am besten mal googeln! Wenn du diese nach Anleitung erstellst, wird sie automatisch in der index.php nach der template.css geladen und überschreibt die Standard-Werte.

    In diese user.css kommen dann nur die individuellen Änderungen rein. Keinesfalls solltest du den gesamten Inhalt der template.css dort hinein kopieren.

    Die richtigen Stellen findest du eigentlich nur über Analysetools, also F12 im Firefox und anderen Browsern oder ähnliches. 8000 Zeilen kannst du nicht überblicken.


    Da Protostar bei einem Joomla-Update überschrieben werden kann, sollte man am besten zunächst unter "Erweiterungen"->"Templates" eine Kopie von Protostar anlegen (z.B. mein-protostar) und mit dieser Kopie arbeiten.

    Auch hierzu gibt es Anleitungen.

    Wenn du den Menüpunkt für die Joomla-Aktualisierung anklicken kannst und alles läuft, dann kann das nur eine Kleinigkeit sein.


    Gehe in die Tabelle _menu, markiere die Zeile mit "com_joomlaupdate" und klicke auf "Bearbeiten"! Hiervon kannst mal einen bzw. zwei Screenshots machen und posten! Dann könnte man das mal mit anderen Joomla-Versionen vergleichen.


    p.s. Ein Screenshot von der Tabellenübersicht (Auflistung aller Tabellen) nützt nichts.

    Dein eigenes Modul liegt auf Position-6. Wo ist diese denn im Protostar-Template?


    Modul-Positionen:

    http://bj.zemplate.com/protost…rotostar-module-positions


    Nimm erst einmal eine Position, die nicht als "frei" oder "unused" angegeben ist!

    Ich meine, dass Position-6 gar nicht in der index.php steht und erst eingefügt werden müsste. Positionen könnte man in jedem Template ergänzen, falls es nicht genügend davon haben sollte. Fang zunächst mit den gegebenen Positionen an, z.B. Position-2 oder Position3.

    Habe jetzt aber auch nicht extra nachgeschaut. Deshalb ohne Garantie.

    table #__extensions

    table #__menu


    Suche in den beiden Tabellen nach com_joomlaupdate !


    Hast du eine Joomla-Version, die einwandfrei läuft? Dann vergleiche die einzelnen Spalten aus beiden Joomlas Es müsste einen Unterschied geben, denn du korrigieren kannst.


    Mit den Sprachen stimmt wirklich alles? (Frontend und Backend)

    (Bei den Sprachen lässt sich ja der Filter zwischen "Site" und "Administration" umschalten)


    Und "Reparieren" unter Datenbank hast du bestimmt auch schon angeklickt?


    Mit diesem Menüpunkt "Joomla-Aktualisierung" hatte ich auch schon mal Schwierigkeiten, da er auf einmal verschwunden war.

    Lässt sich notfalls aber in der DB wieder neu anlegen unter table#__menu .

    ....dss Modul ist Aktiviert und einem Menüpunkt zugeordnet (Shop). Caches natürlich auch geleert.
    Bestätigen kann ich es dadurch wenn ich den Menüpunkt Shop wähle, wird die Home Seite neu aufgeladen. Spricht es wird was ausgeführt nur in dem Fall das er die Hauptseite lädt anstatt die VM Seite.

    Wenn ich das richtig verstehe, hast du einen Menüpunkt zu dem Shop (VM-Seite) auf deiner Landing Page. Doch wenn du ihn aufrufst, wird nicht die Shop-Seite geladen, sondern erneut die Hauptseite (deine Landing Page) angezeigt, oder?


    Das hat mit einem Modul erst einmal gar nichts zu tun. Welchen Menüeintragstyp hast du denn für den Menüpunkt eingetragen?

    Anzeige der VM-Produktkategorien... ?


    Hast du mal einen Link zur Seite, wo man sich die Problematik anschauen kann?


    Verwendest du einen Link-Button, um zu einer bestimmten Seite zu gelangen, dann solltest du hier einen Menüpunkt als Link wählen und nicht beispielsweise einen Beitrag oder so....

    Eigentlich springt er immer zu der Stelle, wie es im Menü oben vorgesehen ist. Lediglich beim allerersten Aufruf scheint es irgendwelche Probleme zu geben. Komischerweise nur solange, bis die Cookie-Meldung bestätigt wurde. So hatte ich zumindest das Gefühl.

    Deaktiviere die Meldung mal!

    Führe mal alles gleichzeitig durch und teste dann (also nicht nur immer 1 Eintrag ändern und wieder rückgängig machen, bevor man den nächsten Eintrag ändert):


    1. In der zuletzt geposteten htaccess steht der 3-Zeiler nun doppelt drin. Entferne diese Zeilen!

    2. Setze: # Options +FollowSymlinks

    3. Setze: RewriteBase /

    4. Setze auch die obersten Zeilen mal als Kommentar, also:


    #AddHandler php72-cgi .php

    #php_value memory_limit 256M

    #php_value max_input_vars 10000

    #php_value max_execution_time 300

    #php_value max_input_time 300


    Auch wenn es ohne den 3-Zeiler funktioniert, würde ich das mal testen! Kommt dann immer noch ein 500er.



    5. Schalte mal testweise um auf Protostar und teste mit dem 3-Zeiler. Cache leeren!


    Welchen Hoster hast du denn überhaupt?


    BTW: Der Unterschied zwischen der Standard-htaccess und der erweiterten htaccess von joomla-security liegt vor allem in dem zusätzlichen Hackschutz. In beiden Dateien müssen in jedem Fall gewisse Einträge überprüft und ev. je nach Hoster angepasst werden.

    Wenn von der Verwendung der Originalen die Rede ist, heißt das nicht, dass z.B. RewriteBase / als Kommentar so bleiben soll. Bei 1&1 muss es beispielsweise zwingend aktiviert sein.


    Wenn es an dem Editor liegen sollte, dürfte die .htaccess ohne den 3-Zeiler auch nicht funktionieren, wenn sie falsch abgespeichert wird. Oder verwendest du zwei htaccess, die du durch umbenennen aktivierst?

    Wenn ich ein wenig die Suchmaschinen bemühe, kommen sehr häufig Hinweise auf verschiedene Browser. Könnte es vielleicht auch mit dem Browser zu tun haben?

    Teste mal einen anderen oder poste mal den Link zur Webseite, wenn die 3 Zeilen drinstehen. Dann könnte man das mal testen!

    Man weiß ja nie.