Probleme bei Umstellung auf https

  • Hallo zusammen,
    möchte auf https umstellen und stoße auf Probleme:
    Joomla 3.6.5, PHP 5.6.30, Server: world4you, Standartbrowser Firefox, url: www.herzundverstand.at


    Habe in der .htaccesse am Ende folgendes eingetragen:


    RewriteEngine On
    RewriteCond %{SERVER_PORT} !^443$
    RewriteRule (.*) https://%{HTTP_HOST}/$1 [R=301,L]


    Backend funktioniert auf https, Frontend wird nicht angezeigt.
    HTTP Status Code Checker bringt als Fehlermeldung:
    Location: https://www.herzundverstand.at/" data-original-title="HTTP/1.1 301 Moved Permanently
    ">301
    → Location: http://www.herzundverstand.at/" data-original-title="HTTP/1.1 303 See other
    ">303
    → Error while fetching URL.


    Leere nach jeder Änderung den Cache im Backend und die Cookies im Browser.
    In Joomla "https erzwingen" lässt joomla nicht zu.
    Mehrsprachigkeit der Seite habe ich rückgängig gemacht,
    Seofreundliche Urls deaktiviert.


    Kenne mich bei htaccess nicht aus - was habe ich falsch gemacht?


    gernot

  • Hallo Gernot,

    In Joomla "https erzwingen" lässt joomla nicht zu.


    doch, doch :-)


    Zitat

    Seofreundliche Urls deaktiviert.


    brauchst Du nicht. (deaktivieren)


    Zitat

    Kenne mich bei htaccess nicht aus - was habe ich falsch gemacht?


    Du brauchst bezüglich SSL nichts in der .htaccess ändern. Außer, wenn Du kein "www" vor Deiner Seite hättest. Also: nonwww zu www.


    Du gehst ins Kundencenter von W4Y > dann zu > SSL/TLS Verschlüsselung > dort wird Dir ein 24h stündiger (Test) Zugang zu SLL angeboten.
    Ich selbst habe nur das da genommen: Produkt letsencrypt (genügt für mich). Dieser Testzugang wird (automatisch) fix eingerichtet, wenn man dem vor 24h nicht "widerspricht".


    Dann ins backend, eben SSL aktivieren.


    Liebe Grüße, Christine

  • Hallo Gernot,


    das ist aber schon komisch. Bei mir hatte es so funktioniert, was Dich natürlich jetzt nicht tröstet :-)
    Hier steht der .htaccess Eintrag anders: https://faq.world4you.com/inde…l&cat=3&id=290&artlang=de


    "Läuft" diese Testphase noch? Schau dort noch mal nach, ob Zertifikat "aktiviert" ist.


    Dennoch, ich würde dem Support dort schreiben. Was anderes: Hast Du schon probiert auf PHP 7 umzusteigen? Kann man dort auch aktivieren.


    Liebe Grüße, Christine

  • Liebe Christine,


    Testphase ist vorbei, habe an w4y geschrieben - bis jetzt keine Antwort. Zertifikat ist aktiv. Den .htaccess-Eintrag habe ich ebenfalls schon versucht. Da funktioniert https zwar im Backend, im Frontend "läuft sich jedoch der Server tot" (Endlosschleife lt. Diagnosetool).
    Für mich verwunderlich, dass "https erzwingen" Joomla nicht zulässt. (Fehlermeldung beim Speichern) Das ist auch de Grund, warum ich die Mehrsprachigkeit "rückgebaut" habe, und seofreundlich deaktiviert habe - stand so in einem Forum.
    Hat aber nicht geholfen.
    Vielleicht habe ich beim Seitenaufbau irgendetwas übersehen oder nicht beachtet.


    Liebe Grüße


    Gernot

  • Hallo Gernot,

    Backend läuft über https, Frontend nicht.


    Warum sollte es im backend funktionieren, aber nicht im frontend. Es sei denn, man hat es nicht für "beide" aktiviert.


    Deswegen nachgeschaut. Deine URL/administrator > da sehe ich kein SSL. Abgesehen davon, dass kein Verzeichnisschutz existiert. Das geht auch über das Kundenpanel von W4Y.
    Nur so eine Idee: Was steht bei: RewriteBase? So: RewriteBase oder so: #RewriteBase /


    Liebe Grüße, Christine

  • Deaktiviere doch mal die .htaccess oder zeige den kompletten Inhalt.
    Eine einzelne Datei aus dem Web kann ich problemlos via SSL aufrufen:
    https://www.herzundverstand.at/robots.txt


    Sobald der Aufruf aber über Joomla und der index.php läuft, wird umgeleitet auf http:
    Irgendwo muss eine solche Regeln/Funktion aktiviert sein.

  • Hallo Christine,
    Hallo Uwe
    hier die komplette .htaccess:



    Die letzten drei Zeilen sind lt world4you ans Ende der .htaccess zu setzen. Habe ich vorübergehend herausgenommen, damit meine Siete überhaupt erreichbar ist.
    Sind die drei Zeilen gesetzt, ist das Frontend nicht erreichbar, das Backend läuft über https.


    Viele Grüße
    Gernot

  • Hallo Uwe,
    Habe SEO im Backend bereits einmal deaktiviert.
    Den Cache sowohl in Joomla als auch im Browser leere ich sicherheitshalber immer, wenn ich etwas verändert habe.
    Auch die Deaktivierung des Caches in Joomla hat nichts gebracht.
    Deinen Vorschlag mit der .htaccess werde ich am späteren Nachmittag versuchen. - Muß jetzt weg.
    Danke vorab - melde mich nach dem "Versuch" wieder


    Grüße


    Gernot

  • Hallo Uwe,
    [quote].. SEO im Backend deaktivierst und die .htaccess durch umbenennen deaktivierst?
    Lösche auch den INhalt des /cache Ordners und deaktiviere Cache-Funktionen im Joomla.
    Browser-Cache auch löschen[quote]
    Cache in Joomla geleert und deaktiviert, SEO deaktiviert, Browsercache geleert, .htaccess umbenannt auf 1htaccess.
    Seite läuft im Frontend und im Backend auf http://


    Liebe Grüße Gernot

  • Hallo Gernot, grüß Dich Uwe,


    hab's gerade gesehen, dass Du SEO deaktiviert hast etc.


    Also wir sind mit Herz bei Dir :-) aber mein Verstand sagt, dass es nicht sein kann, dass wegen SSL, SEO nicht fahren darf. Sicherlich, es war/ist ein Versuch ... dennoch.


    Was mir auffällt ist: (vielleicht war das eh auch schon vorher), dass wenn man über die Menüs hovert, dass https in der unteren Browserzeile gesehen wird!
    Allerdings NICHT bei den breadcrumbs > ul.uk-breadcrumb


    Hmmm, tja liebe Grüße, Christine

  • Liebe Christine
    Lieber Uwe


    Das mit den Breadcrumbs ist mir nicht aufgefallen. Hab das Modul probehalber deaktiviert - hat nichts geändert.
    Ebenso die gzip-Komprimierung - ausgeschaltet - Cache und cookies geleert - hat nichts geändert


    Habe die .htaccess so einmal so belassen, wie sie original ist und einmal mit den Umleitungszeilen lt. worls4you versehen.
    Bei
    original lauft sowohl Backend als auch Frintend auf http, mit den drei
    Zeilen Backend https, Frontend http - auch wenn beim hoovern https
    angezeigt wird.


    Viele Grüße Gernot fiehmm