Beiträge von christine2

    Ich möchte das beim Klick auf einen Menü Titel (siehe Test 2) allen anderen Link auch sichtbar bleiben (alle unten). So wie es jetzt ist, werden die Links unten überdeckt und sind somit nicht mehr sichtbar.

    verstehe jetzt, was Du meinst. Dafür gibt's ja diesen Pfeil:



    Bei vielen Untermenüs, ob das nicht eine zu lange Wurst werden würde?


    Liebe Grüße

    Christine

    Hallo,


    Vielleicht bekomme ich eins auf dem Deckel, aber ich frage jetzt trotzdem mal, um sicher zu sein.

    na, ich überlegs mir mal chinese Aber Ernst beiseite:


    Was genau gefällt Dir daran nicht?



    Sollte es mehr links sein, oder wie?

    Liebe Grüße
    Christine

    denke von hier: RE: Gleiches Login für mehrere Benutzer


    Liebe Grüße

    Christine

    Der Entwickler passt die Daten selbst an und lädt neue Version hoch. Dann ändern sich auch die angezeigten Daten.

    Ja natürlich, so wird bzw. soll(te) es auch sein.


    Elwood bezieht sich u.a. auf dieses Beispiel hier:


    Liebe Grüße

    Christine

    Hallo JoomlaWunder,

    ich habe mir die beiden folgenden Sprach-Pakete für J4 heruntergeladen:

    de-AT_joomla_lang_full_4.0.0v1-rc4

    de-CH_joomla_lang_full_4.0.0v1-rc4

    weiß auch nicht, von wo diese sind?


    Auf die Schnelle nur das hier gefunden: https://downloads.joomla.org/l…/downloads/joomla4-german


    Hab mal einen Issue aufgemacht:

    https://github.com/joomlagerman/joomla/issues/1980


    Liebe Grüße
    Christine


    Ergänzung: Wird wahrscheinlich mit obigem nichts zu tun haben, dennoch zur Info:

    https://github.com/joomla/joomla-cms/discussions/34685

    Hallo Michael,

    Die könntest du wohl über custom css in JEvents verändern. Eine Änderung wirkt sich allerdings auf beide Module aus.

    Ja, sehe ich auch so. Betreffend jEvents Einstellungen etc., weiß ich nicht, da ich diese nicht kenne.


    Wegen dem schwarzen Balken: Habe mal temporär folgendes in die user.css eingegeben:

    Code
    .moduletable td.mod_events_latest_first, .moduletable td.mod_events_latest {
    border-style: inherit;
    }

    Die Kategorien-Farben (rechts) blieben erhalten.

    Noch etwas: der Abschnitt "moduletable" beginnt mit 6 Zeilenumbrüchen, die ich mit "margin-top: -5em;" wieder rückgängig mache. Das ist sicher nicht besonders elegant. Gibt es eine bessere Lösung?

    Da würde ich diese 6 Zeilenumbrüche entfernen und dann:

    Code
    div.moduletable {
        margin-left: auto;
        margin-right: auto;
        width: 90%;
        margin-top: -5em; /*entfernen*/
        padding-top: 2em; /*dazugeben*/
    }

    Liebe Grüße
    Christine

    Der vierte Release Candidate (RC) für Joomla 4 ist jetzt erschienen und kann heruntergeladen werden. Wieder erscheint gemeinsam mit Joomla 4 RC4 auch ein neues Release der zum Upgrade nötigen „Brückenversion“, Joomla 3.10 Alpha 9.


    https://www.joomla.de/news/joo…0-alpha-9-veroeffentlicht

    https://www.joomla.org/announcements/release-news/5841


    Nightly Builds:

    https://developer.joomla.org/nightly-builds.html

    3.10.0-alpha10-dev

    4.0.0-rc5-dev


    Liebe Grüße

    Christine

    Hallo Jan,

    Danke für Deine Rückmeldung.

    ... dachte ich, es sollte automatisch barrierefrei sein. Wenn nicht, würde ich mich über einen Ratschlag zu dieser Feature freuen, da ich kein Experte auf diesem Gebiet bin.

    was ist schon automatisch? :-)


    Es gibt hiezu viele Issues, PRs, wenn Du auf Github direkt nach a11y schaust:



    Expertin ist da firstlady


    Im Backend kann man auch einschalten (Plugin System - Additional Accessibility Features):



    Beispiel: die "hover" Möglichkeit wird (auch) öfters besprochen.


    Liebe Grüße

    Christine

    Dann ist das mit meinen restlichen 25% geklärt. Weil im Patch ist noch das durchgestrichene rote drinnen:



    Da hatte ich ja die Icon Class reingegeben.

    Diese Programme sind leider uralt und seit den Anfängen von Joomla wurde immer nur angebaut. Leider ist das für die K4 nur übernommen aber nicht richtig neu aufgebaut worden. Ich kann jetzt kurz vor knapp keine größeren Änderungen mehr machen, das wäre zu riskant.

    Dann ist es eben so. Ist halt dann für die 4.1, oder oder :-)


    Obiges zähle ich eher zu nice to have, oder so.


    Gibt noch genug andere Bugs etc., die Deine Arbeit erfordern. Danke dafür!


    Liebe Grüße

    Christine

    Hallo Christiane,


    hab jetzt 75% Erfolg. Diese "notice" wurde ja nun in der /modules/mod_menu/src/Helper/MenuHelper.php gefixt. Danke schön.

    Auch das Schriftproblem (vom Issue #32471) wurde damit gelöst. Habe davor aber das besagte Menü "Search" gelöscht und neu aufgebaut.

    Der Titel ist aber geblieben.


    Liebe Grüße

    Christine

    Hallo Phil,

    Bennene ich die custom.css um, so sieht die Seite aus, wie frisch nach dem Backup. Nur mit der alten custom.css sieht sie halbwegs annehmbar aus. Denkst du ich sollte die custom.css ganz ignorieren und nur per user.css stylen?

    Ja, wenn ich temporär die custom.css rausnehmen, sieht das Menü bescheiden aus ....


    Probiere mal: Nimm die CSSen von der custom.css (dort sind ja u.a. Navi CSSen) und gib diese in die user.css

    Wobei darin ja auch (wie erwähnt) diese Bootstrap3 Elemente sind = fast unwirksam. Nicht näher beguckt.


    Danach brauchst Du Dich nur mehr auf die user.css konzentrieren und weitere Kosmetik machen.

    Ran mit dem Inspector & ev. Änderungen/Ergänzungen, welche Du in der template.css siehst, dort hin geben.


    Edit: Obiges kann nur teilweise gelöst werden. Siehe auch #9


    Liebe Grüße

    Christine

    Hallo,

    Das liegt an der Zeile 38 der custom.css.

    CSS
    nav.navigation {
        display: none;
    }

    Wenn ich das rausnehme ist ein Burgersymbol vorhanden, aber das Menü und die Suche ist nicht besonders gut gestylet. Hier solltest Du den fragen, der das gebaut hat, das ist nämlich nicht Standard.

    Kann ich bestätigen. Es fehlt u.a.: .navbar etc. Formatierungen.

    Ich verstehe bloß nicht, wieso es trotz des Überschreibens des Templates mit dem "Alten" immer noch zu Problemen kommt.

    ergänzend zu Indigo66, welcher u.a. (auch) das wegen dem Core-Update erklärt hat (keine Template Kopie):


    custom.css > Diese wurde vor langer Zeit im Protostar angelegt. Diese nimmt man nicht mehr (gilt für andere Templates)

    user.css > Kam dann später als Ersatz dazu (= OK)


    Aber:

    U.a. hast Du in der user.css einige BS3 Einträge. Protostar ist aber Bootstrap2.

    CSSen, welche in der user.css sind - überschreiben die custom.css bzw. sind vorrangig.


    Man müsste da alle durchgehen & dementsprechend abändern, sodass nur mehr die user.css (Änderungen, Ergänzungen) und die template.css wirken. Wäre/ist recht mühsam.


    Nach Deinem Backup und Update auf J 3.9.28 würde ich es neu "aufziehen". Auch wenn es dann natürlich in Moment nicht so aussieht, wie Du möchtest. Bzw. von Indigo66

    Zitat

    Du hast ein Backup von vor 7 Tagen, daraus extrahierst Du Dir das Verzeichnis administrator/templates/protostar und überschreibst per FTP selbiges auf dem Webspace. Dann könnte es evtl. wieder passen.


    - Obere Menüs auf Position-1 mit den "berühmten" " nav-pills". Gibt dazu einige Threads.

    Dann kommt der Hamburger von alleine ..... Kosmetik danach. Ev. Farbänderungen usw.


    - user.css > CSS Änderungen/Ergänzungen


    - Template Copy (wurde schon erklärt)


    Liebe Grüße

    Christine

    Hallo Stef,


    müsste ich mal ausprobieren. Auf die Schnelle geraten, vielleicht deswegen:

    Code
    <div itemprop="articleBody" class="com-content-article__body">
            <p style="text-align: center;"> </p>
    <p style="text-align: center;">

    scheint das oben fehlende </p> (3. Zeile) sich unten dranzuhängen, weil hier kein offenes <p> ist:

    Code
    width="294" height="44" loading="lazy" /></p></div>
    </p>     </div>