Mehrsprachige Webseite - falsches Language Tag in Quellext

  • Hallo zusammen


    Ich habe eine mehrsprachige Webseite DE/EN erstellt. Der Sprachwechsel, die URL's und Flaggen funktionieren und werden wie gewünscht angezeigt. Nur habe ich das Problem, dass im Quelltext bei allen Sprachen immer das gleiche Language Tag angezeigt wird.


    Setze ich die Standardsprache auf DE erfolgt die Anzeige im Quelltext bei allen Sprachen so: <html xmlns="https://www.w3.org/1999/xhtml" xml:lang="de-de" lang="de-de" >
    Setze ich die Standardsprache auf EN erfolgt die Anzeige im Quelltext bei allen Sprachen so: <html xmlns="https://www.w3.org/1999/xhtml" xml:lang="en-gb" lang="en-gb" >


    Die Einstellungen im Plugin System - Sprachenfilter sind wie folgt:
    Sprachauswahl: Seitensprache
    Automatischer Sprachwechsel: Ja
    Verknüpfungen: Ja
    „Alternate“-Meta-Tag hinzufügen: Ja
    „X-Default“-Meta-Tag hinzufügen: Ja
    „X-Default“-Sprache: Standard Website-Sprache
    URL-Sprachkürzel entfernen: Nein
    Cookie-Lebensdauer: Sitzung


    Im Header vom Template index.php ist das Tag wie folgt eingefügt:
    <html xmlns="https://www.w3.org/1999/xhtml" xml:lang="<?php echo $this->language; ?>" lang="<?php echo $this->language; ?>" >


    Das Problem besteht auch, wenn ich die Webseite auf das Standard-Template Protostar umstelle.


    Hat vielleicht jemand eine Idee woran das liegen könnte? Vielen Dank für eure Hilfe.


    Gruss Beat

  • Das Problem besteht auch, wenn ich die Webseite auf das Standard-Template Protostar umstelle.

    Dann habe ich immer zuerst ein zuinstalliertes Plugin in Verdacht, das zu einem zu frühen Zeitpunkt die Template-Parameter abfragt, bspw. im Konstruktor. Dadurch wird u.a. auch die Sprache festgeschrieben und spätere Versuche des Systems, sie anzupassen, scheitern.


    Meist, aber nicht immer, sind das System-Plugins.


    Wäre also einen Versuch wert, diese zuinstallierten Plugins mal durchzugehen und schrittweise zu deaktivieren. Erst mal Tests unter Protostar.

  • Hat leider alles nichts gebracht... auch auf der englischen /en Seite:

    <html xml:lang="de-de" lang="de-de" >


    egal welches Template, auch wenn ich die sprachen neu installieren...


    hmmm... Jetzt weiß ich leider nicht mehr weiter...


    Laut SEOCHECK: Beheben Sie die Fehler bei der Sprachangabe im HTML Code der Seite.


    Im Text erkannte Sprache: en

    Im HTML angegebene Sprache: de-de

    Serverstandort: Österreich

    Die angegebene Sprache de stimmt nicht mit der im Text erkannten Sprache en überein.

  • Um sicher zu sein:

    - Plugins hast deaktiviert? Und getestet ohne aktivierten Cache? Auch den Browser-Cache immer wieder geleert?

    - Du hast eine mehrsprachige Seite mit Sprachumschalter und das ist der Joomla-Umschalter und die Mehrspachigkeit ist über Joomla eingerichtet?

    - Das Backend-Info-Modul "Mehrsprachenstatus" zeigt keine Fehler an? (Siehe Post #5).

    - Joomla ist aktuell?

    - Link zur Seite?