Widgetkit Problem nach Änderung auf PHP 7-72 7.2.11

  • Guten Morgen zusammen,


    ich habe auf meine Website (http://www.physio-in-esslingen.de) folgendes Problem:

    Seit dem ich auf PHP7 (vorher 5) umgestellt habe, habe ich folgende Fehlermeldung:

    Deprecated: Function create_function() is deprecated in /kunden/414031_73765/joomla-2016/media/widgetkit/widgets/lightbox/lightbox.php on line 49



    Deprecated: Function create_function() is deprecated in /kunden/414031_73765/joomla-2016/media/widgetkit/widgets/lightbox/lightbox.php on line 49



    Deprecated: Function create_function() is deprecated in /kunden/414031_73765/joomla-2016/media/widgetkit/widgets/lightbox/lightbox.php on line 49



    Deprecated: Function create_function() is deprecated in /kunden/414031_73765/joomla-2016/media/widgetkit/widgets/lightbox/lightbox.php on line 49



    Deprecated: Function create_function() is deprecated in /kunden/414031_73765/joomla-2016/media/widgetkit/widgets/lightbox/lightbox.php on line 49



    Deprecated: Function create_function() is deprecated in /kunden/414031_73765/joomla-2016/media/widgetkit/widgets/lightbox/lightbox.php on line 49


    Ich konnte aber mit meinen Wissen nicht rausfinden was ich da Ändern muss das ich diese korrigieren kann.


    Könnte mir jemanden helfen?


    Vielen herzlichen Dank!


    Joomla Version Joomla! 3.9.8 Stable [ Amani ]

  • Auf welche PHP-Version genau hast du umgestellt:

    PHP 7.0 oder 7.1 oder 7.2 oder 7.3 ?

    Von PHP 5.6 ist das definitiv kein kleiner Schritt. Hättest du eigentlich schon längst umstellen müssen.


    Joomla ist veraltet. Aktuell 3.9.11!

    Womöglich ist dein Widgetkit2 auch veraltet. Aktuell wäre 2.9.22 !

    Gleiches gilt für das Warp-Framework.

    Eventuell sind auch andere Drittanbieter-Erweiterungen veraltet.


    Du solltest alles auf einen aktuellen Stand bringen. Die nötigen Anpassungen für PHP 7.2 oder gar 7.3 wurden von den Anbietern in den letzten Jahren durchgeführt. Diese fehlen bei dir. Ebenso wichtige Sicherheitsupdates.


    Sichere deine Webseite aber zuerst, bevor du dich an die Arbeit machst!

  • Hi,


    du nutzt Widgetkit I in Version 1.5.5 - die neuste Version ist Widgetkit 1.5.11.
    Ich gehe davon aus, dass die "Deprecated" Funktionen in der aktuellen Version korrigiert/aktualisiert worden sind.


    Davon abgesehen sind die "Deprecated" Medungen nur Hinweise darauf, dass in zukünfitgen PHP Versionen irgendwann der Support dafür eingestellt wird - also in dem Sinne keine Fehler.

    Um die Meldungen ohne Widgetkit Update loszuwerden, kannst du "Fehler berichten" in der Joomla Konfiguration auf "keine" stellen.

    In einer Produktivumgebung ist das ohnehin immer empfehlenswert.


    Gruß


    Pascal

  • Widgetkit ist kostenpflichtig, daher werden keine Aktualisierungen dafür über den Joomla Updater angezeigt - Updates bekommst du hier:

    https://yootheme.com/widgetkit


    Wenn so weit alles funktioniert (bei ausgeblendeten PHP Hinweisen), ist ein Update nicht nötig.

    Ich muss dich korrigieren. Bei Widgetkit 3.X bekommt man das auch im Backend angezeigt und wenn man den Key hinterlegt kann man auch normal updaten. Wenn es hakt dann einfach, wie von dir genannt runterladen und installieren (der updatet das dann nur).

  • Ich habe die Aktualisierungen immer über meinen Kontrollzentrum gemacht.

    Bei älteren Erweiterungen war es so, dass deren Updates gar nicht über "Aktualisieren" angezeigt wurden. Dieses "System" wurde erst ab einer bestimmten Joomla-Version eingeführt. (Keine Ahnung, wann das war). Zusätzlich muss der Erweiterungsanbieter das auch unterstützen, was mittlerweile der Normalfall sein sollte.

    Deshalb kann es durchaus sein, dass manche Aktualisierungen in Joomla gar nicht angezeigt werden, wenn die Erweiterungen älter sind. Musst du halt einzeln über deren Webseite prüfen!