Probleme beim Serverwechsel Joomla 3.10.

  • Hallo Ihr Wissenden,

    Ich habe von einer produktiven Seite in Internet eine Kopie auf meiner eigenen Ubuntu-Maschine gemacht.
    1. ein FTP durchgeführt
    2. Die configuration.php angepasst (den DB-Zugang und die beiden Pfade für log und tmp angepasst)
    3. Die DB exportiert bzw importiert

    Nun musste ich feststellen, dass die Links im Menü ins Nirvana gehen und bekomme 404 Error.
    Im Adminbereich funzt alles. Im Frontend funzt nur die Startseite.
    Ich dachte, dann verknüpfst du im Adminbereich den Menülink noch mal neu mit dem Beitrag - was leider auch nichts brachte.

    Hat jemand eine Idee? Früher ging das mal so. Danke im Vorraus

  • Du musst SEO korrekt einstellen. Oft sind die ersten beiden Haken gesetzt, was dann auch eine korrekte .htaccess bedingt. Diese muss beim Umzug meist auch angepasst werden. Macht man das nicht oder auch wenn sie nicht existiert (das ist der eigentliche ausschlagebenede Punkt), kann nur die Startseite aufgerufen werden und alle anderen Menüpunkte führen zu 404. Bei inkorrekter .htaccess meist 500er.

    Also entweder den zweiten Haken entfernen oder die .htaccess an den neuen Server anpassen!

  • Im Joomla-Backend unter "System" -> "Konfiguration" -> "Suchmaschinenoptimierung (rechte Seite)"!

    Für "URL-Rewrite nutzen" wird die .htaccess benötigt. Steht auch dabei, wenn man mit dem Mauszeiger rüberfährt oder dort die "Hilfe" aufruft.

    Ach so: Gilt natürlich nur auf Apache-Servern.

  • Ist das alles, was da drinsteht?

    Dann nimmt die originale htaccess.txt (die Joomla beiliegt) mal als Vorlage und benenne diese um!


    Das nächste wäre, das RewriteBase / zu überprüfen!

    Die # entfernen und dann einfach das Unterverzeichnis ergänzen, falls Joomla in einem Unterverzeichnis liegt, z.B.

    RewriteBase /dein-joomla/

  • natürlich nicht .. ich wollte nur das wesentliche zeigen