Beiträge von Firefox2010

    Alles klaro dann weiß ich Bescheid.

    Ich musste tatsächlich auf joomla 4 updaten weil mein Hoster php Versionen unter 7 alle abschaltet.

    Ich hab tatsächlich Geduld, da es eh eine neue Seite gibt, und diese nur eine Seite sein wird um auf die ganzen alten Bilder etc zuzugreifen. Ich wollte nicht auf die neue Seite diese Tausende von Bildern neu hochladen und hab sozusagen einen cut dann gemacht und die Seite wird auf ner subdomain laufen. Somit habe ich aktuell keinen Stress! Und solange wenn es dann joomgallery4 gibt die ganzen Galerien wieder angezeigt werden bin ich zufrieden!

    Ich habe soeben eine Migration von Joomla 3.10 auf Joomla 4.4.4 durchgeführt.

    Leider sind alle meine Galerien nicht mehr zu sehen.

    Wenn ich im Backend auf JoomGallery gehe, kommt folgender Fehler:

    Es ist ein Fehler aufgetreten!

    Zitat
    500 behavior::tabstate not found.

    Kann mir da jemand weiterhelfen?

    LG

    Da Joomla mit relativen Pfaden arbeitet, ist der Domainname egal. Joomla läuft ohne Anpassungen (außer Serverpfad für tmp und logs) in dem Verzeichnis auf dem Webserver, auf dem die Domain oder Subdomain connectiert ist.
    Achte nur darauf, dass in der configuration.php der Verweis auf live_site leer ist.

    Wenn die connectierung nicht sauber funktioniert, ist das eine Fehlkonfiguration auf dem Webserver und hat nichts mit Joomla selbst zu tun.

    Danke schonmal für deine Antwort

    Die live Site in der config ist leer. Ich werde mir nochmal die htacces etc genau anschauen nicht das da was hinterlegt ist.


    Ja da kenn ich mich aus und weiß wie das alles funktioniert. Das ist nicht das Thema das ich habe :) Danke trotzdem für den Link

    nochmal das geht nicht beim server, ich kann zwar klar das installationsverzeichnis auf die subdomain spielen komme dann aber immer auf die normale domain nicht auf die subdomain da ich automatisch auf diese komme. Bei Joomla muss doch irgendwo die Domain im Backend in der Datenbank oder sonst wo hinterlegt sein oder nicht ?


    also ich habe das joomla instalationsverzeichnis auf die subdomain zugewiesen und habe dann die neue seite auf die alte domasin zugewiesen leider passiert folgendes; ich komme auf die neue Seite unter der alten domain unter der Subdomain passiert genau dasselbe also komme ich auch da wenn ich auf die Subdomain gehe, auf die neue Seite obwohl ich das eigentlich nicht sollte

    Es gibt eine neue Seite die auf die Domain der alten ( jetzigen) Seite laufen wird deshalb muss die jetzige von der Domain weg und auf eine subdomain.

    Und nein das kann ich nicht, denn das läuft auf einen Server

    Das, was Du machen willst, nennt sich Subdomain. Die musst Du bei Deinem Hoster erstellen und dann den Webspace entsprechend verweisen.

    Das ist mir alles bewusst und die subdomain ist auch schon erstellt etc. Nur weiß ich nicht wie ich joomla darauf verweise, denn wenn ich nur das heimatverzeichnis am Server andere komm ich nicht mehr drauf weder alte noch neue (sub) Domain


    Bei Wordpress ist es so das man im backend die Domain ändern kann und das dann automatisch geht. Hier finde ich leider nichts darüber aktuell denkt joomla es ist die alte Domain noch

    Hallo, dadurch das ich eine neue Seite gebaut habe, die auf aktuellen Versionen läuft, möchte ich die URL der alten ändern. also von http://www.testurl.de zu http://www.alt.testurl.de

    Ich finde darüber aber absolut nichts im Internet oder sonst wo.

    Kann mir da jemand helfen wo ich das vornehmen muss?

    in der config.php hatte ich bei Live Site schon die neue rein geschrieben ging aber nicht. auch in der htaccess hatte ich es geändert dann ging die seite gar nicht mehr.

    LG und danke

    Ja war es. Bin jetzt bereits wieder auf joomla 3.10 die Migration auf 4 wird erst später erfolgen muss jetzt erstmal wieder alle Funktionen etc herstellen.

    Kann aktuell über joomla Gallery keine Bilder hochladen. Es kommt immer eine Fehlermeldung das muss ich erstmal hinbekommen das das wieder geht etc

    Den Tipp habe ich gerade versucht, ich hab zwar die tabelle Session jetzt wieder zugänglich in myphpadmin aber alle anderen noch nicht und zeigen weiterhin den fehler an , also hat dieser versuch leider auch nichts gebracht


    Was mir gerade noch aufgefallen ist. In PHPMYADMIN steht bei allen Tabellen die nicht gehen bei Kollation in Benutzung. bei denen die gehen stehen die richtigen kollationen dort. Keine Ahnung ob das was zu bedeuten hat.


    Ich habe gerade mal in meiner Sicherung des Webspaces nach .sql dateien gesucht. Da FInde ich massig dateien die auch in den Dateien die Namen der vorhanden Tabellen beinhalten.

    Kann man damit was anfangen?


    WAHHHNSINNNNN.

    Ich habe ein Backup aus 2016 gefunden von der Datenbank. dieses in ne neue Datenbank importiert Config im Webspace geändert und siehe da Seite ist online. Zwar zum Stand auf 2016 aber besser als gar nicht.

    Nachtrag zur Datenbank:

    In der Datenbank gibt es einen kleinen Unterschied in der Tabelle "Session", die Reihe "data" ist bei bei Joomla 3 vom Typ "longtext" und bei Joomla 4/5 vom Typ "mediumtext".


    Vielleicht ist der Server nach den Betriebssystem- und Datenbankupdate nicht mehr für Joomla 3 geeignet ?

    Gruß Gindi

    .

    Und wieso habe ich das ganze dann bei einer aktuellen Wordpress Seite auch ? Das ergibt keinen Sinn das es daran liegt


    Genau so ist es. Ich gehe in PHPMYADMIN da sehe ich die Datenbank, dort sind auch allte Tabellen aufgelistet. Wenn ich Exportiere finde ich in der sql datei wenn ich diese per Notepad öffne alle tabellen aufgelistet die dich nicht gehen zeigen folgendes in der SQL in Notepad an:

    -- Tabellenstruktur für Tabelle `cfu7k_contentitem_tag_map`

    --

    -- Fehler beim Lesen der Struktur von Tabelle db00079177.cfu7k_contentitem_tag_map: #1932 - Table 'db0XXXXX.cfu7k_contentitem_tag_map' doesn't exist in engine

    -- Fehler beim Lesen der Daten von Tabelle dbXXXXX.cfu7k_contentitem_tag_map: #1064 - Fehler in der SQL-Syntax. Bitte die korrekte Syntax im Handbuch nachschlagen bei 'FROM `dbXXXXX`.`cfu7k_contentitem_tag_map`' in Zeile 1

    Genau es betrifft diese Joomla version und weitere Wordpress installationen die alle auf den aktuellen Stand sind.

    Die Datenbank ist definitiv nicht zu voll da ich für jede Domain eine eigene Datenbank habe. und die 45 stück sind nicht alle webseiten sondern auch welche die ich besitze zur Umleitungen etc.


    Du meinst inmnerhalb der Webspace daten gibt es die DB? da habe ich nämlich eine Sicherung von vor dem serverupdate rumliegen.

    Da ging noch alles.

    Das glaube ich und versteh ich auch das die dafür zuständig sind aber was soll ich tun wenn sie mir nicht entgegenkommen?

    Hast Du schon mal die Fehlermeldung in das Suchfeld deines Browsers eingegeben?

    Da gibt es viele Einträge zu den Thema "#1932 Table doesnt exist in engine"

    Gruß Gindi

    Natürlich und ich habe schon alle Möglichkeiten die goolge ausspuckt probiert... XAMPP. PUTTY etc. ich weiß nicht wie ich die Struktur wieder richtig stellen kann. Desweiteren ist es irgendwo nachzulesen das was mit der ibdata nicht stimmt und er so nicht weiß welche tabellennamen zuzuordnen sind. Ich habe aber halt wie gesagt kein uodate um die Datenbank auf die neue zu migrieren. Leider bei jetzt erstellten Export fehlen 75 Tabellen die nicht mit exportiert werden,