einsprachige Webseite

  • Guten Tag,


    ich stocke an folgendem Problem.


    PHP
    <!DOCTYPE html>
    <html xmlns="http://www.w3.org/1999/xhtml"
          xml:lang="<?php echo $this->language; ?>"
          lang="<?php echo $this->language; ?>"
          dir="<?php echo $this->direction; ?>">
    <head>

    Wir verwenden diesen Code in der Index.php, allerdings sagt Xovi uns bei der Auswertung der Webseite, welche einsprachig ist, dass die Links keine Sprachangabe haben.


    Die Systemsprache ist bei Joomla bereits auf deutsch und alle anderen Sprachen sind deinstalliert.


    Den Beiträgen wurde bereits die Sprache zugewiesen, doch wenn das bei den Links gemacht wird, wird der Ländertag hinter den Link gesetzt, was vollkommen unschön ist und auch unnötig, da die Webseite ja auf Deutsch festgelegt wurde.


    Im head schmeißt er mir beim untersuchen auch das raus:

    HTML
    <html xmlns:og="xxx" xmlns:fb="https://xxx" xmlns="xxx" xml:lang="de-de"       lang="de-de"       dir="ltr">

    Hier der Screen von Xovi:

    http://prntscr.com/11fseox


    Kann ich im Code regeln, dass er auch die Links automatisch mit der festgelegten Sprache erkennt?


    Vielen Dank schon jetzt!

  • Huhu,

    danke für die Antwort.


    Also unter Sprache - Installiert -- ist der Standart auf Deutsch.

    Und bei Inhaltssprachen gibt es nur noch DE.


    Das einzige, was nicht eingestellt ist, sind die Sprachen bei Links (die stehen auf "Alle").


    Er erkennt auch beim Seiten untersuchen, dass die Seite "xml:lang="de-de" lang="de-de"" hat.


    Aber Xovi zeigt eben bei den Links dennoch an, dass die Spracheinstellung fehlt.


    Daher ist meine letzte Option, dass eventuell im Code steht, die Seite könnte mehrsprachig sein, statt einsprachig und er deswegen bei den Links meckert.


    Liebe Grüße

  • Das einzige, was nicht eingestellt ist, sind die Sprachen bei Links (die stehen auf "Alle").

    Ich weiß nicht, was du da überall an den Sprachen herumstellst. Man hat Englisch und Deutsch im Backend, Frontend und als Inhaltssprache. Im Backend und Frontend stellt man dann Deutsch als Standardsprache ein.


    Beiträge, Menüpunkte usw. sollten alle auf "alle" gesetzt werden!

  • Das ist korrekt! Allerdings hast du die Inhaltssprache "Englisch" gelöscht. Ob das einen Unterschied macht, weiß ich nicht.


    Was aber wichtig ist: Du darfst den Menüpunkten, Beiträgen usw. keine Sprache zuordnen, sondern immer auf "alle" stellen!

    Das macht man nur, wenn man seine Webseite zwei- oder mehrsprachig macht.

  • Hey,

    ja, es ist die richtige Webseite.

    Es wurde damals die normale große Joomla-Installation gemacht und danach die deutsche Sprache installiert.

    Es wurden mit dem Grundgerüst noch 2 weitere Webseiten erstellt. Die beiden haben das selbe Problem bei Xovi, aber haben nur (de) nicht (nl).

    Wo könnte sich denn noch ein Codeschnipsel befinden, der eventuell dafür verantwortlich ist?

    Weil die index.php scheint es nicht zu sein, da der Code für mich oben korrekt aussieht.

  • Man kann jedes HTML-Element mit einem lang=nl oder ähnlich auszeichnen. Bspw., wenn man ein niederländisches Zitat in den deutschen Text setzt.


    Einfachste ist dann wohl, sich im Browser den Seitenquelltext der untersuchten Seite anzeigen lassen und mal nach nl zu durchsuchen.


    Manche so Untersuchungstools sind aber auch einfach Schrott ;-) und machen aus Mücke Elefant. Finden ja oft Sachen, die längst nicht mehr notwendig sind in modernem Internet.


    Vielleicht hat das "nl" auch eine ganz andere Bedeutung?

  • Es wurde damals die normale große Joomla-Installation gemacht und danach die deutsche Sprache installiert.

    Es wurden mit dem Grundgerüst noch 2 weitere Webseiten erstellt. Die beiden haben das selbe Problem bei Xovi, aber haben nur (de) nicht (nl).

    Was ist eine große Joomla-Installation?

    Und mit welchem Grundgerüst wurden die weiteren Webseiten erstellt.


    Es gibt doch nur ein(e) Joomla-(Installation).