Container-Contenthintergrundbild beschreibbar machen

  • Ahoi
    Bin mal wieder da mit einem sicher trivialen Problem in Joomla 3.6.5 Vorab.
    Habe in verschiedenen Foren passende Themen gesucht und gefunden, ABER nichts hat mir geholfen.
    Ich möchte ein Bild als Hintergrund passend zum Thema im Beitrag wiederholen und mit Text über- be-schreiben.
    siehe als Beispiel http://sajda.de/Svalbard___/svalbard___.html u.a.
    Folgendes habe ich gemacht. 1. eine Protostar-Kopie erstellt und als Standard definiert. Dann eine
    User.css mit dem Inhalt von Template.css erstellt. Frage nebenbei - wo soll die sich befinden?
    Im CSS-Ordner oder im Template? Egal - ich habe beide Versionen getestet ohne Erfolg.
    In der USER.CSS hatte ich statements für den Background eingegeben (am Ende der CSS)
    mit images -referenzen und repeat definitionen und dem anderen Schmonzes.


    .bild {
    background-image:url("../images/bg4.jpg");background-position: 50% 50%;background-repeat: repeat;
    }


    Im Beitrag <div class="bild"> und </div>



    Der Erfolg war gleich Null. Fehhlernachrichten habe ich aber auch keine erhalten
    Leider ist die ganze Geschichte nur lokal vorhanden.

  • @christine2
    Hallo Christine


    danke aber damit hat sich auch nichts geändert
    Folgende Version hatte ich auch schon probiert im ....css - ohne Erfolg
    }
    .body .container {
    background-color: #fff;
    background-image: url('..images/bg1.jpg');
    background-repeat: repeat;
    -moz-border-radius: 4px;
    -webkit-border-radius: 4px;
    border-radius: 4px;
    padding: 20px;
    border: 1px solid rgba(0,0,0,0.15);
    -moz-box-shadow: 0px 0px 6px rgba(0,0,0,0.05);
    -webkit-box-shadow: 0px 0px 6px rgba(0,0,0,0.05);
    box-shadow: 0px 0px 6px rgba(0,0,0,0.05);
    }



    Jetzt ist gutes Rad teuer
    LG Fritz

  • Hallo Fritz,


    Zum Thema user.css hier: http://develop.linsner-luebeck…m-template-protostar.html & hier: https://extensions.joomla.org/…-default-joomla-template/


    Bild: Hast Du mit dem inspector schon geschaut, ob vielleicht die Grafik nicht gefunden werden kann. Bzw. überprüfe den Pfad (auch mit den Punkten).

    Im 1. Code hast Du: url("../images/bg4.jpg") im 2. dagegen: url("..images/bg4.jpg") (da fehlt der / )


    Liebe Grüße, Christine

  • @christine2
    Hallo Christine
    danke - die beiden Links hatt ich auch schon auf dem Schirm. das mit dem fehlenden / habe ich ohne Erfolg korrigiert.
    Was ich gemacht habe: diese BGx.jpgs als Einleitungsbild und Beitragsbild im Beitrag angegeben und sie werden angezeigt.
    Das heißt, dass die Bilder im /images--- Verzeichnis gefunden werden.
    Dann habe ich die User.css modifiziert wie unten:
    Zusätzlich hatte ich noch die font-size und line-height Parameter angehängt , nur um zu sehen ob die user.ccs angezogen wird.
    Sie wird, denn meine Texte in den Beiträgen wurden entsprechend größer.
    Das Bild kommt aber trotzdem nicht.
    Was mir auffällt ist: dieser images-parameter ist beim editieren der CSS genauso rot wie unten zu sehen.
    Alle anderen sind grün, oder blau oder grau. Inspector hat mich auch nicht schlauer gemacht.


    Ich bin kurz davor, alles rauszuschmeißen und Joomla neu zu installieren. Aber ob das die Lösung bringt?


    LG Fritz


    .body .container {
    background-color: #fff;
    background-image: url("../images/bg1.jpg");
    background-repeat: repeat;
    -moz-border-radius: 4px;
    -webkit-border-radius: 4px;
    border-radius: 4px;
    padding: 20px;
    border: 1px solid rgba(0,0,0,0.15);
    -moz-box-shadow: 0px 0px 6px rgba(0,0,0,0.05);
    -webkit-box-shadow: 0px 0px 6px rgba(0,0,0,0.05);
    box-shadow: 0px 0px 6px rgba(0,0,0,0.05);
    font-size: 20px;
    line-height: 30px;

    }


    LG Fritz

  • Hallo Fritz,


    als deswegen gleich Joomla neu zu installieren? :-)


    Ist mir doch auch schon passiert. Dann guckte bzw. "hoverte" ich über die betreffende Zeile und sah: "Grafik konnte nicht geladen/gefunden werden".
    Pfadanpassung und ... passt. Probier doch mal (wie oben schon gesagt) mit den Punkten davor. Lass die mal weg.


    An der user.css sollte es nicht liegen, da andere Segmente ja greifen. Wäre Seite online, hätten wir sicher längst schon den Übeltäter gefunden.


    Liebe Grüße, Christine

  • Hallo ihr beide,


    Background: url("../images/bild.jpg") stimmt, wenn das Bild im image-ordner des templates (!!!!!) liegt.


    Am besten, du schaust mal, in welchem Verzeichnis dein background bild ist:
    /templates/deintemplate/images/bg1.jpg dann stimmt url("../images/bild.jpg")
    oder
    /images/bg1.jpg dann stimmt url("../../../images/bild.jpg") wenn ich mich nicht verzählt habe


    Und wie Christine sagt: Mit einem link könnte man das Problem schnell klären

    • Hilfreich

    @Christiane
    Hallo Christiane!
    DAS WAR ES!!!! Du bist die Größte! Tausendfachen Dank.
    Dazu habe ich nur noch eine Anmerkung - in all den Forenbeiträgen wird auf diese Problematik NICHT
    hingewiesen. Zumindest habe ich nichts gefunden.
    Jetzt ist es wenigstens dokumentiert!
    Herzlichst Fritz

  • @Indigo66
    Hai Tom ja Du magst ja recht haben, aber Joomla wirbt ja auch damit, dass alles so EASY ist.
    und doch hat es auch hier geraume Zeit gedauert bis in diesem Fall sich Christiane eingeschaltet und die zündende Idee hatte.
    Und noch was in diesem Zusammenhang : Fehlermeldungen von Joomla in so einem Fall wären auch SEHR hilfreich.
    Die Hilfe-Funktion für die Templates ist so schwach, dass sie so direkt überflüssig ist.
    Aber: "Nichts ist so gut, als dass es nicht noch verbessert werden kann" Gell?
    LG Fritz

  • Da muss ich mich nochmal einschalten.


    Auf deiner ursprünglichen Seite hast du genau denselben Befehl wie du schreibst:

    Code
    1. .bild {
    2. background-image:url("../images/bg4.jpg");background-position: 50% 50%;background-repeat: repeat;
    3. }


    Das ist CSS. Wenn du dort schreiben würdest background-image:url("../../images/bg4.jpg"); wäre es falsch. Und du bekämst auch dort keine Fehlermeldung, wie auch?


    Joomla hat keinen Einfluss darauf, wo du deine Bilder ablegst.

  • Hai Tom ja Du magst ja recht haben, aber Joomla wirbt ja auch damit, dass alles so EASY ist.


    Ja wenn es darum geht ein CMS zu bedienen, sprich Content zu generieren, Erweiterungen zu nutzen und mit den Vorgaben von Fertigtemplates zu arbeiten. Du willst die "Standards" nicht verwenden und bist einen Schritt weiter gegenagen und hast den Templatecode bearbeiten. Dafür sind natürlich mind. HTML und CSS Gundkenntnisste (dazu gehört eben auch die relativen Pfade) nötig, sofern man kein mächtiges Templateframework oder einen Pagebuilder verwendet. Und das ist bei "jedem" CMS so, wenn es darum geht das Design über den Code zu verändern.