JoomlaCamp 2018 Essen - 03.02.2017 in Essen

Merkwürdige URLs

    Merkwürdige URLs

    Hallo zusammen,
    Ich habe das Problem, dass in meiner Joomla Instanz merkwürdige URLs zustande kommen und ich diese deaktivieren möchte.

    Wenn ich
    URL/2 (Bsp: musterurl.de/2) aufrufe, zeigt er mir den Beitrag mit der ID 2.

    rufe ich URL/2-EinKategoriename auf, werden mir mehrere Beiträge untereinander dargstellt. Einen Zusammenhang kann ich hier aber nicht erkennen.

    Bisher kenne ich es nur, dass URLS über den erzeugten Alias bzw. mit der entsprechenden /index.php?... aufgerufen werden und brauche nun eine Lösung, dass oben angegebene Fälle unterbunden werden.

    Die suchmaschinenfreundlichen URLs habe ich aktiviert und ich verwende Joomla 3.5.1.

    Vielen Dank im Voraus für eure Antworten.

    Viele Grüße :)

    Nico
    Das ist so alt wie Joomla. Es reicht die ID einzugeben.
    Wenn es passt wird der Artikel mit ID 2 angezeigt. U.U. aber auch die Kategorie. Hängt von der "URL-Umgebung" des Aufrufs ab.

    Gäbe es weder eine Kategorie, noch Artikel mit ID 2, läufts auf eine 404-Seite raus.

    Entscheidend sollte für dich ausschließlich sein, dass Suchmaschinen solche Links auf deiner Seite (also von dir explizit eingesetzt, so dass SuMas überhaupt auf die Idee kommen, die zu indexieren) nicht finden.

    Klar kannst du sehr viel Mühe aufwenden, das per Umleitungen abzufangen (ich würde ein selbst geschriebenes Plugin für die individuelle Seite empfehlen, das logischerweise die Performance der Seite etwas mindert), aber, was Google nicht weiß, macht mich nicht heiß.

    Nebenbei verwende ich dieses Verhalten für bestimmte Kurzlinks bspw. in automatisch generierten PDF-Anschreiben, was die Performance dann wieder erhöht. Will nur sagen: Mir gefällt das so ;)

    Es wird an neuen Routern gearbeitet von @Hackwar . Inwieweit die dann was exakt abfangen werden (wohl ab Joomla 3.7), kann ich dir aber nicht sagen, da ich noch nicht gründlich getestet habe.
    Joomla-Fachmann: ghsvs.de

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Re:Later“ ()

    Re:Later schrieb:

    Es wird an neuen Routern gearbeitet von @Hackwar . Inwieweit die dann was exakt abfangen werden (wohl ab Joomla 3.7), kann ich dir aber nicht sagen, da ich noch nicht gründlich getestet habe.

    Wer nicht so lange warten mag, kann das verwenden: extensions.joomla.org/extensio…sef/sef-wizard-for-joomla
    Damit habe ich bis jetzt alles im Griff. Steht zwar dass es nur ein Plugin sei, ist aber mittlerweile ist es eine ausgereifte Komponente.
    Gruß Tom - JUG-München
    Keinen privaten Support

    "Wir werden nicht größer, wenn wir andere kleiner machen." Phil Bosmans
    Perfekt, lieber Indigo66! Erstmal vielen Dank, habe die Komponente installiert.

    Die ID ist nun aus dem Artikel raus! :)

    Dafür steht am Ende der url /de/?format=html. Leider erzeugt der Link auch einen 404 fehler.

    Ich checks leider nicht. ;( Der Anhang entsteht wenn ich die SEF Wizard Engine aktiviere.

    Aktiviere ich die Engine nicht, beiben die Zahlen in der URL stehen. Weißt Du zufällig wie ich das ausblenden kann?

    Lieben Dank, Silke
    @SilOrs67: Auch erstmal Danke für Deine Hilfe. Wenn ich das SEF Plugin deaktiviere, werden teilweise keine Bilder mehr angezeit - ich hab das Plugin wieder aktiviert.

    @Indigo66: Ja wenn ich das wüsste - an einige Urls hängt sich das format=html dran. Ich weiß leider nicht wann sich das generiert. Ich habe gehofft, dass Du oder jemand anderes das auch hat und mir eventuell sagen kann wie ich das unterdrücken kann.

    In manche Urls hängt sich auch diese Endung dran:"?catid=0&id=308". Dieser Beitrag hat aber nichts mit der Kategorie zu tun. Es entsteht zwar kein 404 Fehler, aber der Inhalt stimmt nicht. Ich löse das im Moment mit Umleitungen - eine rechte Fleißarbeit und ich würde die Generierungen der Endung grundsätzlich ausschalten, dass sich keine Neuen mehr bilden. Es muss an mir liegen. Irgendetwas mache ich nicht richtig. Falls Du mir helfen könntest, wäre ich sehr dankbar.

    LG, Silke
    Hilfreich!
    Hallo Silke,

    ich halte von diesen ganzen SEF Plugins gar nichts. Sie sind meist nur das Problem des Problems. Es reicht wenn Du einfach die Joomlaeigene SEF-Funktion im Backend nutzt.

    Auch die Umleitungsfunktion würde ich deaktivieren. Mit dieser sagst Du Google nur, dass deine alten defekten Links weiterhin gültig sind. Zudem vergibst Du dir die Chance, deine Seite einfach mal neu Indexieren zu lassen.

    Mein Tipp, alle Umleitungen löschen, Umleitungsplugin Deaktivieren. Dann das SEF Plugin löschen und den Browsercasch und Joomlacache leeren.

    LG Faro

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „faro“ ()

    Moin, zum Thema SEF Urls
    Ich bin schon der Meinung dass man eine gewisse Zeit investieren sollte, um mit den SEF Plugins zurecht, bzw. optimal eingestellt zu sein. Immerhin das SEF immer noch ein ziemliches TOP Thema was das gefunden werden im Web angeht. Ich für meinen Teil halte sehr viel von "sprechenden" URLS (da wo es Sinn macht).

    Ich nutze JoomSef und dort kenne ich das "?format=html" aus folgendem Zusammenhang: In dem Plugin kann man dynamisch (URL Attribute filtern) - sprich vom URL ReWrite ausschließen. Das macht auch Sinn, denn sonst würde er in deinem Fall aus dieser "schönen" URL "https://www.cityguide-rosenheim.de/restaurants-rosenheim/strehles-bioladen-vegan-essen.html" ggf. 2 Versionen erstellen - das wiederum findet google gar nicht so schön: Stichwort Duplicated Content. Solche optionalen URL Ergänzungen erkennt Google aber ziemlich gut und kann damit dann entsprechend umgehen (s. Webmaster Tools)
    Vielen Dank und mit Grüßen aus Bremen,
    Kai

    https://www.szenenight.de

    silgra schrieb:

    an einige Urls hängt sich das format=html dran. Ich weiß leider nicht wann sich das generiert. Ich habe gehofft, dass Du oder jemand anderes das auch hat und mir eventuell sagen kann wie ich das unterdrücken kann.

    Hilft dir jetzt nicht wirklich, aber das sind Routerprobleme, besonders dann, wenn nicht direkt der Komponentenrouter verwendet wird, sondern das JRoute::_(). Weiß ich nur, weil das Breadcrumbsmenü gelegentlich ähnliche Probleme hat und ich mal tiefer gegraben habe.

    Die Frage von @Indigo66 war wohl so gemeint. Wo klickst du, wo du anschleißend auf einer Seite mit einer solchen URL landest? Es geht darum, wo diese URLs erstmalig erscheinen. Erst nach dem Klick? Vielleicht durch das Plugin verursacht? Oder schon zuvor auf der Seite als Link oder im Menü oder im Breadcrumbs? Ich konnte jedenfalls einen solchen Link auf deiner Seite nirgends entdecken.

    silgra schrieb:

    In manche Urls hängt sich auch diese Endung dran:"?catid=0&id=308".

    Auch das ist letztlich ein Routerproblem bzw. die unvorsichtige Nutzung derselben. Ich habe mir in den Suchergebnissen und 404 bei einer Seite 100e solcher URLs über ein "cleveres Canonical-Plugin" eingehandelt. Und brauchte dann wieder ein selbst programmiertes Plugin, um den Schotter wieder halbwegs zeiteffizient loszuwerden ;)

    Zurück zu Post #2. Was ist das Problem dabei, dass rein hypothetisch irgendjemand irgendwann irgendwo mal nur eine 2 eingeben könnte???? Was ist das SEO-Problem dabei, dass eine ID in der URL steht???? Tut niemandem weh. Und niemand liest URLs (außer Suchmaschinen). Heutzutage noch weniger als gestern. Und die ID darin stört Sumas nicht. So wie ich das sehe, handelst du dir aus reiner Pedanterie gerade weitaus mehr Probleme ein, als du beseitigst.

    faro schrieb:

    Dann das SEF Plugin löschen

    aber nicht versehentlich das joomlaeigene...
    Joomla-Fachmann: ghsvs.de
    Vielen vielen Dank für Eure Hilfe und Antworten.

    @Indigo66 und alle anderen: Ich habe jetzt rausbekommen, an was es (bei mir) mit der Endung /de/?format=html mit 404 Fehler lag. Und zwar an dem joomlaeigenen Sprachenfilter Plugin. Wenn ich das deaktiviere, ist die URL einwandfrei - ohne Fehler und auch ohne Zahlen. Die Seite ist eh nur in Deutsch. Im Moment sind auf oben stehender Seite, keine Links mehr mit zusätzlichen Endungen zu finden, wenn die Seiten über die Menüführungen aufgerufen werden.

    Wenn ich (oder auch der Google Robot) die URL mit Endung aufrufe, ist sie genauso erreichbar, wie ohne Endung:
    cityguide-rosenheim.de/restaur…an-essen.html?format=html
    cityguide-rosenheim.de/restaur…bioladen-vegan-essen.html

    Und schon hama einen duplicate Content, stimmts?

    @snkai Da bin ich ganz Deiner Meinung. Mich irritiert das wie gesagt - die gleiche Seite mit dem URL-Anhang. Weißt Du zufällig, ob die SEF WIZARD Komponente auch die Möglichkeit hat, die dynamischen URL Attribute zu filtern, auszuschließen?

    Die Webseite die ich gepostet habe, ist 16 Jahre alt - ich habe immer wieder Updates und Anpassungen gemacht und die Seite bis heute weiter entwickelt. Da haben sich im Laufe der Zeit dementsprechend Links im Web angesammelt, die es schon ewig nicht mehr gibt. Deswegen finde ich den SEF WIZARD auch toll, da ich die Umleitungen nicht mehr mit der htaccess machen muss.

    @faro Ich habe jetzt das Umleitungs-Plugin ausgeschalten. Diesen Tipp probiere ich jetzt mal aus. Alles clean, keine Umleitungen mehr. Ich will dem Robot nur erklären welche Links aktiv und gültig sind. Vielen Dank!

    @Re:Later Du sagst es, keine Ahnung was Routerprobleme machen bzw. wie die entstehen. Ich hoffe eben, dass ich nicht mehrere produziere.
    Ich schicke oft einen Link zum Gegenlesen an Kunden. Das ist ein Grund, warum ich die URLS "schön" haben möchte und sie sind ohne Zahlen auch kürzer.

    Nochmals herzlichen Dank an alle für Euer Feedback! Liebe Grüße, silgra
    Hilfreich!

    silgra schrieb:

    Wenn ich (oder auch der Google Robot) die URL mit Endung aufrufe, ist sie genauso erreichbar, wie ohne Endung:

    Na und? Ist ja nicht Penalty DC und außerdem, denkst Du wirklich Google erkennt nicht, das nur ein Parameter anhängt?
    Deine URLs sind ja zu dem auch noch so erreichbar: cityguide-rosenheim.de/restaur…hles-bioladen-vegan-essen also ohne .html.
    Und ich finde bestimmt noch einige andere Parameter die ich anhängen kann (z.B. ?tmpl=component). Wenn diese nicht irgendwo verlinkt sind, warum solten diese dann indexiert werden?
    Ich habe in all den hunderten Projekten, die ich schon gemacht habe nicht einmal ein nennenswertes Problem damit gahabt und werde mich der URL-Hysterie auch nicht hingeben.
    Gruß Tom - JUG-München
    Keinen privaten Support

    "Wir werden nicht größer, wenn wir andere kleiner machen." Phil Bosmans
    @silgra
    Nein ich kenne die Komponente SEF WIZARD leider nicht - ich nutzte wie gesagt JoomSef - damit kann man das ganz einfach pro installierte Komponente einstellen. Aber wie gesagt, lass es einfach über die webmaster tools so einstellen dass er ?format=html wegblockt. Ende :)
    Vielen Dank und mit Grüßen aus Bremen,
    Kai

    https://www.szenenight.de

forum.joomla.de is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.