Update von Joomla 2.5.28 auf 3.5.1 endet mit einer Fehlermeldung...

  • Hallo Zusammen,


    hier nun das Fazit von einem Wochenende, das ich mit Aktualisierungsversuchen verbracht habe.


    Ich habe derzeit insgesamt 3 Seiten mit Joomla 2.5.28. Eine davon habe ich seit Freitagabend vergeblich versucht auf Joomla 3.5.1 zu aktualisieren. Ich hatte dabei fast alle bekannten Fehlermeldungen, von Datenbankfehlern über Fatal Errors bis zur weißen Seite.


    In meiner Verzweiflung habe ich dann versucht eine andere der drei Seiten zu aktualisieren, zusätzlich dazu bei einem anderen Provider. Bei dieser Seite hat die Aktualisierung dann sofort geklappt.


    Meiner erste Vermutung war, dass es am Provider liegt. Um das zu testen, habe ich dann das Gleiche mit der ersten Seite auch probiert. Bei der ersten Seite hatte ich dann allerdings wieder die bekannten Fehler.


    Gleicher Provider aber unterschiedliche Ergebnisse deutet darauf hin, dass es etwas mit der Seite selbst zu tun haben muss. Die Tatsache, dass viele ähnliche Probleme haben, deutet wiederum darauf hin, dass es wohl trotzdem nicht speziell an dieser Seite liegt.


    Der wohl wichtigste Unterschied zwischen den beiden Seiten ist die Datenbankgröße. Bei der Seite mit der kleineren Datenbank, ca. 2 MB, gab es keine Probleme. Bei der anderen Seite mit der größeren Datenbank, ca. 47 MB!, scheitert die Aktualisierung bei beiden Providern.


    Vielleicht hilft diese Beobachtung bei der Fehlersuche.


    Viele Grüße - Harald

  • Gerne poste ich hier auch noch die Fehlermeldungen:


    Ich habe die Datenbank auch einige Male von Hand durchgesehen und keinerlei ungewöhnliche Einträge oder doppelte Keys gefunden.


    Viele Grüße - Harald

  • Beim letzten Versuch habe ich mal noch die zusätzlichen von Joomla ebenfalls kopiert:


    Call stack


    # Function Location


    1 JApplicationCms->execute() /hp/bm/ac/fs/www/infitj35/administrator/index.php:51


    2 JApplicationAdministrator->doExecute() /hp/bm/ac/fs/www/infitj35/libraries/cms/application/cms.php:257


    3 JApplicationAdministrator->dispatch() /hp/bm/ac/fs/www/infitj35/libraries/cms/application/administrator.php:152


    4 JComponentHelper::renderComponent() /hp/bm/ac/fs/www/infitj35/libraries/cms/application/administrator.php:98


    5 JComponentHelper::executeComponent() /hp/bm/ac/fs/www/infitj35/libraries/cms/component/helper.php:380


    6 require_once() /hp/bm/ac/fs/www/infitj35/libraries/cms/component/helper.php:405


    7 JController->execute() /hp/bm/ac/fs/www/infitj35/administrator/components/com_joomlaupdate/joomlaupdate.php:18


    8 JoomlaupdateControllerUpdate->finalise()
    /hp/bm/ac/fs/www/infitj35/libraries/joomla/application/component/controller.php:761


    9 JoomlaupdateModelDefault->finaliseUpgrade()
    /hp/bm/ac/fs/www/infitj35/administrator/components/com_joomlaupdate/controllers/update.php:99


    10 JInstaller->parseSchemaUpdates()
    /hp/bm/ac/fs/www/infitj35/administrator/components/com_joomlaupdate/models/default.php:678


    11 JDatabaseDriverMysqli->execute() /hp/bm/ac/fs/www/infitj35/libraries/cms/installer/installer.php:1180


    Ich hoffe irgend jemand kann damit was anfangen und mir einen Tipp geben, was ich machen bzw. anders machen muss, damit es klappt.


    Viele Grüße - Harald

  • Hallo Harald,


    hab das Problem gestern auch gehabt - am Umfang bzw. Größe meines Webspace glaunbe ich nicht -


    hab zuerst Fehlemeldung bekommen - hab diese weggedrückt - Installation hat sich aufgehängt!


    Zugriff auf Adminebene und Seite war nicht mehr möglich.
    HG
    Roland

  • Hallo CurlY BracketS,


    Erweiterungen als Ursache kann ich ausschließen. Die Erweiterungen, die installiert sind, sind auch auf einer anderen Seite installiert, bei der die Aktualisierung ganz einfach übers Backend funktioniert hat.


    Die beiden Seiten sind also im Wesentlichen gleich, bei einer klappt es, bei der anderen nicht. Ich habe es auch bei unterschiedlichen Providern versucht und die vorgeschlagenen Werte über eine php.ini erhöht.


    Der größte Unterschied zwischen beiden Seiten ist die Datenbank-Größe...


    Bei der Seite mit einer Datenbank von nur 2 MB hat die Aktualisierung problemlos geklappt.


    Bei der anderen Seite mit einer Datenbank von fast 47 MB schlägt die Aktualisierung immer wieder fehl, egal wie ich es versuche.


    Ich habe es heute auch nochmal versucht die Dateien des Update-Pakets per FTP hochzuladen mit Filezilla und der Einstellung, dass er vorhandene Dateien immer überschreiben soll. Leider war auch das wieder erfolglos, allerdings meldet der Internetexplorer jetzt einen 500 Internal Servererror...der Firefox bringt eine weiße Seite und unter Quelltext anzeigen eine graue 1 links oben in der Ecke.


    Ich habe langsam keine Idee mehr, was mir da noch weiterhelfen könnte, aber es muss doch irgendwie möglich sein, dass man nicht schon wieder (wie von 1.5 auf 2.5) alle Inhalte neu erstellen bzw. per copy und paste übertragen muss in eine neu installierte Joomla 3.5.1 Seite... :(


    Ich kann leider auch nur sehr bedingt etwas mit den Fehlermeldungen anfangen. Bei der Aktualisierung übers Backend wird aber scheinbar die Datenbank zerschossen, nicht richtig konvertiert oder der "Datenbanktreiber" nicht richtig installiert...so verstehe ich die letzte Aktion, die Joomla beim Updaten noch meldet...


    11 JDatabaseDriverMysqli->execute() /hp/bm/ac/fs/www/infitj35/libraries/cms/installer/installer.php:1180

  • Hier im Forum gefunden:



    Nur schnell eingeworfen: Das ist bei diesem Update normal, da ab 86% der zeitaufwendige DB-Umbau stattfindet.


    Das ist auch genau der Stand, an dem mein Update abbricht...ein weiterer Hinweis darauf, dass es mit dem Umbau der Datenbank zu tun hat...

    • Hilfreich

    Dann hilft Update per XAMPP machen. Da kannst execution_time etc. beliebig hochschrauben.


    Oder überlegen, ob die DB so groß sein muss.
    _finder_ -Tabellen kann man ja nach Update neu befüllen durch Neuindexierung des Suchindexes.


    _overrider kann man bedenkenlos platt/leer machen. Ist nur eine Cache-Tabelle.


    _redirect_links, falls das Plugin aktiviert ist und Haufen deaktivierte drin sind, zumindest die deaktivierten löschen (Siehe ghsvs.de/programmierer-schnipsel/joomla/129-komponente-umleitung-loeschen-von-eintraegen-per-datenbank)


    _ucm_history ist zu überlegen, ob man die gesammelten Versionierungen überhaupt braucht oder, ob nicht eh neu begonnen werden kann.


    _session kann man auch bedenkenlos leeren vor Update. Muss sich halt selbst neu anmelden.


    Desweiteren im Backend aufräumen. Alles Unnötige auch aus Papierkorb raus usw. usf.


    Käme ich bspw. derzeit auf >10MB Einsparung, verwende aber Indexsuche gar nicht und auch nicht Umleitungskomponente (zumindest sammelt die nicht).

  • Mit XAMPP kenne ich mich überhaupt nicht aus.


    Derzeit habe ich folgende Einstellungen für den Server geändert/gemacht:


    upload_max_filesize = 150M


    max_execution_time = 2500


    mysql.connect_timeout = 800


    error_reporting = E_ALL | E_STRICT


    log_errors = On


    display_errors = Off


    error_log = /hp/bm/ac/fs/www/php-errors.log


    Gibt es eventuell andere Einstellungen, die helfen könnten?

  • Achtung Crossposting:


  • #__banners - Die letzten 5 Spalten heißen bei mir anders???


    #__content_types - scheint alles normal zu sein
    #__tags löschen - nur ein Eintrag (root)
    #__postinstall löschen - habe ich gelöscht

  • Nach der Entfernung der genannten Tabellen lief das Update durch, allerdings kam jetzt ein anderer Fehler:


    1091 - Es ist ein Fehler aufgetreten


    Can't DROP 'idx_tag'; check that column/key exists SQL=ALTER TABLE `#__contentitem_tag_map` DROP INDEX `idx_tag`;


    Ich kann die Datenbank nicht im Backend reparieren... :(


    Wenn ich das Versuche, bekomme ich einen weißen Bildschirm...und als Quelltext wieder die kleine graue 1 links oben in der Ecke...

  • Zusätzlich zu den Problemen mit der Datenbank waren wohl nicht alle Dateien korrekt übertragen worden. Um das zu beheben, habe ich den Ordner libraries koplett entfernt, die Dateien für die vollständige Neuinstallation per FTP nochmal in das entsprechende Verzeichnis kopiert (vorher lokal entpackt) und zum Schluss den Ordner installation wieder gelöscht (hätte man nicht mit hochkopieren müssen).


    Gegen die weiße Seite hilft diese Einstellung in einer php.ini: display_errors = On


    Das war bei mir ursprünglich abgeschaltet, kann nach erfolgreicher Fehlersuche auch wieder abgeschaltet werden (display_errors = Off).


    Meine Probleme sind hiermit gelöst. :)


    Viele Grüße - Harald