neues template und offene prozesse auf dem server

  • hallo joomla-forum,
    ich betreue seit jahren mehrere joomla seiten, stosse jetzt aber auf ein problem was ich - und mein provider - nicht lösen kann.
    ein kunde - der ich schon seit 6 jahr betreue - wollte ein neues design und hat sich dazu ein neues template ausgewählt. es war nicht so toll zu integrieren aber es hat funktioniert.
    nachdem die seite eine weile online war, kommt es immer wieder zu aussetzer. letztendlich hat der provider gesehen dass bestimmte prozesse auf dem server nicht korrekt beenden und er denn irgendwann am limit ist.


    anbei ein alte server-ausgabe, das problem liegt hier im index.php
    bier 515 0.0 0.1 215192 19492 ? S Nov03 1:22 /opt/cpanel/ea-php56/root/usr/bin/php-cgi /home/bier/public_html/index.php
    habe schon versucht verschiedene plugins zu deaktivieren, aber da liegt es nicht dran.
    mein vermuten ist also dass das template die ursache ist. wie kann man aber der fehler aufspuren?


    freue mich auf feedback,
    bart



    joomla 3.8.4 - damals lief es noch auf php 5.6, jetzt auf php 7.

  • hallo elwood,
    dank für deine antwort.


    anbei ein link zur kauf template: https://www.templatemonster.co…-vorlagen-tipo-63595.html
    die seite lauft jetzt gut auf php7 und j 3.8.4, nur... nach ein paar tagen sind es wieder zuviele prozesse und wird es extrem langsam.
    so hat man auch kein direktes feedback ob das problem gelöst ist.
    link zur problem-seite kann ich hier nicht öffentlich posten.


    wenn man fehler berichten auf maximum setzt: bekomme ich 1 warning & ein paar notices.
    alle von mod_swiper, da ist ein templatemonster module.
    ich wird die mal zu beheben.


    habe der template-ersteller auch angeschrieben, aber leider kein feedback.


    grüsse,
    bart

  • Diese Templates taugen nichts, da dort nur geflickt wurde - und wir sind bei Joomla 3.8.4 - spätestens bei J4 wird es eng mit solch alten Templates - hast Du dafür wirklich € 61,- bezahlt oder so ähnlich (habe den genauen Betrag wieder vergessen)?

  • soviel erfahrung mit templates habe ich nicht, aber dieses template war tatsächlich schrott.
    bin jetzt vorsichtiger geworden was kauf templates betrifft und nehme jetzt lieber die templates von ein deutschen anbieter.


    übrigens: der kunde hat das template bezahlt, ich würde nur für das implementieren beauftragt.

  • die seite ist schon ein halbes jahr online, der kauf reklamieren geht also nicht mehr.


    habe nochmal die tickets zu den verkaufer angeschaut. da habe ich das problem geschildert, aber es kommt ein 08 15 antwort: keine fehler im code gefunden und die performance ist von server abhängig. dafür ist nur der provider zuständig.
    der provider (mit wem ich hand in hand arbeite) kann auch nur die logs anzeigen.


    mir wundert es das es keine tools gibt um solche "server prozess probleme" zu lokalisieren.

  • Vielleicht können die Profis hier ja doch mit einem Link zur Seite das Problem und das Template analysieren.


    Wenn es wirklich am Template liegt und andere Templates ohne Probleme funktionieren.


    Zitat

    link zur problem-seite kann ich hier nicht öffentlich posten.


    Das Internet kennt den Link, aber für kostenlosen Support für Fehlersuche ist er geheim?

  • Du darfst in diesem Forum keine Jobs anbieten. Auch nicht über solche Umwege.


    Zitat

    nach ein paar tagen sind es wieder zuviele prozesse und wird es extrem langsam.


    Im Normalfall ist es Job des Servers Prozesse zu beenden und nicht endlos rödeln zu lassen. Selbst dann, wenn irgendein Skript kein Ende findet. Wenn Prozesse tagelang offen bleiben und sich anhäufen, läuft was serverseitig falsch.


    Es könnte auch sein, dass das neue Template einfach etwas mehr Last macht als das alte und dadurch erst ein Flaschenhals der schon immer da war auffällig wird. Dann liegt das aber an der Flasche...


    Nur nebenbei: Ich fände es angenehm, wenn du nicht alles in Kleinschrift posten würdest.

  • Du findest professionellen Support hier


    Die Supporter hier haben natürlich Ahnung, nur kann man sowas nicht klären ohne etwas zu sehen. Vielleicht hat es gar nichts mit dem Template zu tun sondern mit einem Link irgendwo hin ...


    Was ist wenn du auf php 5.6 zurück gehst? Schalte jedenfalls mas alles an, was an Debugging verfügbar ist.
    Unter Konfiguration in den Reitern System und Site. Mit etwas Glück bekommstdu dann Fehlermeldungen. Du kannst das Debugger-Plugin so einstellen, dass nur der Administrator die Meldungen sieht, aber nicht die Anwender. Die Warnnungen und Notices von denne du schreibst kannst du ignorieren. Man müsste sehen was auf der Datenbank geschieht.

  • Du darfst in diesem Forum keine Jobs anbieten. Auch nicht über solche Umwege.


    ok, war mich nicht so bewusst. da achte ich jetzt drauf.


    Im Normalfall ist es Job des Servers Prozesse zu beenden und nicht endlos rödeln zu lassen. Selbst dann, wenn irgendein Skript kein Ende findet. Wenn Prozesse tagelang offen bleiben und sich anhäufen, läuft was serverseitig falsch.


    danke für diesen input, wird ich so mein provider nochmal weiterleiten.

  • osmap-free

    Hat bei mir nur solange funktioniert bis nach wöchentlichen Updates das Framework einfach mitinstalliert wurde. Danach ging bei VirtueMart und SobiPro gar nichts mehr. Zuerst habe ich das Framework gar nicht mitbekommen.


    Nach vielen Tagen und Nächten habe ich dann letztendlich durch das Ausschlussverfahren meine Warenkorbprobleme in VM und die Formularprobleme in SobiPro beheben können.

    Der Übeltäter war dann dieses Framework, welches irgendwie mit diesen Erweiterungen einfach nicht wollte. Nach der Deinstallation der Komponente und der einzelnen Pakete, inkl. Datenbankbereinigung lief dann wieder alles wie vorher.