Joomla wird nicht korrekt aufgerufen.

  • Hallo zusammen


    Ich versuche mal mein problem zu schildern.


    Meine Webseite lässt sich nicht mehr über die Standartdomain https://www.ancestry24.de aufrufen sondern nur noch über https://www.ancestry24.de/index.php/de/


    Was habe ich gemacht.


    Ich habe wegen der Umstellung auf PHP 7.x die gesamte Webseite neu installiert. Jetzt linke ich aber wieder auf die ursprüngliche Datenbank.

    Ich habe neu installiert, weil ich viele Extensions nutze und offensichtlich nicht alle kompatibel sind. An sich funktioniert das bisher auch alles ganz gut, auch wenn ich noch nicht alle Komponenten wieder installiert oder ersetzt habe.


    Nur die Webseite lässt sich wie oben beschrieben, nicht mehr sauber aufrufen.


    Ich hab mir alles selbst beigebracht und bin eigentlich laie in PHP und ähnlichem. Kann eigentlich nur wenig.


    Kann mir eventuell bitte jemand auf die Sprünge helfen? Wo mache ich den denkfehler, was habe ich falsch eingestellt?


    Danke

    Clair

  • Hallo Clair,

    das war vollkommen richtig was du gemacht hast.

    Nun musst du in der neuen Installation noch die Datei htaccess.txt zu .htaccess umbenennen.

    Und eventuell (das hängt von deinemHoster ab) darin das RewriteBase anpassen.

    Am besten vergleichst du die alte .htaccess - vielleicht waren dort noch andere Einträge die du wieder brauchst.

  • Poste auch mal den Inhalt der .htaccess!

  • Ich würde wie oben angegeben "URL Rewrite nutzen" aktivieren (dann spätestens wird die .htaccess zwingend benötigt) und in der .htaccess zunächst die # vor RewriteBase / entfernen.

    Ändert sich dann etwas?

    (mit Ausnahme, dass das index.php wegfällt)


    EDIT: Und sicherheitshalber auch noch eine # vor "Options +FollowSymlinks" setzen, da es sonst auf manchen Servern zu Problemen führen könnte (500er).

  • wenn ich die web.config.txt in web. config umbenenne, wie im Joomla beschrieben, dann ändert sich nichts, auch das index.php ist noch da

    Ob du die .htaccess Datei umbennenen musst oder die web.config hängt auch nur von deinem Servertypen ab. Bei Apache Servern wird die htaccess genutzt bei den Microsoft IIS Servern die web.config.

    Bei welchem Hoster bist du denn? Vielleicht ist der bekannt und man kann so rausfinden ob es ein Apache oder IIS System ist. Ansonsten prüfe nochmal in Ruhe und genau das was meine Vorredner hier gesagt haben. Ich bin mir sehr sehr sicher, dass es damit zusammenhängt...

  • Ich habe gerade festgestellt, dass ich genau diegleiche Problematik auf einer lokalen Joomla Installation mit PHP 7.2 und Apache2 habe. Bei mir ist es aber nicht so kriegsentscheiden, da die Seite nicht im WWW ist, deshalb lasse ich das Problem erstmal so wie es ist, denn auf unserer Webseite läuft das ...


    Clair in deiner .htaccess stehen Einträge mit "Erzwinge www"


    Code
    # Erzwinge www
    RewriteCond %{HTTP_HOST} !^www.
    RewriteCond %{HTTP_HOST} !^$ [NC]
    RewriteRule ^(.*) http://www.%{HTTP_HOST}/$1 [R=301,L]

    was passiert wenn du die auskommentierst? Daraus also ein


    Code
    # Erzwinge www
    #RewriteCond %{HTTP_HOST} !^www.
    #RewriteCond %{HTTP_HOST} !^$ [NC]
    #RewriteRule ^(.*) http://www.%{HTTP_HOST}/$1 [R=301,L]


    machst?

  • Also Domainfactory verwendet zumindest laut deren Blog Appache Server. Also kannst du die web.config schon mal völlig vergessen, die interessiert den Server nicht die Bohne.


    Aber du bist dir sicher, dass deine Datei auf dem Webserver ".htaccess" heißt ? In Joomla ist URL Rewrite auf "Ja", die Zeile "RewriteEngine On" in der Access enthält kein "#" und du hast es mal mit "RewriteBase /" und einmal mit "# RewriteBase /" ausprobiert?

    Das würde mich stark wundern, denn genau das empfiehlt auch DF: https://www.df.eu/de/support/d…faq/htaccess/mod-rewrite/

    Ansonsten kannst du nochmal das entfernen:


    # Erzwinge www

    RewriteCond %{HTTP_HOST} !^www.

    RewriteCond %{HTTP_HOST} !^$ [NC]

    RewriteRule ^(.*) http://www.%{HTTP_HOST}/$1 [R=301,L]

    Das ist ja nicht standardmäßig in der Joomla .htaccess drin. Warum auch immer das einen Fehler reinhämmern sollte...

  • nichts ändert sich