Could not connect to MySQL server

  • Moin zusammen


    Vor zwei Tagen habe ich die Zweoi Faktor Autenzifierung in meinem Joomla Backend aktiviert, ohne mir allerdings den benötigten Code zu merken.

    Gestern Abend habe ich dann , nach dem Studium des Netzes versucht das in der PHP MYAdmin wieder abzuschalten, damit ich für das anstehende Update wieder ins backend komme.

    Die benutzte Joomla Version ist 3.96 und die Seite ist bei DF gehosted. url: yoga-schule.org

    Als Amateur, war ich dabei wohl zu gründlich und habe nicht nur einen Wert auf 0 gestezt.

    Bei beiden Einztägen in der Datenbank stehen nun die Werte:

    Client ID 0

    enabled 0

    acess 1

    protected 0


    Jetzt habe ich damit die Seite unerreichbar gemacht , was natürlich schlecht ist.

    Habt ihr vielleicht einen hint wie die Werte in der Datenbank nun richtig eingestellt werden müssen, damit die Seite wieder laäuft?


    Vielen Dank schon mal im voraus.


    P.S. MySQL Version ist 5.6.19 und PHP Version ist 7.72

  • Die Datenbank hat mehr als nur 2 Einträge. Wo genau hast du Werte geändert? Welche DB-Tabelle? Welches Plugin?

    Dann könnte ich mal schnell nachschauen.

    Wenn das entsprechende Plugin der ZF-Authentifizierung deaktiviert ist, ist es eigentlich egal, wie die anderen Werte des Plugins lauten.


    Folgende Plugins sollten aktiviert sein:

    Authentifizerung - Joomla

    Authentifizierung - Coookies


    Hast du eventuell auch an den DB-Zugangsdaten in der configuration.php etwas geändert?

  • Hallo


    Geändert habe ich hier:

    https://yoga-schule.org/sqladmin


    unter extensions dann bei den plugins:

    plg_twofactorauth_totp

    plg_twofactorauth_yubikey


    Die oben angeführten Werte verändert.


    Ob das aktiviert ist schaue ich jetzt sofort mal nach.

    Authentifizerung - Joomla

    Authentifizierung - Cookies





    Authentifizierung - Cookies ist aktiv

    Authentifizerung - Joomla ist aktiv


    In der configuration.php hab ich nichts geändert


    Es war schon spät in der Nacht, der Mensch der mir sonst bei solchen Sachen hilft ist im Outback in Laos ohne Netz.

    Da ich das Passwort für die Datenbank nicht gefunden habe, hab ich bei DF dieses dann geändert.

    Kann es daran liegen, dass ich nicht mehr an die Seite komme?

    Und wie kann ich das dann ev. korrigieren?

  • Wenn du das DB-Passwort bei deinem Hoster änderst, muss du es natürlich auch in Joomla anpassen, also in der configuration.php neu eintragen.

    Diese mit einem geeigneten Editor öffnen, DB-Passwort ändern und abspeichern. Oder du stellst es bei deinem Hoster zurück!


    Hat aber beides nicht mit der ZFA zu tun. Hättest da also gar nichts dran ändern dürfen.

  • Bei

    Authentifizierung - Cookies steht: Client ID = 0, enabled =1, acess =1, protected =1


    Bei

    Authentifizerung - Joomla steht: Client ID = 0, enabled =1, acess =1, protected =0


    Vielleicht hilft es euch auch zu wissen, dass auf der Seite JCH Optimize und Jotcache laufen.


    "Wenn du das DB-Passwort bei deinem Hoster änderst, muss du es natürlich auch in Joomla anpassen, also in der configuration.php neu eintragen.

    Diese mit einem geeigneten Editor öffnen, DB-Passwort ändern und abspeichern."


    Ok dann versuche ich mich mal daran.


    Also das Datenbank Passwort ist geändert, die Seite wieder erreichbar, nur ins Backend komme ich leider immer noch nicht.


    Versuche ich mich mit meinem UserNamen und Passwort anzumelden kommt folgendes:


    "Es konnte keine Verbindung zum Authentifizierungsdienst hergestellt werden."

  • @JoomlaWunder


    "Hat aber beides nicht mit der ZFA zu tun. Hättest da also gar nichts dran ändern dürfen."


    Es hatte sich zweimal in Serie Jemand als User auf meiner Seite angemeldet obwohl eigentlich die Registrierung neuer User deaktiviert ist. Da habe ich als, sagen wir mal, etwas geübter Laie halt gedacht, ich sichere das System besser ab und hab die ZFA im Joomla Backend aktiviert.

    Das war zu voreilig und nun habe ich den Salat.


    @Indigo66 Das Problem mit dem Datenbank Passwort ist gelöst, die Seite wieder erreichbar, dafür erstmal ein ganz fettes Danke.

  • Es hatte sich zweimal in Serie Jemand als User auf meiner Seite angemeldet obwohl eigentlich die Registrierung neuer User deaktiviert ist. Da habe ich als, sagen wir mal, etwas geübter Laie halt gedacht, ich sichere das System besser ab und hab die ZFA im Joomla Backend aktiviert.

    Das war zu voreilig und nun habe ich den Salat.

    Dann nur als Tipp für die Zukunft. Immer ein Backup machen! Vor allem, wenn man ohne richtige Kenntnisse, in der DB rumfuchtelt.

  • @ JoomlaWunder


    Ja Plugin ..ldap steht auch auf 0


    @ JohannesK


    Es gibt tatsächlich ein backup, da ich aber bisher noch nie mit FTP Geschichten gearbeitet habe und mein Kollege, der sonst sowas macht , das erste mal für mehrere Monate nicht im Netz erreichbar ist, hab ichs halt selbst versucht.


    Man lernt nie aus und ich lese mich aktuell gerade ein wie ich so ein vorhandenes Akeeba backup per file Zilla wieder hochladen kann.


    Wie gesagt Versuch macht klug und ich bin nun leider nicht so ein Experte wie ihr. :-)

  • Leere mal sämtliche Caches (Joomla und Browser)!

    Caches in Joomla: /administrator/cache fürs Backend und /cache fürs Frontend


    Ansonsten wird wohl immer noch eines der Plugins aktiviert sein.


    Wie gesagt, nur

    Auth. - Cookies

    Auth. - Joomla


    benötigst du.


    Zu deiner Frage nach AkeebaBAckup:

    Um ein AkeebaBackup einzuspielen, musst du das .jpa-Archiv zusammen mit kickstart.php in ein leeres Verzeichnis legen und kickstart.php aufrufen. Dann werden die Dateien extrahiert, die DB-Zugangsdaten usw. abgefragt und die DB-Tabellen importiert. Eine leere Datenbank sollte vorher natürlich angelegt worden sein.

    Das Einspielen würde ich grundsätzlich auf einer Subdomain machen. Wenn alles läuft einfach auf die Domain umschalten.

    Nur so für die Zukunft, falls du mal ein Backup einspielen musst.

  • Ihr seid zwar wohl längst woanders, aber

    um die 2-Faktor-Anmeldung für einen User zu deaktivieren, geht man in die Tabelle #__users und löscht für den betreffenden Benutzer die Inhalte der beiden Felder

    otpKey

    otep


    Ein Deaktivieren der Plugins ist nicht nötig. Man sieht dann zwar noch das zusätzliche Eingabefeld, aber braucht keinen Token für Anmeldung eingeben.

  • Ach Leute ihr seid klasse.


    Habe mir gerade file Zilla runtergeladen, mir den Akkeeba Kickstart scribt besorgt komme damit aber noch nicht an meiner Firewall (Windows7) vorbei, bzw. es verliert ständig die Verbindung.

    Ergo versuche ich es jetzt erstmal mit dem Tip von Re:Later.

    Und egal obs funzt oder nicht mache ich mich anschließend schlau wie ich File Zilla ans Laufebn bringe.

  • So


    Das Problem ist gelöst, zumindest teilweise.


    Ein Anruf beim freundlichen DF Kundendienst brachte zu Tage, dass der File Zilla Server bei DF zickt

    Mit dem File Zilla Client Konnte ich das Backup hochladen und wiederherstellen.

    Jetzt komme ich wieder ohne Probleme ins Backend, konnte auf die aktuellste Joomla Version updaten, habe aber nun ein neues Problem.


    Egal welchen Beitrag ich aufrufe erhalte ich folgende Fehlermeldung:


    "

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at [no address given] to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Apache/2.4.39 Server at http://www.yoga-schule.org Port 443"

  • Hmm die .htaccess war schon vorhanden und sieht folgendermaßen aus

    #
    # @package Joomla
    # @copyright Copyright (C) 2005 - 2019 Open Source Matters. All rights reserved.
    # @license GNU General Public License version 2 or later; see LICENSE.txt
    ##

    ##
    # READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
    #
    # The line 'Options +FollowSymLinks' may cause problems with some server configurations.
    # It is required for the use of mod_rewrite, but it may have already been set by your
    # server administrator in a way that disallows changing it in this .htaccess file.
    # If using it causes your site to produce an error, comment it out (add # to the
    # beginning of the line), reload your site in your browser and test your sef urls. If
    # they work, then it has been set by your server administrator and you do not need to
    # set it here.
    ##

    ## No directory listings

    IndexIgnore *

    ## Suppress mime type detection in browsers for unknown types

    Header always set X-Content-Type-Options "nosniff"

    ## Can be commented out if causes errors, see notes above.
    Options +FollowSymlinks
    Options -Indexes

    ## Mod_rewrite in use.

    RewriteEngine On

    ## Begin - Rewrite rules to block out some common exploits.
    # If you experience problems on your site then comment out the operations listed
    # below by adding a # to the beginning of the line.
    # This attempts to block the most common type of exploit `attempts` on Joomla!
    #
    # Block any script trying to base64_encode data within the URL.
    RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
    # Block any script that includes a

  • Ich habe die alte Version erst mal aktiviert komme da zwar nicht ins backend aber sie läuft für die User.


    paralell hab ich ne subdomain: "test.yoga-schule.org" eingerichtet.


    Ein Kollege der aber auch kein Joomla Spezi ist hat mich gelöchert was ich noch in der letzten zeit mit der Seite gemacht habe, und da ist mir eingefallen das ich das Lucid Bottrap plugin deinstaliert habe, weil es eh nicht mehr lief und nicht mehr upgedatet wird.


    Er meinte, ich solle euch mal fragen ob das die Ursache sein könnte.

  • Probieren geht über studieren.

    Ich hab grad mal das URL Rewrite abgeschaltet und so läuft das Ding.

    Im Backend stand bei IIS 7 Servern solle man die "web.config.text" umbennen in "web.config"

    Das Probiere ich jetzt nochmal, hab aber keine Ahnung ob dF so einen Server verwendet.