Beiträge von jgoetz

    Hallo Elwood!


    Möchte mich auch hier ganz ganz herzlich bei Dir bedanken. Das war ganz großes Kino, das ist nicht selbstverständlich, dass ein Forianer sich hinsetzt und abseits der Tipps im Forum auch noch Hand anlegt, um das Problem zu lösen.

    Vielleicht sehen wir einander ja wirklich mal beim Heurigen ;-)

    LG und vielen Dank abschließend auch an alle anderen, die sich die Mühe gemacht haben, dem Thema zu folgen und Hilfe anzubieten.


    Johann

    Ich habe keine Lust, mich durch diesen ganzen Wust zu wühlen, aber:

    - Der TE hat seine Seite per Akeeba offenbar lokal zum laufen gebracht.

    - Da wird man nach den db Treiber gefragt bei der Installation und kann kaum noch mysql wählen

    - Dem TE wurde geraten, den db Treiber in der Konfig auf mysqli umzustellen. Ob er das getan hat, hat er bei schneller Durchsicht nicht mitgeteilt.

    Ich habe alle Empfehlungen vorbehaltlos umgesetzt - also auch das i eingefügt ;-) - hat aber nix genützt

    Wenn du ein Backup hast, kannst du die Seite lokal einspielen (Backup bedeutet immer DB und Dateien). Damit kannst du lokal dann testen. Wenn alles zerschossen ist halt wieder Backup einspielen und neuer Versuch.


    Nicht alle Erweiterungen nutzen die Möglichkeit ein Update mitteilen zu lassen. Wie dieser Mechanismus heißt weiß ich nicht. Auch nicht alle im JoomlaExtensionDirectory angebotenen machen das. Gerade alte oder nicht mehr gepflegte Erweiterungen dürften dafür in Frage kommen.


    Fazit: Weniger ist mehr. Wenn eine Erweiterung nicht mehr gebraucht wird, sollte man sie m.E. besser deinstallieren als deaktivieren. Sie wird sonst vergessen und ist dann ggf. mal das Einfallstor für Hacker.

    Hab zwar ein Akeeba Backup, aber ich kanns mit Kickstart nicht mehr einspielen, weil ich via Configtool des Providers irgendwas am Server angestellt hab, sodass kickstart.php einen Error 500 produziert. Mal sehen, was der Firmenchef noch machen kann, auf die schnelle zwischendurch ist er mal gescheitert, hat aber grad keine Zeit für tiefer einsteigen.

    Sprry, dass ich mich jetzt auch noch einmische, aber ich verfolge diesen Thread von Anfang an und stelle gerade fest, dass hier ein immer grösseres Chaos entsteht hmm


    @ jgoetz


    In #66 schreibst du, du seist auf PHP 7.3.8, im Screenshot #70 geht es um PHP 7.4. Ich will dir nicht zu nahe treten, aber willst du nicht jemanden, der sich damit auskennt, darum bitten, sich das alles selbst mal anzusehen?

    Hallo anka!


    Du beschreibst mein IT-Gefühlsleben grad sehr gut :-) - kein Problem für mich, Du trittst mir nicht zu nahe.


    Zur Erklärung: mit 7.4 kommt die Voreinstellung im Providertool daher, in diesem Tool kann ich fast jede beliebige Version anwählen - und lui-brempt hat die Sachlage sehr treffend zusammen gefasst.


    LG


    Johann


    Danke für die Zusammenfassung. Ich hab jetzt den Provider gequält, der hat einen Dump erstellt und eingespielt - Seite trotzdem keine Verbindung. Da er grad keine Zeit hat, sind wir jetzt mal offline.


    Was mir bisher nicht klar war und ich aus Deinen/euren Hilfestellungen entnommen habe: wir verwenden Programmteile, die nicht über eine Meldung im Backoffice mitteilen, dass ein update zur Verfügung steht und wo ich daher auf der Herstellerseite hätte nachschauen sollen, richtig?


    Die Joomla-updates und die angebotenen Erweiterungsupdates hab ich natürlich immer eingespielt, wobei ich mit dem Hinweis, dass ich vor Joomla-update überprüfen solle, ob alle Erweiterungen kompatibel sind, nichts anzufangen weiß/wusste. Wie kann ich das vorher überprüfen?


    Da ich aktuell nichts mehr machen kann, sage ich mal herzlichen Dank für eure Hilfe, ich werde Bescheid geben, wenn der Provider uns hoffentlich wieder online gebracht hat und dann mal Erweiterung für Erweiterung auf updates checken - kann ja auf meiner lokalen Installation schon mal üben.


    Wünsche euch noch einen schönen Tag

    Eventuell auch mal im Config-Tool unter

    Allgemeines -> PHP-Einstellungen -> Konfiguration -> MySQLi

    nachschauen.

    Da sieht es so aus:




    Aber jetzt hab ich ein offenbar ein gröberes Problem im Providertool verursacht, wobei ich wirklich nicht weiß, was ich da verbockt haben könnte: Im Frontend kommt Error: Failed to start application: Could not connect to MySQL server.


    Im Backend: Warning: session_start(): Failed to read session data: user (path: ) in /home/radgngxc/www.radclub-pielachtal.at/libraries/joomla/session/handler/native.php on line 260

    Error: Failed to start application: Failed to start the session


    Wenn ich euch schon nerve, kann ichs verstehen. Sorry dafür. Eure Geduld ist ein Wahnsinn ...

    Danke, mach ich mich mal drüber her ...


    Evtl testen, nach der Umstellung auf PHP 7 eine neue DB anzulegen, und dort den Dump der jetzigen DB einzuspielen. Danach die neuen DB Daten in die configuration.php eintragen. Das hatte ich mal bei einem Wald- und Wiesenhoster.

    Was Datenbanken anlangt, bin ich völlig plank - auch der Ausdruck Dump in diesem Zusammenhang sag mir nix - obwohl das Hostertool sowas anbietet:



    Hab ich befolgt und in der .htaccess alles was mit php zu tun haben könnte, auskommentiert. Phpinfo.php liefert mir jetzt php7.3.8 - so habe ich es im Providertool eingestellt - also genau gesagt 7.3 und die 8 kommt über phpinfo.php.


    Durch das Auskommentieren der phpzeilen und das Umschalten im Providertool ist die HP wieder weiß mit genau der von Dir genannten Fehlermeldung:


    Warning: session_start(): Failed to read session data: user (path: ) in /home/radgngxc/www.radclub-pielachtal.at/libraries/joomla/session/handler/native.php on line 260

    Error: Failed to start application: Failed to start the session


    Zusatzinfo: ich kann im Providertool für das rootverzeichnis und das darunterliegende Administratorverzeichnis unterschiedliche php-Versionen einstellen. Wenn ich root auf 7.3 und Administrator auf 5.6 setze, dann ist die Webseite weiß mit der hier genannten Fehlermeldung und das Backoffice kommt wie gehabt mit dem Hinweis auf den 5.6 php Fehler

    Ich glaube du versuchst zu viele Dinge gleichzeitig! So schnell kommen die Supporter hier gar nicht nach!


    Das mit dem lokalen liegt daran, dass da sicher kein PHP FPM/FCGI installiert ist und daher der Eintrag in der htaccess gar keine Auswirkung hat...


    Nimm alles bei deiner htaccess raus, ruf deinen Hoster an und sag ihm egal was du Einstellst die PHP Version bleibt immer gleich. So lässt sich das Problem am schnellsten lösen. Um welchen Hoster geht es eigentlich?

    Naja, ich arbeite die Tipps hier halt ab - und bin schrecklich dankbar, dass es Leute gibt, die sich da durchlesen und helfen ...


    Der Hoster ist ein kleines lokales Unternehmen, der unserem Radclub seine Technik kostenlos zur Verfügung stellt. So gesehen tu ich mir etwas schwer, den mit Nachdruck zum Handeln aufzufordern, wenn es möglicherweise gar nicht an ihm liegt - siehe meine Frage bei #58 ganz unten.

    Guten Morgen!


    Hab jetzt noch die Links von Jesus Charlie durchgesehen, damit komm ich leider nicht weiter.


    Da ich nicht überlauert hatte, dass ich die phpinfo.php auch im Störungszustand abfragen kann, hab ich euch wohl auf eine falsche Fährte Richtung Provider geführt - ist das richtig?


    Was noch auffallend ist: ich habe die Datensicherung der spinnenden Homepage 1:1 auf die lokale Maschine gespielt, dort tritt der Fehler nicht auf. Die phpinfo.php zeigt mir dort php 7.3.9, obwohl in der .htaccess AddHandler php-fastcgi5.6 .php eingetragen ist. Jetzt bin ich total verwirrt.


    Könnte eine Neuinstallation auf dem Webserver eurer Meinung nach was bewirken - Versuch wärs ja wert, oder?


    Die deaktivierten und unnötigen Komponenten hab ich mal alle runtergeschmissen.

    Mit AddHandler application/x-httpd-php7.3 .php kommt bei Aufruf der HP dann dieses:



    Mit AddType application/x-httpd-php7.3 .php steh ich wieder auf 5.3.29


    Jetzt hab ich überlauert, was genau Du meinst - und das führt uns, denk ich, einen Schritt weiter.


    Ich hab jetzt im Tool 7.3 eingestellt und dann wie schon gefühlt 100 Mal die weiße Seite mit diversen Fehlermeldungen erhalten. Ich hab aber nicht die phpinfo.php unter dieser Konfiguration getestet - jetzt dank Dir schon. Das Ergebnis:




    Offenbar liefert mein Provider ja richtig an, oder? - deine weiteren Tipps test ich gleich im Anschluss ...

    Zuvor mußt du die .htaccess umbenenen oder die Zeilen die mit AddHandler darin beginnen auskommentieren.

    Ja, das hab ich schon gemacht, wie erwähnt, alles auskommentiert aus der htaccess, jetzt hab ich sie nochmal umbenannt, gleiches Ergebnis: im Providertool kann ich alles einstellen, aber nur bei 5.6 funktioniert die Seite. Sonst die Fehlermeldung mit der Datei native.php - oder sogar noch zusätzliche Meldungen, wenn ich 7.4 im Tool anwähle.

    Das hab ich schon durchgespielt. Voreingestellt ist dort 7.4:


    forum.joomla.de/core/attachment/4506/


    Die Auswahl von Versionen ist umfangreich:



    Und 5.6 ist die einzige Einstellung, in der die Webseite richtig dargestellt wird, ohne diese weiße Seite mit der Fehlermeldung aus Posting #46.

    Ergänzung: in dieser native.php findet sich das:


    {

    throw new RuntimeException('Failed to start the session: already started by PHP.');

    }


    // Fallback check for PHP 5.3

    if (version_compare(PHP_VERSION, '5.4', 'lt') && !$this->closed && isset($_SESSION) && $this->getId())

    {

    throw new RuntimeException('Failed to start the session: already started by PHP ($_SESSION is set).');

    }


    // If we are using cookies (default true) and headers have already been started (early output),

    if (ini_get('session.use_cookies') && headers_sent($file, $line))


    Ist das beachtlich? Weil Fallback check for PHP 5.3 erinnert mich daran, dass bei fehlendem Verweis in der htaccess die 5.3.29 aktiv wird

    Danke schon mal, Tom!


    Noch eine Frage, bevor ich den Provider nochmal anschreibe: wenn ich in der htaccess alles auskommentiere, kann ich im Providertool die php 5.6 anwählen und alles funktioniert - außer die ominöse Fehlermeldung im Backoffice. Bei jeder anderen Auswahl im Providertool bekomme ich diese Fehlermeldung:


    Error: Failed to start application: Could not connect to MySQL server.

    Warning: session_write_close(): Failed to write session data (user). Please verify that the current setting of session.save_path is correct () in /home/radgngxc/www.radclub-pielachtal.at/libraries/joomla/session/handler/native.php on line 194


    Kann dort der Hund begraben liegen - weil der Provider wird mir das sicher entgegenhalten.


    LG


    Johann

    Wieso 7.4 ist doch noch im Beta-Status? PHP 7.3 wäre derzeit zu empfehlen.

    Kann ich nicht sagen, war vom Hoster so eingestellt. Ich habs jetzt im Configtool auf 7.3 gesetzt, aber es ist völlig egal, was dort steht. Wenn in der htaccess auf die 5.6 verwiesen wird, dann funktioniert die Seite mit der Fehlermeldung im Backend, wenn diese auskommentiert wird, fällt die Version auf php 5.3.29 zurück - wie wenn im configtool gar nix bewirkt würde.

    Wenn ich in der .htaccess alles mit php auskommentiere, bleibt im Configtool die Zeile mit der aktiven php Version frei, ebenso der Ordner:











    Und beim Aufruf des Backend kommt:


    Parse error: syntax error, unexpected '[' in /home/radgngxc/www.radclub-pielachtal.at/plugins/quickicon/akeebabackup/akeebabackup.php on line 240


    Wenn ich dann diese Datei deaktiviere - bei in der .htaccess auskommentierten php Befehlen ist die Seite wieder auf php 5.3.x - und die Zeile wie hier oben im Screeshot wieder leer.