Fehlermeldung phpVersion 5.6 im Backend

  • Ich schreib es jetzt einfach nochmal neu und anders:


    Bezüglich deiner letzten Dateiordner-Bilder im post #16:

    Ist auch auf der höchsten Dateiordnerverzeichnisebene also keine der nachfolgend genannten Dateien?

    php.ini oder user.ini oder .htaccess


    Also in dem Dateiordner /

    wo z.B. die Dateiodner .nano und log und logs und logs_old liegen.


    Die Dateiodner logs und logs_old usw. und deren Inhalt und Dateien ist nicht das was von Interesse ist!

    Sondern ob sonst etwas in

    /

    ist.

  • Oh, sorry. Stand auf dem Schlauch. Ist aber nix drin, was mir relevant scheint. guggt mal:


  • Zumindest erst dann das Update durchführen wenn die .htaccess wieder so eingestellt ist das unter

    System -> Systeminformationen auch wieder zumindest 5.6.40 als PHP-Version angezeigt wird

    und dann auch am besten zuerst ein Backup anstoßen, falls nicht bereits erstellt,

    da du ja das ensprechende Akeeba-System-Plugin "Backup on update" vermutlich noch deaktiviert hast.


    Mit der Datei .profile kenn ich mich zwar auch nicht aus.

    Du kannst aber trotzem mal reinschauen ob sich darin etwas mit php befindet.

    Ansonsten mußt du in deinem Account beim Webhoster nachschauen ob du die PHP-Version dort ändern kannst oder deinen Webhoster Fragen wie du zu PHP 7.3 kommst, da ja Standardmäßig offensichtlich die PHP-Version 5.3.29 ausgeführt wird.

  • Zumindest erst dann das Update durchführen wenn die .htaccess wieder so eingestellt ist das unter

    System -> Systeminformationen auch wieder zumindest 5.6.40 als PHP-Version angezeigt wird

    und dann auch am besten zuerst ein Backup anstoßen, falls nicht bereits erstellt,

    da du ja das ensprechende Akeeba-System-Plugin "Backup on update" vermutlich noch deaktiviert hast.

    Ich hab jetzt testhalber in der .htaccess auf die php7.3.9 - das sollte jene des Providers sein, verwiesen. Da kommt jetzt beim Aufruf der Webseite (Back- und Frontend) folgendes:


    Hab jetzt wieder auf 5.6.40 gestellt via .htaccess. Akeebasicherung hab ich eh erst heute erstellt, so gesehen bleib ich jetzt mal auf der 3.9.11

  • Was ich noch gefunden hab im ersten von mir besuchten Thread hier zu diesem Thema - von einem User mit dem gleichen Problem:


    Hallo zusammen,


    erstmal vielen Dank an alle die geantwortet haben. Letztlich hat die aktualisierung des Gantry templates den gewünschten Erfolg gebracht und alles läuft nun wunderbar auf PHP 7.2 ohne weitere Fehlermeldungen.


    Danke für eure Hilfe.


    Gruss


    Opti


    Kann das evtl. hilfreich sein für hier? Ich hab ja diese Gantry Plugins alle deaktiviert. Da gabs Gantry4 und Gantry5:



    Der Thread lief hier: PHP 5.6.40 Fehlermeldung

  • Mit der Datei .profile kenn ich mich zwar auch nicht aus.

    Du kannst aber trotzem mal reinschauen ob sich darin etwas mit php befindet.

    Ansonsten mußt du in deinem Account beim Webhoster nachschauen ob du die PHP-Version dort ändern kannst oder deinen Webhoster Fragen wie du zu PHP 7.3 kommst, da ja Standardmäßig offensichtlich die PHP-Version 5.3.29 ausgeführt wird.

    Mit PHP ist da nix:



    if [ -f ~/.bashrc ]; then

    source ~/.bashrc

    fi


    # MySQL

    PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/mysql/bin/

    export PATH


    alias ll="ls -l"

    alias la="ls -la"


    Hab die Datei vorsichtshalber mal umbenannt, hat keine bemerkbare Auswirkung.


    Meinen Provider hab ich ja schon genervt, nicht soviel wie euch hier ;-) - aber der kommt auch nicht weiter. Ich hatte zwar Zugang zu einem Verwaltungstool, aber dort wurde eben 7.3.9 angezeigt.

  • Nein!

    Du hast nur PHP 5.3.29 oder 5.6.40 zur Verfügung und das liegt in keinem Fall am Template !


    .profile dann aber wieder in den ursprünglichen Dateinamen und Zustand versetzten.

    Die ist ja wohl eigentlich beim Komandozeilenzugang zum Webserver wirksam, also z.B. bei Zugang per SSH

    Falls ich mich nicht irre.



    Ich hatte zwar Zugang zu einem Verwaltungstool, aber dort wurde eben 7.3.9 angezeigt.

    Name des Verwaltungstools ?

    Bildschirmfoto der Einstellung von 7.3.9 im Verwaltungstool hier posten.

  • Zum Verwaltungstool komm ich frühestens morgen wieder - da ist offenbar das PW geändert worden. Muss ich den Provider morgen kontaktieren.

  • Und Vorsicht:


    PHP 5.3 ist in Verbindung mit dem aktuellem AkeebaBackup und Joomla 3.9 absolut nicht empfehlenswert, da nicht kompatibel.

    https://www.akeebabackup.com/c…html#heading-akeebabackup


    Fehlermeldungen wären also nicht ungewöhnlich.

    Deaktiviere also mindestens das Plugin "System - Backup on Update" ! Könnte aber weitere Probleme mit AkeebaBackup geben. Eventuell AkeebaBackup deinstallieren und Webseite manuell sichern (also per FTP und DB-Tabellen exportieren).

    Besser aber , du bekommst deine PHP-Version korrekt eingestellt.


    Falls du bereits Sicherungen mit AkeebaBackup durchgeführt hast, würde ich nicht unbedingt davon ausgehen, dass diese fehlerfrei sind, wenn es Inkompatibilitäten gegeben haben sollte.


    EDIT: Die originale htaccess liegt jedem Joomla bei in Form einer htaccess.txt. Musst du halt nur umbenennen (also mit Punkt davor und ohne Dateiendung).

  • Ok, hab jetzt mal testweise die originale .htaccess eingespielt. Tut sich nix, außer dass ich dann auf php 5.3.x bin und wenn ich Akeeba Backup aufrufe, mecker bekomm, dass die php-version zu niedrig ist und akeeba deshalb nicht ausgeführt wird.


    Hab Akeeba auch testhalber mal deaktiviert, die Ausgangsfehlermeldung ist aber immer noch da ...