Website vom Server auf USB-Platte mit Akeeba/Kickstart übertragen ??

  • Hallo,

    ist es grundsätzlich möglich, mittels Akeeba/Klickstart eine website vom Server (Alfahosting) auf eine USB Platte am PC zu übertragen ??

    Bei mir jedenfalls funktioniert's (bis jetzt) nicht.

    Das Problem ist die „Restoration of site's main database“ in Kickstart.

    Ehrlich gesagt, ich weiß auch nicht, welche Daten da eingegeben werden müssen:

    Die Zeilen 1 und 2 dürften mit MySQL und localhost OK sein.

    Und die Zeilen 3, 4 und 5 sind die Daten vom Server ?? und nicht von XAMPP ??

    und was genau muss in Zeile 6 eingetragen werden ??


    1. Zeile: Databas typ: MySQL (PDO driver)
    2. Zeile: Databasy server host name: localhost
    3. Zeile: User name ?
    4. Zeile: Password ?
    5. Zeile: Database name ?
    6. Zeile: Database table name prefix ? (vxjke_)


    Vielleicht kennt sich ja jemand damit aus und kann mir helfen. (Habe Joomla 3.9.14 und PHP 7.2.26)

    Danke

    Ciao

    Girgei

  • Du musst eine Datenbank via phpMyAdmin erstellen und dann die dort von Dir angelegten Daten Datenbankname, -benutzer und Passwort eintragen. Der Tabellenpräfix ist bei der Joomla-Installation vorgegeben worden und wird von Akeeba übernommen.

    Hallööchen und danke für den Tipp

    Ich muss also in, bzw. mit XAMPP noch eine neue Datenbank erstellen ??

    Und an das Tabellenpräfix den Namen der neu erstellten Datenbank anhängen ?? oder in Zeile 6 nichts weiter eintragen ??


    Danke für weiter Hilfe

    Ciao

    Girgei

  • Klar kannst du von deinem Provider auf die Festplate umziehen:

    Als user_name trägst du "root" ein (also ohne Hochkommata),

    als db-Typ dann "mysqli",

    als db gibst du den Namen der in Xampp vorher angelegten Datenbank an (DB wird mittlerweile sogar automatisch angelegt, brauchst du also vorher gar nicht machen)

    host ist "localhost",

    das Passwort einfach leer lassen, da in Xampp standardmäßig keines vorgegeben ist. In Xampp könnte man prinzipiell eines anlegen und dieses dann verwenden.


    Das Präfix wird automatisch übernommen.

  • Vielen Dank für Dein TUT. Ist ja eigentlich simpel, wenn man es erst mal weiß, wie es geht. Ohne neuer Datenbank ist es allerdings nicht gegangen.

    Die Wiederherstellung ist dann ohne Fehlermeldung über die Bühne gegangen.
    Aber ich kann die website nicht aufrufen,. Ich habe jetzt eine index.php mit nur 2 KB und die vom administrator hat auch nur 2KB wogegen die "echte" auf dem Server hat ca. 1400kb oder so. Irgendwas haut da noch nicht hin.

    Nur was ??

    Danke für weitere Hilfe

    Ciao

    Girgei

  • Das sind wohl 1420b nicht kb und ist dann somit auch so korrekt.

    Liegt dein Joomla jetzt direkt unter /htdocs oder in einem Unterverzeichnis vo /htdocs ?

    Und mit welcher URL versuchst du die Seite aufzurufen?

    Beispielsweise: http://localhost/dein-unterverzeichnis/administrator/

    (sofern deine Seite in einem Unterverzeichnis liegt)


    Prüfe auch gleich die SEO-Einstellungen sowie die Menüpunkte. Liefern diese ein 404, müsste noch mit der .htaccess gerbeitet werden.

  • Das sind wohl 1420b nicht kb und ist dann somit auch so korrekt.

    Liegt dein Joomla jetzt direkt unter /htdocs oder in einem Unterverzeichnis vo /htdocs ?

    Und mit welcher URL versuchst du die Seite aufzurufen?

    Der Pfad zum Stammverzeichnis von Joomla ist:

    z:\XAMPP\apps\joomla\htdocs

    (Z ist die USB Platte)

    Und zum Kontrollzentrum ist die URL :https://192.168.137.1/joomla/administrator/index.php

  • Hallo,

    wenn ich das richtig gelesen habe, hast Du einen "Umzug" vom Server zu lokal (Xampp) vorgenommen und dort läuft jetzt die Seite nicht, oder?

    Wie sieht die configuration.php aus?


    Christian

    Bitte hier:

    class JConfig {

    public $MetaAuthor = '0';

    public $MetaDesc = 'Infos zu unserer Musik, zu Grünsink und dem Pfarrstadel. Enfach mal reinschauen!';

    public $MetaKeys = 'blaskapelle, musik, musizieren, orchester, probe, blechbläser, holzbläser, proben, konzert, ';

    public $MetaRights = '';

    public $MetaTitle = '1';

    public $MetaVersion = '0';

    public $access = '1';

    public $cache_handler = 'file';

    public $cachetime = '15';

    public $caching = '0';

    public $captcha = '0';

    public $cookie_domain = '';

    public $cookie_path = '';

    public $db = 'joomla_xampp';

    public $dbprefix = 'vxjke_';

    public $dbtype = 'mysqli';

    public $debug = '0';

    public $debug_lang = '0';

    public $display_offline_message = '2';

    public $editor = 'tinymce';

    public $error_reporting = 'default';

    public $feed_email = 'none';

    public $feed_limit = '10';

    public $force_ssl = '2';

    public $fromname = ' ';

    public $ftp_enable = '0';

    public $ftp_host = 'ENTFERNT';

    public $ftp_pass = 'ENTFERNT';

    public $ftp_port = '21';

    public $ftp_root = '/';

    public $ftp_user = 'ENTFERNT';

    public $gzip = '0';

    public $helpurl = 'https://help.joomla.org/proxy?keyref=Help{major}{minor}:{keyref}&lang={langcode}';

    public $host = 'localhost';

    public $lifetime = '29';

    public $list_limit = '20';

    public $live_site = '';

    public $log_path = 'Z:/XAMPP/apps/joomla/htdocs/administrator/logs';

    public $mailer = 'mail';

    public $mailfrom = 'jth3344@gmail.com';

    public $memcache_compress = '0';

    public $memcache_persist = '1';

    public $memcache_server_host = 'localhost';

    public $memcache_server_port = '11211';

    public $offline = '0';

    public $offline_image = '';

    public $offline_message = 'Diese Website ist zurzeit im Wartungsmodus.<br />Bitte später wiederkommen.';

    public $offset = 'UTC';

    public $offset_user = 'UTC';

    public $password = '';

    public $robots = '';

    public $secret = 'IyfMxbm8Bu69O63PwnkOXmEk0KKLLcMa';

    public $sef = '1';

    public $sef_rewrite = '1';

    public $sef_suffix = '0';

    public $sendmail = '/usr/sbin/sendmail';

    public $session_handler = 'database';

    public $sitename = ' Girgeirestoresite';

    public $sitename_pagetitles = '0';

    public $smtpauth = '0';

    public $smtphost = 'localhost';

    public $smtppass = '';

    public $smtpport = '25';

    public $smtpsecure = 'none';

    public $smtpuser = '';

    public $tmp_path = 'Z:/XAMPP/apps/joomla/htdocs/tmp';

    public $unicodeslugs = '0';

    public $user = 'root';

    public $mailonline = '1';

    public $cache_platformprefix = '0';

    public $memcached_persist = '1';

    public $memcached_compress = '0';

    public $memcached_server_host = 'localhost';

    public $memcached_server_port = '11211';

    public $redis_persist = '1';

    public $redis_server_host = 'localhost';

    public $redis_server_port = '6379';

    public $redis_server_auth = '';

    public $redis_server_db = '0';

    public $proxy_enable = '0';

    public $proxy_host = '';

    public $proxy_port = '';

    public $proxy_user = '';

    public $proxy_pass = '';

    public $massmailoff = '0';

    public $session_memcache_server_host = 'localhost';

    public $session_memcache_server_port = '11211';

    public $session_memcached_server_host = 'localhost';

    public $session_memcached_server_port = '11211';

    public $frontediting = '0';

    public $asset_id = '1';

    public $replyto = '';

    public $replytoname = '';

    public $shared_session = '0';

    public $session_redis_persist = '1';

    public $session_redis_server_host = 'localhost';

    public $session_redis_server_port = '6379';

    public $session_redis_server_auth = '';

    public $session_redis_server_db = '0';

    public $debug_lang_const = '1';

    }

  • Versuche mal: http://localhost/administrator/


    Bist du sicher, dass in deinem Pfad der Platte das /htdocs ein Unterverzeichnis ist von /joomla. Möglicherweise ist es genau andersherum. Das wäre der Normalfall. Dann versuche:

    http://localhost/joomla/administrator/

    geht leider gar nicht Fehlermeldung: Objekt nicht gefunden.

    Übrigens beim Aufrufen wie oben : :https://192.168.137.1/joomla/administrator/index.php

    kommt:

    Ihre Verbindung ist nicht privat

    Dieser Server konnte nicht beweisen, dass er 192.168.137.1 ist. Sein Sicherheitszertifikat wird vom Betriebssystem Ihres Computers als nicht vertrauenswürdig eingestuft. Mögliche Gründe sind eine fehlerhafte Konfiguration oder ein Angreifer, der Ihre Verbindung abfängt.

    NET::ERR_CERT_AUTHORITY_INVALID


    Vielleicht hift das irgendwie weiter ??

    Ciaao

    Girgei

  • Das hat bereits ein Admin gemacht ;) . Jetzt musst du aber unbedingt(!) noch dein FTP-Passwort beim Hoster ändern. Sämtliche Zugangsdaten waren hier eine ganze Weile für jeden sichtbar, und man weiss nie, ob sich da nicht ein böser Bube (oder Mädel) darunter befindet.

    So?? ist aber noch da!

    1000 Dank für Deine Aufmerksamkeit. DasPW habe schon geändert.

    Danke

    Ciao

    Girgei

  • ..... und wenn du vorher beschriebenes gemacht hast:

    Scheinbar wird versucht die Webseite vom Webserber abzurufen. Ist die .htaccess lokal im Einsatz. Da steht dann eventuell noch die Domain vom Webserver drin, vielleicht die SSL-Weiterleitung?!? Müsstest du dann anpassen bzw. entfernen!