Aufruf Backend wird auf Frontend umgeleitet

  • Hallo Leute ich soll bei einer Seite helfen komme aber selber nicht mehr weiter. Das Problem ist folgendes.


    Wenn ich den Administrator Bereich öffnen möchte komme ich wieder auf die Startseite. Ich vermute es hat etwas mit K2 zu tun das installiert ist. Bin mir daher auch nicht ganz sicher ob die Frage hier auch richtig ist ;) Mit K2 habe ich bis jetzt nicht gearbeitet.


    admintool ist auch drauf das hätte ich mal deaktiviert hat aber nichts gebracht.


    Welche Infos braucht ihr noch um hier vielleicht helfen zu können.


    Joomla ist 3.9

    PHP ist 7.4

    K2 ist auf 2.9.0 was ich raus finden konnte


    Danke für eure Hilfe

  • Typischerweise passiert das meist, wenn man einen zusätzlichen Schutz des administrator-Verzeichnisses realisieren möchte.

    Man kann hier z.B. weitere Zugangsdaten über eine .htaccess- und .htpasswd-Datei nutzen. Oder man verändert den Aufruf des administrator-Verzeichnisses von z.B. example.org/administrator zu example.org/admin oder was auch immer. Manchmal hängt man an die URL auch noch bestimmte Daten ran. All das solll vermeiden, dass man die Login-Maske auf einfache Art und Weise aufrufen kann. Ruft man selber den Link nicht korrekt auf, wird meist zur Startseite weitergeleitet.

    Meine erste Frage wäre deshalb die Frage nach einem Sicherheitsttool gewesen. Admintools wäre mein erster Tipp.


    Du hast es wohl nicht komplett deaktiviert. "Caches leeren" könnte hierbei auch eine wichtige Rolle spielen. Ansonsten schau mal in die .htacces rein, ob da noch was drinsteht, was man rausnehmen sollte.

    Ich nutze Admintools nicht. Bin mir deshalb auch nicht sicher, ob deaktivieren überhaupt reicht. Besser deinstallieren!


    Alternativ: Richte dir einfach einen zusätzlichen Passwortschutz für das Backend ein (wie oben erwähnt). Das ist ein wichtiger Grundschutz und reicht vollkommen aus.


    EDIT: Falls du K2 verwenden möchtest, müsstest du es auch aktualisieren! Aktuell gibt es die Version 2.10.3. Wenn nicht, dann deinstalliere es einfach!

    Joomla selber sollte die Version 3.9.23 sein.

  • Wenn ich den Administrator Bereich öffnen möchte komme ich wieder auf die Startseite.

    bist Du im Frontend eingeloggt? Wie rufst Du den Administrator Bereich auf?

    Gibt es ev. einen .htaccess Schutz?

    admintool ist auch drauf das hätte ich mal deaktiviert hat aber nichts gebracht.

    Wie hast Du denn das deaktiviert, wennst ins Backend nicht mehr kommst? Oder via Datenbank gemacht?

    Verwende dieses Admintool (gab da oder dort bei Usern schon Probleme damit) nicht.

    K2 kenne auch ich nicht. Aktuelle Version: V2.10.3 https://getk2.org/

    Joomla ist 3.9

    welche genau?


    In Moment haben wir mehr Fragen als Du :-)


    Frohe Weihnachten & liebe Grüße

    Christine


    OT: JoomlaWunder: Hab erst jetzt Dein Posting gesehen. Warst schneller :-)

  • Hallo Danke mal für euer Antworten ich werde mal schauen was ich alles beantworten kann :S

    .htaccess ist der Standard der von Joomla mit kommt da wurde nichts verändert im admin order ist nur die index.php

    Zitat


    aufruf des administrator-Verzeichnisses von z.B. example.org/administrator zu example.org/admin

    wo kann man das machen?


    admintools habe ich über FTP wie hier beschrieben deaktiviert


    Zitat


    welche genau?

    Ja gute frage ich konnte nur 3.9 finden aber welche genau leider nicht. Wie komme ich ohne Backend zu einem genaueren Ergebnis?


    Andere Erweiterungen habe ich in der DB leider nicht finden können. Vielleicht habe ich aber auch am falschen Ort gesucht. Wo genau sollte ich den schauen.


    Ich habe mal versucht das Admin Verzeichnis um zu benenne da komme ich etwas weiter weil da bekomme ich dann einen Fehler vom K2 Modul daher vermute ich das es am K2 liegen könnte.


    Ohne Backend updaten von K2 ist denke ich nicht so einfach möglich oder?

  • Joomla-Version ermitteln: Rufe folgendes auf!

    example.org/administrator/manifests/files/joomla.xml

    (example.org durch deine Domain ersetzen)

    Das wird möglicherweise aufgrund der Weiterleitung nicht funktionieren.


    Was genau hast du in Admintools eingestellt? Ich vermute, dass es zu 99% daran liegt und nicht an K2.

    Wahrscheinlich musst du in der Datenbank noch das ein oder andere Plugin von Admintools deaktivieren. Wie gesagt, ich arbeite damit nicht und kann dir da deshalb auch keine konkreten Tipps geben, ohne mich da jetzt einzuarbeiten.


    Hast du die .htaccess mal wirklich verglichen, da Admintools da wohl auch reinschreibt bzw. diese neu erstellt?


    Ansonsten könnte ich dir wieder ab morgen Abend weiterhelfen, indem ich mal einen Blick auf die Seite werfe.

    Dazu bräuchte ich dann aber mindestens FTP-Zugang und eventuell auch Zugang zu phpmyadmin. Kontakt könntest du oben über "Konversation" aufnehmen.

  • An K2 liegt es sicher nicht. Bist du dir sicher, Admintools wirklich deaktiviert zu haben? ECC+ ist nicht installiert? Mir fällt da spontan noch der Ark Editor ein, der früher solche Sperenzchen machte. Allerdings konnte man sich ins BE einloggen. Muss man genauer analysieren, wenn du magst, schicke mir ne Mail (siehe Signatur) mit Link zum Backend und einen FTP Account, und ich schaue da mal rein.

  • ...Aufruf des administrator-Verzeichnisses von z.B. example.org/administrator zu example.org/admin...

    wo kann man das machen?

    Siehe z.B.:

    https://www.web-worker-berlin.…minverzeichnis-verstecken


    https://wicked-software.de/adm…is-per-htaccess-schuetzen

  • ... ich konnte nur 3.9 finden aber welche genau leider nicht. Wie komme ich ohne Backend zu einem genaueren Ergebnis?

    Siehe z.B.:

    https://docs.joomla.org/How_to…dere_M.C3.B6glichkeiten_6


    wie gekommt man die Joomla version raus die installiert war

  • Danke mal für eure Hilfe und das auch zu den Festtagen. Ich bin selber gerade nicht oft am PC darum melde ich mich gerade jetzt erst wieder.

    Joomla-Version ermitteln: Rufe folgendes auf!

    example.org/administrator/manifests/files/joomla.xml

    3.9.1 ist dabei raus das hat sich auch ohne Problem aufrufen lassen


    Ich muss auch noch mal Sagen ich habe auf der Seite bis jetzt noch nicht einstellt da ich hier selber vom Besitzer um Hilfe gebeten würde.

    Die .htaccess hab ich gelöscht und ersetzt die sollte es dann eigentlich nicht sein.


    Ich denke schon das ich es deaktiviert habe. Werde mich mit euch dann am Montag noch mal in Verbindung setzten bezüglich Zugang.

    Ja das habe ich mir auch gedacht konnte ich aber nicht finden das es so etwas geben würde.

  • Hallo Leute ich hab jetzt mal die Lösung gefunden. Es war kareebu Secure der das Problem gemacht hat. Nach dem ich über FTP die ksecure.php umbenannt hatte konnte ich wieder zugreifen. Zu finden ist diese unter plugins / system / ksecure. Nach der Homepage nach wurde die Entwicklung eingestellt da es dies nur noch für Joomla 1.5 gibt.


    LG