weiße Seite - Hilfe

  • Liebe Leute, ich benötige eure Hilfe.
    Auf meiner Seite wurden diverse "Unterseiten" nicht mehr angezeigt sondern nur eine weiße Seite.


    Nun habe ich den "Vorschlag" befolgt und habe die index.php-Datei wie folgt geändert:
    <?php phpinfo(); ?>


    Zusätzlich habe ich in der configuration.php
    var $gzip = '0';
    var $error_reporting = 'maximum';


    geändert


    Nun wird weder ein Fehler auf meiner Homepage angezeigt. Noch die Startseite... Die Startseite ging vor der Änderung noch...


    Ich bin am verzweifeln, da ich mich nicht auskenne und nicht weiter weiß.


    Ich bitte um eure Hilfe. Das Backend funktioniert noch.


    Die Homepage lautet: www.spta.at


    Vielen Dank für eure Unterstützung.

  • als erstes solltest du die beiden sachen mal wieder rückgängig machen!


    - hast du ein backup deiner Seite ? ( per Ftp + die Datenbank und ggf vielleicht mit akeeba backup übers BE)
    - welche Version von Joomla und php version nutzt du ?
    - Fehlerberichten einstellen kanst du bequem aus dem BE machen: SYSTEM -> Server -> dann Fehler berichtenim Klappmenu auf: Maximum stellen (das was du in der config.php gemacht hast)
    und nun ggf. auf der FE Seite deiner Homepage die angezeigten Fehler hier posten
    - Welche Änderungen wurden an der Seite vorgenommen bevor es zu den weißen Seiten kam ?

  • Willkommen an Bo(a)rd,

    Ich bin am verzweifeln, da ich mich nicht auskenne und nicht weiter weiß.
    Ich bitte um eure Hilfe. Das Backend funktioniert noch.


    Bevor Du weiter rumdoktorst: wir brauchen Informationen:

    • Joomla-Version?
    • Welche Erweiterungen sind am start?
    • PHP-Version; MySQL-Version
    • Was hast zuletzt gemacht, nachdem die Seite noch lief (bzw. bevor sie den Dienst quittiert hat)?

    Im Regelfall trifft mindestens einer der Ursachen I - III zu: http://getserver.de/sonstiges/58-joomla-weisse-seite.html

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )

    Einmal editiert, zuletzt von hechtnetz ()

  • Du hast deine Joomla-Projekte nicht sauber genug angelegt.
    Dein Joomla 3.6.5 ist in einem Unterordner, während dein altes Joomla im Root-Verzeichnis liegt. Hier wirken sich wahrscheinlich wieder .htaccess-Dateien auf die darunter liegenden Verzeichnisse aus. Beide benötigen auch unterschiedliche PHP-Versionen. Für Joomla 3.6.5 am besten PHP 7.0, mindestens aber 5.6.
    Und dann ist da noch die Weiterleitung (wie von Christine beschrieben).


    Schiebe die Projekte am besten alle in parallele Unterverzeichnisse vom Root (configuration.php noch anpassen), lass das Root-Verzeichnis selber frei, und stelle die Domain bzw. Subdomain auf das gewünschte Verzeichnis ein. Dann hast du keine gegenseitigen Beeinflussungen.


    GZIP und die Cache-Nutzung kannst du zum Testen erst einmal deaktivieren!


    phpinfo() diente lediglich dazu, die PHP-Version usw. zu ermitteln. Entferne dies wieder!

  • die Änderungen in der index.php und der configuration.php habe ich sofort wieder rückgängig gemacht, als ich gesehen habe, dass nun die Startseite auch weiß ist und nicht nur einzelne Unter-Menü-Seiten.


    Ich habe akeeba backup im backend - hier wurde die letzte Sicherung im Oktober 2016 gemacht. Danach hat das Akkeba keine Sicherungen mehr erfolgreich gemacht.
    ich weiß aber nicht wie man das einspielen könnte.


    joomla-Version 3.6.5


    ja die Unterseite ist jene die nicht funktioniert. Ich musste mal die Homepage neu machen. Deshalb gibt es spta.at/index.php welche dann auf die spta.at/spta weitergeleitet wird. welche eben nun das Problem macht.


    MySQL 5.5
    PHP 5.6 -> Hier gäbe es die Version 7


    mein provider-Support meint die weisse Seite könnte durch das joomla-update kommen. Diese habe ich vor einigen Wochen gemacht. Ich habe aber nicht jede einzelne Seite durchgeschaut ob alle noch funktionieren.


  • danke für die Erklärung und ich würde dies ja sehr gerne machen, nur kenne ich mich hierfür einfach zu wenig aus. Da brauche ich jemand der soetwas kann. Ich mach da nur was kaputt. nur ist es schwer jemand zu finden der einem so etwas macht....

  • nur kenne ich mich hierfür einfach zu wenig aus


    Nu komm, der Anfang ist gemacht.

    • Mach ein aktuelles Backup.
    • Geh mal ins Backend und aktualisiere alles, was angezeigt wird (Sprachdatei ist ja schonmal 3.6.5)
    • Dann wieder ein Backup und das gut bewachen.
    • Hausaufgabe (ich gehe jetzt Fußball gucken): Die Domain sollte direkt auf den Unterordner zeigen und nicht weitergeleitet werden. Schau bei Deinem Hoster nach, wie das gemacht wird. Bevor Du es umsetzt: prüfe, ob es eine Datei .htaccess im Jommla-Verzeichnis gibt oder die Datei htaccess.txt heißt.

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )