AcyMailing 5 aund 6

  • Hallo,

    ich bin neu bei Joomla und habe mir ein Template besorgt, das acyMailing 5 bei der Installatin automatisch mitinstalliert hat.

    Auf der Website von acyMailing habe ich gesehen, dass es schon die Version 6.10.3 gibt.


    Meine 3 Fragen:

    1) kann ich die Version 5 deaktivieren oder löschen und dann die Version 6 installieren? In der Version 5 von acyMailing sind noch keine Einstellungen gespeichert.

    2) Wird die Version 5 mit Joomla 4 kompatibel sein oder muss ich dann sowieso die Version 6.x benutzen?

    3) Oder gibt es eine gute Alternative zu acyMailing für den E-Mail-Versand, die voraussichtlich auch mit Joomla 4 kompatibel sein wird?


    Danke.

    Jürgen

  • Das es eine 6.3.10 gibt, war mir auch neu. Auf einer Seite lief tatsächlich noch eine 5.9.6 (Autsch!) Diese hat die Joomla-Update-Funktion noch nicht genutzt.

    Das Installieren der neuen Version führt zu einer Art Migration. In deren Verlauf kannst du dann die bisherigen Daten/Einstellungen aus 5 übernehmen. Am Ende wird noch eine Testemail verschickt und ähnliches. Dies habe ich dann übersprungen.


    Merkwürdigerweise ist Acymailing 6 parallel zu 5 installiert worden. Hätte ich so nicht erwartet.

    Nun weiß ich selber nicht, ob Version 5 vielleicht ohne das "Überspringen" am Ende automatisch deinstalliert worden wäre. Muss man wohl manuell deinstallieren, natürlich hinterher, wenn man die bisherigen Daten übernehmen möchte.


    Hast du in 5 noch nichts eingerichtet, würde ich diese vorher deinstallieren.

  • Die 6 gibt es ja schon länger. In der Update-Prüfen-Ecke von AM wurde man allerdings auf eine nicht existierende 5-er Version als Update hingewiesen. Die leitete aber auf 6. Ich habe das damals der Werbung für 6 wegen ("noch doller") also installiert/"geupdatet" und das Ergebnis war komplette Irritation.

    (Auch im JED steht übrigens "5.10.13")

    Es hat sich aber viel seitdem an der 6-er geändert. Trotzdem überlege ich es mir seitdem 2x, ob ich mal eben das "Update" auf 6 mache ;-)

    Merkwürdigerweise ist Acymailing 6 parallel zu 5 installiert worden.

    Zum Glück ;-)


    Acymailing hat es einfach versäumt, das irgendwo klarer zu beschreiben.


    Eine Neuinstallation sollte aber natürlich 6 sein.


    Da Vieles der AM-Programmlogik sowieso nicht so Joomla-Standard-nah ist, denke ich schon, dass es das weiterhin für J 4 geben wird.

  • Morgen,


    Acymailing 5 und 6 sindzwei völlig verschiedene Komponenten. Du kannst es sogar parallel Betreiben.

    Du hast dann auch 2 Menüpunkte in Komponenten.


    Wenn dann im 6er alles funktioniert, kannst du einfach die 5er deinstallieren.


    Ich habe selbst z.T. beide Versionen installiert, da ich nach und nach den Wechsel anstrebe. Solange es aber für 5 noch Updates gibt und es nicht EOL ist habe ich keine hohe Prio dafür.

  • Acymailing 5 und 6 sindzwei völlig verschiedene Komponenten. Du kannst es sogar parallel Betreiben.

    Irgendwie vermisse ich da eine Gegenüberstellung beider Komponenten, was kann die eine und was die andere. Zumindest konnte ich keinen Versionsvergleich finden. Vermutlich wurden die optionalen Plugins für die 5er-Version nun in die 6er integriert? Weiß das jemand?


    Nun verstehe ich auch diese merkwürdige chronologischen Changelogs. 5.10.13 kam im März 2020, obwohl es die 6er-Version schon länger gab.

  • Weiß jemand, wo man die aktuelle 5.10.13 downloaden kann?

    Auf deren Webseite findet man nur die aktuelle 6er-Version und die Changelogs-Liste, aber nirgends die 5er.


    Unter "Erweiterungen"->"Aktualisieren" wird kein Update angezeigt und in der Komponente selber wird die 5.9.6 als aktuelle Version eingestuft.


    Gemeint ist die Free/Starter-Version.

  • Irgendwie vermisse ich da eine Gegenüberstellung beider Komponenten, was kann die eine und was die andere. Zumindest konnte ich keinen Versionsvergleich finden. Vermutlich wurden die optionalen Plugins für die 5er-Version nun in die 6er integriert? Weiß das jemand?

    Ich kann dir nur sagen dass ich es bereue überall schon auf die 6er umgeswitcht zu haben. Rein vom bedienen her, gerade was die Templates betrifft, war die 5er schon sehr unkomplizierter. Mag aber auch Geschmackssache sein. Ansonsten wüsste nicht nicht, zumindest in der free Version, was die 6er mehr könnte. Evtl. im statistischen Bereich.

  • Weiß jemand, wo man die aktuelle 5.10.13 downloaden kann?

    Code
    https://www.acyba.com/index.php?option=com_updateme&ctrl=updatexml&component=acymailing&cms=joomla&level=starter&version=5.10.13

    Nimm die tar.gz! Die zip sind leer!

    Ohne Garantie, dass die darin enthaltenen Download-Links das liefern, was du haben willst. Ich glaube allerdings schon nach Sichtung der XMLs.


    Bei mir laden ALLE tar.gz-Links eine 5.10.14. Wohl ein Release von heute.

    Auch, wenn man das Ganze bspw. mit 5.10.15 oder 5.10.10 im tar.gz-Link ausprobiert oder obige XML mit 5.10.15 ausprobiert oder wasimmer auch.

    Schätze also 5.10.14 ist schon richtig.


    Heb dir den Link gut auf, weil es jedesmal reichlich Gebastel ist, bevor man den dann aus den Einzelteilen, die in Installationspaketen rumschwirren wieder zusammen hat ;-) Aus den Joomla-Aktualisierungsquellen war er nämlich irgendwann mal verschwunden.


    Die wollen einfach nicht mehr, dass man 5 verwendet, habe ich den Eindruck ;-)