TemplateDetails.xml wird nicht gefunden

  • Hallo,

    ich habe auf meinem Rechner Joomla 3.10.2 installier um zunächst mit den beiden Templates ein wenig zu üben um eines von beiden auf meine Bedürfnisse anzupassen. Das ist nun schon einige Zeit her und habe es aufgegeben, da nach dem Erstellen einer Kopie alles irgendwie durcheinander war.

    Jedenfalls waren die einzelnen Blöcke nicht da wo sie im Original sein sollten.

    Auch beim Beez Template fehlte das Headerbild vollkommen.


    Also habe ich meinen Rechner gequält und mir in den letzen Wochen Unmengen an Youtube Videos zum Thema Html und Css reingezogen, sowie ein Handbuch zum Thema.

    Alles wunderbar und habe auch sehr viel gelernt. Das Ergebnis, eine kleine Webseite in html und css. Diese funktioniert auch, doch was viel wichtiger für mich ist, zu verstehen wie so eine Seite aufgebaut ist und wie diese mit css gestylt werden kann.


    Mein html Datei habe ich ergänzt und als index.php gespeichert.

    In der templateDetails.xml wurden von mir alle notwendigen Eintragungen gemacht und auch in Anlehnung an da keine Template aus dem Weihnachtstürchen hier aus dem Forum überprüft ob alles vorhanden ist.


    Leider gibt es hier bei der Installation ein Problem. Es wird von Jommla eine Fehlermeldung ausgegeben, das die templateDetails.xml nicht gefunden wird, obwohl diese im gepackten zip Archiv vorhanden ist. hmm


    Wäre schön, wenn mir hier jemand einen Rat geben könnte, oder bereits ähnliche Erfahrungen gemacht hat.


    Gruß Herbert63

  • Hast du das Template so aufgebaut, wie es vorgesehen ist? (Anleitung)


    Hinweis:

    Wenn du dir was Neues aufbaust, warum nicht gleich mit J4?
    Aber auch für J3 gibt es jede Menge simple Templates, die man nach Bedarf erweitern kann. Da kann man sehr schön erkennen, wie das mit dem css funktioniert.
    Ich würde mir das mit dem selber schreiben ehrlich gesagt gründlich überlegen.

  • Sorry, das ich meinen Beitrag in den falschen Forenteil gesetzt habe.


    Mit Joom 4 habe ich mich leider noch nicht auseinandergesetzt, da da zunächst eine komplett neue Oberfläche im Backend zu Sache steht und ich gewiss einige Zeit benötige um mich da reinzufinden.


    Für mich ist daher erstmal wichtig zu wissen wie ein Template aufgebaut ist und mit diesem Template welches ich geschrieben habe, auch die Zusammenhänge besser verstehe und so Änderungen vornehmen kann, die letztlich auch funktionieren. Persönlich macht es für mich keinen Sinn in einem fertigen Template was zu ändern, wenn ich von html und css keinen Plan habe.

    Gruß Herbert63

  • Persönlich macht es für mich keinen Sinn in einem fertigen Template was zu ändern, wenn ich von html und css keinen Plan habe.

    Dann ist es aber auch schwierig, etwas eigenes zu entwerfen. Ein fertiges Template kann zum Analysieren dienen und man kann es als Grundgerüst für sein eigenes Template verwenden.


    Sonst poste mal die templateDetails.xml! Vielleicht ist bei dieser etwas falsch. Dann würde ich aber eher eine andere Fehlermeldung vermuten.

    Oft ist es aber auch nur ein Schreibfehler, z.B. wenn das "D" im Dateinamen klein geschrieben wird.

    Oder werden Umlaute irgendwo verwendet? Z.B. im Templatenamen? Ist jetzt geraten.


    Mein html Datei habe ich ergänzt und als index.php gespeichert.

    Diese index.php vielleicht auch mal posten!

  • Hallo, hier mal die "templateDetails.xml"


    <?xml version"1.0" encoding="utf-8"?>
    <!DOCTYPE install PUBLIC "-//Joomla! 3.10//DTD template 1.0//EN" "http://www.joomla.org/xml/dtd/3.10/template-install.dtd">

    <extension version= "3.10" type= "template" client= "site">


    <files>
    <folder> css</folder>
    <folder> images </folder>
    <filename> template.css </filename>
    <filename> content.png </filename>
    <filename> headerbild.png </filename>
    <filename> index.php </filename>
    <filename> template_preview.png </filename>
    <filename> template_thumbnail.png </filename>
    <filename> templateDetails.xml </filename>
    </files>


    <positions>

    <position> menu </position>
    <position> breadcrump </position>
    <position> main-navigation </position>
    <position> suche </position>
    <position> sidebar </position>

    </positions>


    </extension>

  • Hallo,

    mit den Leerzeichen werde ich mal probieren, glaube jedoch nicht das es daran liegt, sonst würde mir das der Editor bereits anzeigen.


    Als Editor verwende ich Visual Studio Code auf dem Mac und auch unter Windows. Dieser zeigt mir unten auch beim Speichern das

    gewünschte Dateiformat.


    Werde aber mal noch einiges ausprobieren.



    Gruß Herbert63

  • Hallo miteinander,


    habe den Fehler nun endlich gefunden. Bin daran selbst Schuld gewesen. Nach dem ich nun alle notwendigen Eintragungen in der templatDetails.xml gemacht hatte, wie <name>, <author> und und und funktionierte es auch nicht. Der Grund hierfür war ganz simpel. Ich hatte beim Erstellen des ZIP- Archives den Namen geändert. Also, wer mal das gleiche Problem hat, der Name des ZIP-Archives muss identisch mit dem vergebenen Namen in der temlateDetails.xml sein.


    Gruß Herbert63 , ein schönes Wochenende und vielen Dank für Eure Unterstützung