Datenbankfehler bei Joomla Neu-Installationen - durch Reparaturfunktion nicht behebbar

  • Habe hier drei Joomla Neuinstallationen. Alle drei wurden auch auf 3.9.8 upgedatet. Ob die Fehler vor dem Update schon drin waren, weiß ich nicht.

    An einer der Installationen experimentiere ich gerade für mein neues Joomla-Projekt, die anderen befinden sich noch in "jungfräulichen" bzw. in unvermurkstem Zustand… so dachte ich jedenfalls, bis ich die Fehlermeldungen zur Datenbank sah. Durch Click auf "Reparatur" blieb alles unverändert.


    Daraufhin habe ich gedacht, ich hätte etwas zerschossen, weil viele Erweiterungen installiert und nach Test wieder deinstalliert worden waren. Folglich prüfte ich die beiden anderen Joomla-Installationen. Dort hatte ich haargenau die gleichen Fehler:

    Fragen: Wie konnte es zu diesen Fehlern kommen? (und noch besser:) Wie bekomme ich die Fehler weg?

    Muss ich jetzt über MySQL-Admin von Hand in den DBs korrigieren? Und wenn da steht, dass da der "falsche Typ" oder das "falsche Attribut" gesetzt sei, weiß ich doch davon nicht, was dort richtiger Weise einzutragen ist.


    Wenn ich das aber alles ignoriere, baue ich evtl. meine neuen Websites auf Sand und darf später womöglich neu anfangen. Was tun?

  • Habe hier drei Joomla Neuinstallationen. Alle drei wurden auch auf 3.9.8 upgedatet. Ob die Fehler vor dem Update schon drin waren, weiß ich nicht.

    ??? Neu oder geupdatet?


    Wenn geupdated: Welche Version lief vorher? Wie bist du beim Update vorgegangen?

    Von wo hast du Joomla heruntergeladen?

    Welcher Hoster?

    Welche PHP-Version?

    Wird die DB als "aktuell" angegeben?

  • Hi!

    Die Erst-Installation habe ich aus dem Webpaket Joomla vorgenommen, das mir mein Webhoster https://webgo.de zur 1-click-Installation bereit stellt. Es war Joomla Version 3.9.7 und ich musste nur ein Mal updaten. Das Updaten nahm ich über den Joomla-eigenen Mechanismus im Backend vor, kam also direkt von den Joomla Repositories.


    Warum es in der Datenbank Einträge von 2012 gibt, verstehe ich auch nicht. Die DBs waren unbenutzt weil von mir zur Installation angelegt.


    Mir ist die Vorgehensweise unbekannt, wie ich in einem HTML_Editor eine Datenbank öffnen kann! Ich arbeite hier mit dem Bluefish-Editor, da ich von Windows 7 auf Ubuntu umgestiegen bin. Aber auch da sehe ich keine Möglichkeit, damit eine Datenbank zu öffnen oder gar zu editieren. Müsste ich dazu einen Dump herunter laden und die DB lokal öffnen?

  • Man verwendet einfach keine "1-click-Installation"en von Hostern, sondern nimmt sich IMMER ein korrektes und AKTUELLES Original-Paket und wählt bei der Installation die empfohlenen DB-Typen, also MySQLi.


    https://downloads.joomla.org/


    Man installiert auf einer MySQL MINDESTENS Version 5.5, damit keine utf8mb4-Probleme auftreten. Wobei schon die total veraltet ist. Selbstverständlich geht auch eine kompatible MariaDB.


    Und dass 2.5.0-Dateien ins Spiel kommen, hat schon grundlegend seine Richtigkeit. Dass die bei dir nach einer Neuinstallation als Fehlerquelle auftauchen allerdings nicht. Ebenso wie alle anderen, die ja vor der angeblichen 3.9.7 liegen.


    Und wenn du nach diesen Tipps immer noch die selben Probleme hast, wende dich an den Hoster.

  • Zitat

    Mir ist die Vorgehensweise unbekannt, wie ich in einem HTML_Editor eine Datenbank öffnen kann!

    Klappt mit z.B. Phase 5 einwandfrei.



    Zitat

    Müsste ich dazu einen Dump herunter laden und die DB lokal öffnen?

    Jepp, genau so habe ich es gemacht.



    Zitat

    da ich von Windows 7 auf Ubuntu umgestiegen bin.

    Dazu kann ich leider keine Hilfe anbieten.

  • Schade, dieses Thema ist NICHT erledigt!


    Ich habe gerade komplett neu installiert, direkt von ttps://downloads.joomla.org und danach das deutsche Sprachpaket. Es erschien die Meldung:

    Warnung Achtung: Die Datenbank ist nicht auf dem neuesten Stand!

    Und das ergab daraufhin die Datenbank-Prüfung:


    Also witzig find ich das nicht und durch die Funktion "Reparieren" tut sich auch nix. Ich glaube sogar, dass es die gleichen Meldungen sind, wie in meinem ersten Beitrag hier.


    Vor der Neu-Installation hatte ich natürlich sowohl das Installationsverzeichnis auf dem Server als auch die alte Datenbank sorgfältig gelöscht.


    Damit ist dann auch mein Webhoster https://webgo.de aus der Kritik! Dessen Leistungen und Kundenservice fand ich bis jetzt hervorragend! Bin gerade erst zu ihm gewechselt.


    Gemäß der bisherigen Diskussion: Muss ich also jetzt nach jeder Neu-Installation einen DB-Dump runterladen, im Editor korrigieren (dann müsste ich aber genau wissen, was ich als Korrektur eintragen müsste) und alles wieder hoch laden. – Also das kann es doch nicht sein mit Joomla!

  • Damit ist dann auch mein Webhoster https://webgo.de aus der Kritik!

    Inwiefern? Wenn dort eine FRISCHE Joomla-Installation nicht klappt und bereits nach der Installation die Datenbank defekt ist und es bei allen anderen klappt, kann es ja nur ein Fehler von dir sein oder eben vom Hoster oder von dem von dir gewählten Paket.


    Wüsste jetzt nicht, was Gefrickel an der Datenbank bringen sollte, außer dass es vielleicht eine Zeit lang scheinbar problemlos läuft. An der DB spiele ich dann rum, wenn ein älteres Joomla mal aufgibt, aber doch nicht, wenn eine Neuinstallation gleich defekt ist.

  • Muss ich also jetzt nach jeder Neu-Installation einen DB-Dump runterladen, im Editor korrigieren (dann müsste ich aber genau wissen, was ich als Korrektur eintragen müsste) und alles wieder hoch laden. – Also das kann es doch nicht sein mit Joomla!

    Nein, natürlich nicht.

    Ich behaupte mal ganz kühn, dass, wenn Du das o. g. Joomla-Paket bei Dir lokal in Uwamp oder XAMPP installierst keine Fehler angezeigt werden. Womit dann wieder der Hoster den schwarzen Peter hätte.

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )

  • Sorry aber da komme ich nicht mit: Ich lege SQLi-Datenbanken an und bei der Joomla-Installation werden diese mit Daten befüllt. Was kann denn da schief laufen?


    Meinst du wirklich, man schreibt in die Datenbank was rein und anschließend steht was anderes drin, als reingeschrieben worden ist???

  • Meinst du wirklich, man schreibt in die Datenbank was rein und anschließend steht was anderes drin, als reingeschrieben worden ist???

    Nach Deinen Fehlermeldungen geht es nicht ums falsche Reinschreiben (in Tabellen, nicht Datenbank). Die Tabellen werden offensichtlich falsch angelegt.

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )

  • wenn Du das o. g. Joomla-Paket bei Dir lokal in Uwamp oder XAMPP installierst

    Tu Dir/uns mal den Gefallen. Wenn die Fehlermeldungen da auch kommen, dann können wir weiterreden. Wenn es an Joomla liegen würde, dann wären die Foren davon schon voll. Bisher scheinst Du aber Einzige zu sein.

    JustMy2Cents

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )

  • Was mir bei dem ganzen nicht ersichtlich ist: Wie wurde die Datenbank angelegt? Das ist von Hoster zu Hoster verschieden.

    Ich habe fbeim Lesen fast den Eindruck, dass in deiner Datenbank bereits vor der Joomla-Installation Tabellen enthalten sind.


    Wenn ich eine Neuinstallation bei einem Hoster mache muss ich sicher sein dass eine Datenbank angelegt wird in der KEINE Tabellen enthalten sind. Bitte überprüfe das.

    Dann prüfe, ob Datenbank und Systemumgebung den aktuellen Anforderungen entsprechen:

    https://downloads.joomla.org/technical-requirements

  • So wie ich das auf die Schnelle sehe, kann man bei deinem Hoster zwischen Mysql, Mysqli, Maria DB.... wählen.

    Da solltest du keinesfalls mysql verwenden! Dazu hast du dich noch nicht geäußert.


    Übrigens:

    Hast du ein Webhosting-Paket oder gar einen eigenen Server?


    PHP 7.2 wird noch immer als neu angegeben. Die meisten Hoster bieten schon lange PHP 7.3 an.


    PHP scheint auch als Modul zu laufen. Schau mal unter Systeminformationen nach (PHP-Interface). Weiß aber nicht, ob es deine Problematik verursachen kann.

  • Ich war gestern im See schwimmen, daher erst jetzt meine Antwort.


    Ich habe den gesamten Sachverhalt dem Hoster geschildert, er hat alles nachgeprüft und behauptet nun folgendes:

    1. Ja es liegt an der Datenbank, weil man grundsätzlich nur noch mySQL Version 8 Datenbanken anbietet.
    2. Joomla kommt (zumindest in Versionen unter 4.0) nicht mit diesen mordernen Datenbanken klar.
    3. Der Webhoster empfiehlt mir, die alternativ angebotene MariaDB zu wählen, obwohl diese offiziell von Joomla nicht empfohlen oder supported wird.

    Meine Schlussfolgerungen:

    1. Da MariaDB nicht offiziell von Joomla unterstützt wird, könnte es bereits bei der nächsten Major-Version von MariaDB zu ähnlichen Kompatibilitäts-Problemen kommen, wie jetzt bei mySQL 8.
    2. Joomla-User sind, falls sich an der Datenbank-Kompatibilität von Joomla ändert, aktuell zwischen den Stühlen, weil mySQL 8 noch nicht funktioniert und MariaDB wegen mangelndem offiziellen Support von Joomla ein Kompatibilitätsrisiko darstellt. Dies kann leicht geschehen, wenn Joomla mySQL 8 fähig gemacht wird.

    Nun nochmals zur Klarstellung meiner Installationen:

    Ich habe aktuell zwei seit Jahren laufende Joomla-Sites vom bisherigen Webhoster zum neuen umgezogen. Vorher hatte ich Joomla und alle Extensions auf Aktualität geprüft und die (mySQLi-) Datenbank mit dem Joomla-eigenen Mittel geprüft. Erst als alles sicher OK war, habe ich mit AkeebaBackup gesichert und die Sites auf dem neuen Webspace installiert. Dabei habe ich sicher gestellt, dass in neue Datenbanken installiert wurde, die garantiert keinen Inhalt hatten.

    Ferner habe ich aktuell noch eine Joomla-Installation, die über das Installationspaket des Hosters gelaufen ist und drei neue angelegte, bei denen ich das zuvor aktuellste Joomla-Paket entpackt und per FTP hochgeladen habe und ebenfalls streng darauf geachtet hatte, dass die angegebenen Datenbanken absolut leer waren.

    Bei allen drei Installationsvarianten ergaben sich immer die gleichen 19 Fehlermeldungen die Datenbank betreffend.


    Nach meinen daraufhin heute morgen angestellten Webrecherchen laufen zahlreiche Joomla-Installationen seit Jahren stabil mit MariaDB 5.xx bis 10.xx - Seit Sommer 2018 (?) gibt es aber mySQL-8 und wenn das Joomla-Team wegen seiner Verbundenheit zu mySQL hier künftig die Kompatibilität herstellen wird, kann es sehr wohl mit Maria-DB zu Problemen kommen, für die es dann von Seiten Joomla keinen Support geben wird! Und genau das ist das eigentliche Problem.


    Mir wird aktuell nichts anderes übrig bleiben, als alle meine bisher installierten Sites neu zu installieren und dabei MariaDB verwenden, um aktuell stabile Verhältnisse zu bekommen.

    Bisher habe ich keine Joomla-Instabilitäten mit mySQL-8 feststellen können (weder bei den alten umgezogenen beiden Sites, noch bei den neu angelegten) außer eben die Fehlermeldungen, die Joomla mir ausgibt. Es mag ja sein, dass ich auch künftig nicht mit Problemen rechen muss, aber ich halte es für riskant, darauf zu spekulieren.


    Dem Webhoster werfe ich vor, wenn er schon Joomla-Pakete zur Installatiion anbietet, wenigstens die Information dazu zu liefern, bei Joomla bis auf Weiteres die Maria-DB zu verwenden. Durch dieses Unterlassen hat der Hoster mir rund eine Woche Arbeitszeit vernichtet – gerechnet für die jetzt neu anstehenden Neu-Installationen sowie den bisherigen Aufwand, den Fehler zu finden und zu diskutieren.


    Frage hier jetzt noch:

    Wie würdet ihr jetzt an meiner Stelle entscheiden – Maria-DB verwenden oder es (zumindest bei den beiden Produktiv-Sites) bei der jetzigen mySQL-8-Nutzung belassen bis evtl. wirklich Fehler auftreten?