Ich habe gewechselt auf PHP 7.3 nun zeigt er mir Fehler

  • Hallo und guten Tag.

    In meinem Webinterface werde ich immer aufgefordert meine PHP Version anzupassen weil die 7.2 keine Updates mehr bekommt.

    Das habe ich heute mal gemacht, jetzt wird meine Webseite nicht mehr angezeigt und hat im error_log folgendes drin.

    Mein Webhoster kennt diesen Fehler nicht.

    Evtl. muss ich erst einmal bei 7.2 bleiben, es sei denn hier weiß jemand was ich machen kann.


    Code
    [26-May-2017 15:20:57 Europe/Berlin] PHP Fatal error: Class 'JVersion' not found in /home/ressexde/ressertrailfraeser.de/includes/framework.php on line 25
    [21-Sep-2017 23:28:30 Europe/Berlin] PHP Fatal error: Uncaught exception 'RuntimeException' with message 'Library path /libraries/src cannot be found.' in /home/ressexde/ressertrailfraeser.de/libraries/loader.php:415
    Stack trace:
    #0 /home/ressexde/ressertrailfraeser.de/libraries/cms.php(33): JLoader::registerNamespace('Joomla\\CMS', '/home/ressexde/...', false, false, 'psr4')
    #1 /home/ressexde/ressertrailfraeser.de/includes/framework.php(18): require_once('/home/ressexde/...')
    #2 /home/ressexde/ressertrailfraeser.de/index.php(40): require_once('/home/ressexde/...')
    #3 {main}
    thrown in /home/ressexde/ressertrailfraeser.de/libraries/loader.php on line 415
  • Hm, sieht mir jetzt eigentlich nicht nach Fehlern aus, die durch einen Wechsel der PHP-Version verursacht werden. Eher nach fehlenden Dateien.


    Ist denn dein Joomla aktuell?


    Ich würde in sso einem Fall und, falls Joomla aktuell ist ein Komplett-ZIP-Paket entpacken, Ordner /installation/ und /templates/ der entpackten Dateien löschen. Rest per FTP drüberbügeln.


    Abschließend im Backend unter Erweiterungen > Datenbank den Reparieren-Knopf klicken.


    Hilft oft, nicht immer.

  • Ich bin hier etwas ratlos, habe aber den Entwickler angeschrieben....

    Der Entwickler vom Allrounder Template hat seines mit der aktuellen PHP 7.3 selber am laufen und auch das Wettermodul welches von ihm ist.

    Ich werde mal ein Standard Template morgen benutzen und melde mich dann wieder.

  • Ich melde mich wieder zurück...

    Also folgendes, der Hoster hat wohl ich sage mal kein Interesse, solche Kleinigkeiten zu lösen...


    Ich habe jetzt die PHP 7.4 eingestellt und die Hompage läuft wieder.

    Ich sage mal das hätte auch von denen kommen können wie immer nur zu sagen es liegt an einem Modul oder Plugin...


    Oder kann es sein das Joomla in der neuesten Version PHP 7.4 voraussetzt.?

    Ich wei es leider nicht.


    Mit dem drüber kopieren behalte ich mal im Auge, weil ich noch immer einen Datenbank Fehler habe.


    Ich sage hier mal Danke für die Unterstützung.

  • Hallo,

    Oder kann es sein das Joomla in der neuesten Version PHP 7.4 voraussetzt.?

    Systemvoraussetzungen: https://www.joomla.de/joomla/anforderungen, siehe: Empfehlung: 7.3+

    Ich sage mal das hätte auch von denen kommen können wie immer nur zu sagen es liegt an einem Modul oder Plugin...

    Es kann sein, dass Erweiterungen noch nicht kompatibel mit 7.4 sind. Entwickler kontakten.


    Habe u.a. gesehen, dass Deine Phoca Gallery nicht am neuesten Stand ist.

    Mit dem drüber kopieren behalte ich mal im Auge, weil ich noch immer einen Datenbank Fehler habe.

    Welchen Fehler denn?


    Liebe Grüße

    Christine

  • wie schon geschrieben mit der 7.4 geht alles wieder.

    Laut Systemanforderung sollte die 7.3 wohl auch laufen.

    Meine ganzen Plugins sind alle von den offiziellen Anwendern von Joomla, ocer zumindest runtergeladen.

    Die zwei einzigen Dinge die von Bakual.net sind das Wettermodul und das Template. Den Entwickler habe ich kontaktiert, bei ihm läuft alles mit PHP 7.3


    Ich hatte ja heute den Test gemacht mit einem Standard Template aus Joomla und weiter nichts drin, kein Plugin nichts weiter und die Seite ist mit 7.3 sofort gecrasht.

    Ich habe diese Test Installation extra dafür weil ich schon mal Probleme hatte, so kann ich immer gut selber testen ob es an mir liegt, sobald das funktioniert kann ich es auch auf meine HP übernehmen.


    Die Datenbank Fehler kommen immer wenn ich Joomla, direkt auf dem Hoster Panel aktualisieren möchte.

    Ich bekomme ja von denen immer eine Mail wenn es eine neue Version gibt klicke ich dann bei denen im Webinterface auf Update fängt er an und zeigt dann eine lange Reihe von Fehlern an.

    Ich werde das demnächst mal hier rein stellen.


    Ich mache dann das Update von Joomla über das eigene Administrator Interface.

  • Hallo,

    Die Datenbank Fehler kommen immer wenn ich Joomla, direkt auf dem Hoster Panel aktualisieren möchte.

    Ich bekomme ja von denen immer eine Mail wenn es eine neue Version gibt klicke ich dann bei denen im Webinterface auf Update fängt er an und zeigt dann eine lange Reihe von Fehlern an.

    Ich werde das demnächst mal hier rein stellen.

    würde ich so nicht machen. Was wolltest Du denn noch hier rein stellen?

    Ich mache dann das Update von Joomla über das eigene Administrator Interface.

    Ja, so.


    Aufgrund der Datenbank error.txt: Hast Du Dir schon die Datenbank angesehen? Sieht diese ca. so aus oder anders?



    Liebe Grüße

    Christine

  • Hallo,

    würde ich so nicht machen. Was wolltest Du denn noch hier rein stellen?


    Liebe Grüße

    Christine

    die Datenbankfehler wollte ich noch reinstellen, habe es ja dann per Textdatei gemacht ;) hatte ich vorher geschrieben als ich die Datei noch nicht reingestellt hatte.


    Also das mit der Struktur schaue ich mir demnächst mal an ob ich da was finde, da ich davon so gut wie keine Ahnung habe und noch dazu noch nie etwas gemacht habe verstehe ich sowieso nicht woher diese Fehler kommen.... aktuell weiß ich auch noch nicht wie ich das bereinigen kann.

    Hatte es immer ignoriert, da ich ja von Administrator Bereich alles machen konnte.

  • Also das mit der Struktur schaue ich mir demnächst mal an ob ich da was finde, da ich davon so gut wie keine Ahnung habe und noch dazu noch nie etwas gemacht habe verstehe ich sowieso nicht woher diese Fehler kommen.... aktuell weiß ich auch noch nicht wie ich das bereinigen kann.

    Hatte es immer ignoriert, da ich ja von Administrator Bereich alles machen konnte.

    Was heißt demnächst? - Ist ein 5 Sekunden Klick im backend. :-)


    Liebe Grüße

    Christine

    https://docs.joomla.org/Help39…nsion_Manager_Database/de

  • Vielen Dank an euch beide, das habe ich heute mal gemacht, angezeigt wurde mir aber nichts. Fehler meine ich.

    Mal schauen wenn das nächste Joomla Update kommt dann werde ich es ja sehen, probiere dann die Variante vom Provider Panel aus nochmal und schaue ob da immer noch Fehler angezeigt werden.

  • Mal schauen wenn das nächste Joomla Update kommt dann werde ich es ja sehen, probiere dann die Variante vom Provider Panel aus nochmal und schaue ob da immer noch Fehler angezeigt werden.

    Davon wurde dir ja bereits abgeraten. Aktualisiere immer vom Backend aus und du vermeidest von vornherein einige Probleme!

    Auch sollte man beispielsweise Nachinstallationshinweise beachten! Hin- und wieder ist auch mal eine Änderung in einer eventuell genutzten .htaccess nötig. Das nur so am Rande.

  • Ja ich habe es gelesen, nur damit weiß ich das es eben diese Fehler noch gibt. Ist ja nur zum testen. Ist ohnhin kein Update weil er ja sowieso sofort aufhört.

    Ich hatte nur vorher nie auf Datenbank Reparatur geklickt.


    Das Update mache ich ja schon seit eh und je über die Administrator Oberfläche.

    Ich frage mich nur warum er diese Fehler hat, denn mit der Datenbank hatte ich nie etwas gemacht.

  • Ja ich habe es gelesen, nur damit weiß ich das es eben diese Fehler noch gibt. Ist ja nur zum testen. Ist ohnhin kein Update weil er ja sowieso sofort aufhört.

    Ich hatte nur vorher nie auf Datenbank Reparatur geklickt.


    Das Update mache ich ja schon seit eh und je über die Administrator Oberfläche.

    Ich frage mich nur warum er diese Fehler hat, denn mit der Datenbank hatte ich nie etwas gemacht.

    Weil wahrscheinlich bzw. sicher sogar, bei diesem Update im "Provider Panel" die Datenbankschemas wohl nicht mit aktualisiert werden.


    Liebe Grüße

    Christine