Homepage wird nicht mehr korrekt angezeigt

  • Ich glaube, dass das ganze daren liegt, dass hier 2 Joomla-Instanzen in eine Ordner-Struktur gepackt wurden.

    Sinnvoll wäre gewesen im Root-Verzeichnis für jedes Joomla eine eigenen Ordner anzulegen. Darin jeweils ein Joomla, möglichst mit eigener DB, installieren.

    Die jeweils gewünschte Domain im Tool des Hosters auf den Ordner zeigen lassen.

    Hierbei hätte ich dann eine Subdomain gewählt und nicht wie du einfach einen Ordner unterhalb der vorhandenen Domain.

    Wie anka schon fragt, was steht in der .htacess, hat diese Auswirkungen auf alle Ordner und Unterordner. Insoweit kommen sich dann die beiden Joomlainstanzen in die Quere.

  • Sinnvoll wäre gewesen im Root-Verzeichnis für jedes Joomla eine eigenen Ordner anzulegen. Darin jeweils ein Joomla, möglichst mit eigener DB, installieren.

    Interessanter Tipp - ich hatte vor einigen Jahren die Situation, dass durch eine infizierte Seite (die bereits infiziert war, als ich sie via Akeeba von Strato übertragen hatte) auch alle anderen Seitem, die in eigenen Ordnern lagen, infiziert wurden. Da waren dann 10 Seiten von 10 Kunden infiziert.


    Beim einrichten der "Strato-Seite" (trotz teuer bezahlten Virenscanner bei Strato) kam der Hinweis von meinem Hoster, dass die Seite infiziert sei und hatte sofort den Account gesperrt - trotzdem zu spät.


    War ein teurer Spaß.


    Seit dieser Erfahrung jede Seite durch Reseller-Pakete auch physisch getrennt und nie wieder Probleme gehabt.

  • Hier mal meine .htaccess:


    Die anderen neuen Vorschläge arbeite ich heute Abend durch!

  • Momentan scheinst du irgendwie 3 Seiten installiert zu haben. Das ist irgendwie ein ziemliches Drucheinandern. Da blicke ich nicht mehr durch. Deshalb mal einiges Grundlegendes:


    1. Zunächst zurück zum live_site-Eintrag:

    Wenn folgendes in der configuation.php steht, dann ist das in Ordnung: $live_site = '';

    Lediglich wenn du dort zwischen den Hochkommata etwas einträgst, kann das ungeahnte Folgen habe. Die Zeile selber nicht löschen!


    2. Wenn alle Joomla parallel liegen, dann schaut das ungefähr so aus:

    ... /jooma1

    ... /joomla2


    Du könntest dann die Domain auf /joomla1 stellen und z.B. eine Subdomain auf /joomla2.


    3. Oberhalb von joomla1 bzw. joomla 2 sollte eigentlich nichts liegen, erst recht keine .htaccess, die sich auf beide Joomla auswirken würde.


    4. Innerhalb eines jeden Joomla kannst du mit der .htaccess arbeiten. Das ist spätestens dann notwendig, wenn du in der SEO-Konfigurtion im Backend den zweiten Haken setzt. Aber auch wenn du SSL über die .htaccess aktivierst und nicht über den Haken im Joomla-Backend, dann musst du die .htaccess nutzen, weil du da ja deinen Dreizeiler eintragen musst.

    Sollten weitere Serveranpassungen wie PHP-Versionsänderungen usw. nötig sein, so lässt sich das auch über die .htaccess bewerstelligen.


    5. Verwende immer die htaccess, die mit Joomla mitgeliefert wird. Diese heisst htaccess.txt und muss nur umbenannt werden in .htaccess, damit sie vom Server abgearbeitet wird.


    6. Natürlich kann man eine zweite Domain in Verbindung mit einem weiteren Tarif/Paket verwenden, um beides sauber zu trennen. Legt man jedoch nur eine Testversion an, kann man das ruhig über Parallelinstallation machen.

    Am besten man nutzt eine Subdomain, die man auf die Testversion einstellt.

    Ich selber lasse bis zu 10 Installationen parallel in einem Tarif laufen ohne jegliche Probleme mit Infizierungen oder so. Sollte man natürlich alles selber warten und pflegen und alle Sicherheitsmaßnahmen beachten. In dem Moment, wo weitere User ins Spiel kommen, bekommen die dann einen eigenen Tarif/Paket.


    EDIT: Wo liegt denn diese .htaccess, die du oben gepostet hast? Mit der kommst du nicht weit, wenn du SEO nutzen möchtest.

  • @Birger : Du hast recht, dass man bei Kunden darauf achten muss, dass jeder seinen eigenen und alleinigen Bereich hat, damit nicht Probleme / Fehler des einen Kunden sich auf andere Auswirken.

    Bei eigenen Projekten oder z.B. bei Vereinen mit mehreren Abteilungen, kann mein Vorgehen durchaus Sinn machen.

    Die von dir geschilderte Gefaht besteht natürlich dann auch hier.

  • Guten Abend!


    Ich habe nun folgendes Root-Verzeichnis:

    root/Bort

    root/ascw_homepage

    root/bort_homepage

    root/wbb4


    Das wars. Da sind keine weiteren Dateien drinnen.


    in root/ascw_homepage habe ich alle obigen Dateien hineinkopiert, auch die "originalen" .htaccess und .passwd.


    in root/Bort ist meine neue HP, diese wurde in dieses Verzeichnis installiert.

    in root/bort_homepage ist meine ganz neue Testversion.

    Diese beiden haben nun auch die Joomla .htaccess erhalten. Seit ich die htaccess.txt auf .htaccess umbenannt habe, komme ich bei beiden nicht mehr ins backend.



    Nach dem Versuchen dieser Tipps

    Error 500 mit der .htaccess

    zur Behebung des Error 500, komme ich auch nicht mehr auf die Seite (Frontend?).

  • Was du als /root - Verezichnis beschreibst, ist in aller Regel das /html - Verzeichnis.

    Oder hast du /root als Unterordner von /html angelegt?

    Nun stellt man seine (Sub)Domains auf die jeweiligen Zielverzeichnisse ein. Wenn du nur eine Domain nutzt, dann musst du dieses RewriteBase in der .htaccess verwenden und dort jeweils den Unterordner eintragen.


    Folgender Eintrag muss bei einigen Hostern als Kommentar gesetzt werden, also einfach # davor setzen:

    # Options +FollowSymLinks

  • Die .htpasswd hatte keinerlei Inhalt und wurde jetzt entfernt.


    Ich komme auch wieder ins Backend nachdem ich

    # Options +FollowSymLinks

    in der original Joomla .htaccess auskommentiert habe. World4You W4Y setzt dies offensichtlich bereits serverseitig.


    Ja, mit /root meine ich wohl das /html-Verzeichnes. Also das "unterste" auf meinem Webserver.

    Im /html-Verzeichnis habe ich eine .htaccess für die Weiterleitung der Domain erstellt:

    Code
    RewriteEngine On
    RewriteRule ^$ /ascw_homepage [L]

    In den jeweiligen Unterordnern gibt es dann jeweils eine eigene .htaccess.

    Hier jene für ascw.at/ascw_homepage, es handelt sich um jene, die bei Joomla dabei war + ein paar selbst recherchierte Zeilen:

    Mir fällt auf, dass bei den Fehlermeldungen in der Console auf der Hauptseite (http://www.ascw.at) alles in Ordnung ist und die Links ohne .../index.php/ stehen. Und auf einer Subseite, zB Impressum, stehen sie mit ../index.php/. Siehe Screenshot.


    Leider verstehe ich nicht alle Verlinkungen in der .htaccess. Aber ich weis, dass die aktuelle Fehlerliste in der Console, sich dadurch jedenfalls stark reduzieren lassen wird. Wenn euch etwas auffällt, bin ich dafür offen!

  • Bei deinen Basteleien blickt doch niemand mehr durch, mir scheint, als hättest du dich da irgendwo verlaufen. Ich würde sämtliche .htaccess in den Urzustand setzen, und zusehen, alles einwandfrei zum Laufen zu bringen. Und erst danach Änderungen vornehmen, die dann auch nachvollziehbar sind. Mit Subdomains arbeiten. Eventuell den Hoster wechseln, das Gerumpel mit dem SSL Zertifikat und den PHP Versionen ist suboptimal.


    Als Erfahrener kann ich dir sagen, dass das Aufsetzen einer zweiten (parallelen) Instanz mit einer Kopie der ersten ganz fix geht, das ist eine typische Vorgehensweise, wenn man Instanzen zB migrieren will, und die erste Instanz dabei online bleiben soll.

  • Da kann ich mich meinem Vorredner nur anschließen:

    Lege jeweils eine Subdomain an (das sollte bei deinem Hoster doch möglich sein, oder?) und stelle diese auf das gewünschte Unterverzeichnis ein!


    Verwende in jedem Joomla die originale .htaccess mit der Änderung bzgl. # Symlinks (hast du ja bereits gemacht) und maximal einem zusätzlichen Eintrag für die SSL-Weiterleitung. Könntest hierfür einfach mal folgendes nehmen (ist so eine Art Standardeintrag):

    Code
    # SSL: In allen Fällen wird zur URL mit "https://www" weitergeleitet!
    RewriteCond %{HTTPS} !on [OR,NC]
    RewriteCond %{HTTP_HOST} !^www\. [NC]
    RewriteRule ^(.*)$ https://www.example.org/$1 [R=301,L]

    Für example.org setzt du die deine Domain oder Subdomain für das jeweilige Joomla ein.


    Hinweis: Die Verwendung von SSL ist aber bei Subdomains nicht ganz so einfach. Die meisten SSL-Zertifikate gelten beispielsweise für http://www.example.org und test.example.org, jedoch nicht für http://www.test.example.org.


    Wenn du SSL zum Testen zunächst nicht verwenden möchtest, setzte jeweils eine # vor die 3 Zeilen (Kommentarfunktion).

    Grundsätzlich kannst du SSL auch im Backend aktivieren und deaktivieren bzw. über die Einträge in der configuration.php.

    Ich würde SSL erst aktivieren, sobald deine Version ohne Fehler läuft.

    Auch gzip und irgendwelche Optmierungstools (falls verwendet) würde ich zunächst deaktivieren!


    Die .htaccess im html-Verzeichnis löschen.


    Deine gepostete .htaccess im Joomla-Verzeichnis scheint auch nicht ganz korrekt zu sein. Könnte mir vorstellen, dass das Probleme verursacht. Ist aber nicht mein Fachgebiet.

  • Da habt ihr wohl recht!


    Ich habe ALLES gelöscht und eine zuletzt voll funktionierende Sicherung hochgespielt.

    HTTPS beim Hoster deaktiviert.

    Sie geht immer noch nicht.


    Mir ist aufgefallen, dass ich nie eine .htaccess hatte. Erst beim Klick auf HTTPS beim Provider wurde eine angelegt. Stelle ich das aus, wird sie wieder gelöscht.

    Bei der alten Version war HTTPS erzwingen deaktiviert und ist es immer noch.

    Es hat wohl damit eher nichts zu tun.


    Am Abend bin ich wieder daran. Danke für eure Hilfe! Ist wohl wirklich ein vollkommen individuelles Issue. Ws. wegen dem Template.

  • Wenn dein Hoster die .htaccess automatisch anlegt, sobald du bei ihm https anklickst, dann würde ich auf diese Methode verzichten.

    Stattdessen einfach die Joomla-htaccess nutzen und die SSL-Zeilen des Hosters dann einfach dort mit eintragen. Dann müsste das mit dem Zertifikat auch laufen und du hast jederzeit die Möglichkeit, weiteres in die htaccess zu schreiben. Die benötigst du ja auch für die SEO-Einstellungen im Backend. Und zwei .htaccess sind ja nicht möglich.


    Bzgl. der Fehler auf der Seite müsste man sich das wohl wirklich mal im Backend anschauen und das Problem eingrenzen. Sonst schick mir einfach mal einen Zugang, wenn du möchtest. Aber nicht hier im Forum posten!

  • Hallo!


    Gestern habe ich es total verpatzt. Ich habe auch das Forum gelöscht. ;(

    Gut, nicht so schlimm grundsätzlich. Ich habe es dann wieder darauf gespielt. Die Daten sind ja in der Datenbank gespeichert. Ich habe aber bemerkt, dass Bilder, auch ältere vor der Sicherung, nicht mehr angezeigt wurden. Ob das bereits vorher der Fall war oder nicht, kann ich leider nicht sagen. Es war auch hier wieder ein index.php/Attachment/index.php/Attachment im Zugriff auf die Bilder.


    Nachdem nun ALLES gelöscht ist und auch die Subdomains und .htaccess entfernt sind:


    http://www.ascw.at -> führt zu http://www.ascw.at/ascw_homepage

    Ich kontaktiere aktuell den Webhoster. Dann kümmere ich mich ums Forum.

    Danach möchte ich noch kurz selbst damit befassen und dann ggf. gerne Hilfe in Anspruch nehmen. Natürlich nicht unentgeltlich!


    Ich melde mich sobald, das Forum wieder läuft! Die Homepage ist sekundär und grundsätzlich kann ich die, wenn sie denn wieder laufen, in Kürze selbst wieder aufbauen. Die Inhalte sind ja noch in der DB und die sind aktuell gesichert. :saint:

  • So, ich bin wieder da.


    Ich habe ehrlich gesagt keine Lust mehr, das alte Joom! von Webkomp zu flicken. Wie ich mittlerweile herausgefunden habe ist das drumherum um Joomla heute ganz anders aufgestellt als damals. Joom! war eben ein free Template. Eines von unzähligen. Heute ist es offensichtlich nicht mehr so, dass es unendlich viele freie Templates gibt. Ist auch gut so, wenn entsprechende Qualität geliefert wird.

    Zum Joom, wir haben uns damals, ca. 2015 um ~20 bis 25€ eine vorinstallierte Version gekauft. Wir hatten immer schon, auch vor dem Joom! Schwierigkeiten mit einer teilweise extrem langsamen Homepage. Jetzt habe ich gelernt warum. In dieser Vorinstallation waren Seite/Module, etc. freigeschalten aus denen ich z.T. mehrere tausende Einträge aus einer Arte Gästebuch zu löschen hatte. Die wir aber nicht im geringsten verwendeten.

    Punkt hier.


    Was empfehlt ihr aktuell hier?

    So wie ich das sehe gibt es Joomla, darauf kommt dann etwas wie Helix, Warp, etc. mit dem man dann eine HP zusammenstellen kann.

    Ich zahle gerne für ein Template, das meinen Anforderungen genügt, hauptsächlich optik mit nem netten Slider auf der Mainpage. Meine, wahrscheinlich unberechtigte, Angst ist: zB. 60€ Template + x mal 10€ für diverse Plugins, damit das Template überhaupt mal so läuft wie es beworben ist.


    Welche Template Anbieter werden hier so empfohlen? Soll natürlich wieder Top-Aktuell sein und für mich einfach und schnell Inhalt einzufügen. Ich habe zwo Homepages, die mir Offline einfach mehr kosten als die paar Euro, die ich zu investieren habe. Vor allem auch an Zeit und Nerven, die ich beides anderorts effektiver zu investieren weis.

  • So wie ich das sehe gibt es Joomla, darauf kommt dann etwas wie Helix, Warp, etc. mit dem man dann eine HP zusammenstellen kann.

    Man benötigt für das Erstellen einer Webseite kein Helix oder Warp.... Joomla bringt alles out of the box mit - nutz einfach das bereits vorhandene Template Protostar.


    Die Webseite wird über Komponenten erstellt. Diese werden über Menüeinträge und dessen Menüeintragstypen angezeigt.

  • Was empfehlt ihr aktuell hier?

    Empfehlen will ich nichts, aber hier hast du schon eine große Auswahl von kostenfreien und kostenpflichtigen Templates:


    Template gesucht? Joe's Liste >>


    Ich habe schon gute Templates hiermit erstellt.


    Schau mal nach Quickinstall und/oder Quickstarts.


    Das ist eine Joomla-Installation (Auf die Aktualität achten!) mit Template und Beispielinhalten.