schwerer Fehler bei Update auf 4.0

  • Hallo,


    ich habe am Wochenende das Update von 3.10.x auf 4.0.5 nach Anleitung durchgeführt. Offensichtlich habe ich an irgendeiner Stelle irgendetwas übersehen, auf jeden Fall wurde das Update nicht bis zum Ende durchgeführt. Die Webseite enthielt eine Fehlermeldung, Joomla funktionierte auch im Backend nicht mehr. Erst nach dem Einspielen eines Datenbankbackups funktionierte die Seite zumindest im Frontend wieder. Im Backend läuft es nicht rund, viele Menüpunkte funktionieren nicht mehr. Wenn ich auf Erweiterungen -> Verwalten -> Datenbank gehe, wird mir nun angezeigt, dass diverse Tabellen nicht existieren und die Datenbank nicht auf dem neuesten Stand ist. Zudem wurden jetzt 105 Datenbankprobleme gefunden. Nach Ausführen der Reparaturfunktion bleiben zum einen noch 19 Datenbankfehler über, zum anderen ist dann der Internetauftritt zerschossen, d. h. die Seiten werden nicht mehr vollständig angezeigt.


    Ich bin nun mit meinem Latein am Ende. Weiß jemand hier vielleicht jemand eine Lösung für mein Problem?


    Vielen Dank im Voraus!

  • Woran es genau gelegen hat, lässt sich kaum beurteilen.

    Einfach die zuvor angelegte obligatorische Sicherung wieder neu einspielen (J3), dann auf 3.10.5 updaten und erneut die Migration auf 4.0.6 durchführen. (neueste Versionen)

    Eventuell noch mal genau die Drittanbieter-Erweiterungen auf Kompatibilität überprüfen.

    Welche PHP-Version läuft überhaupt?

    Und welche Datenbank-Version? (MySQL 5.7 muss es auf jeden Fall sein, nicht niedriger)

  • Ich würde das Backup einspielen, alle Extensions updaten,

    schauen, ob das Template/Framework aktuell ist, und dann

    den Updateprozess erneut durchführen.


    Du bekommst ja Meldungen, welche Erweiterungen ggf. nicht mit J4 kompatibel sind.


    Vielleicht mal ein Screenshot davon posten.

  • Danke für die Infos!


    Der Versuch, nach dem Backup auf 3.10.5 upzudaten, ging schief, es gibt folgende Fehlermeldung:


    Fatal error: Trait 'Joomla\Plugin\System\Webauthn\PluginTraits\AjaxHandler' not found in /homepages/22/d66581491/htdocs/plugins/system/webauthn/webauthn.php on line 34


    Also nochmal Backup eingespielt, nachgesehen, welche PHP-Version eingestellt ist - es ist 7.4 ... Habe ich umgehend auf auf 8.0 hochgesetzt. Die Seite läuft erst einmal wieder. Im Backend gibt es keinen Hinweis mehr auf ein Update auf 3.10.5, dafür sind zwei Erweiterungsupdates verfügbar. Diese kann ich aber nicht installieren, denn wenn ich auf "Updates anzeigen" klicke, erscheint die angehängte Fehlermeldung.


    In der Hoffnung, dass morgen wieder ein Update auf 3.10.5 möglich ist, werde ich wohl etwas warten müssen.


    Bevor ich es vergesse - ich hatte auch ein Backup der Dateien über den FTP-Server gemacht und wieder eingespielt. Die Datenbankversion ist MySQL 5.7.


    GFB

  • Verstehe ich jetzt nicht.

    Geht es jetzt hier um Update auf 4 oder 3.10.5?


    Vielleicht noch hilfreich:


  • Eigentlich geht es um ein Update auf 4.0. Nach dem Einspielen des Backups gab es den Hinweis, dass es ein Update auf 3.10.5 gibt, welches ich aber nicht einspielen kann. Um auf Nummer sicher zu gehen, wollte ich dieses Update noch durchführen, um dann auf 4.0 zu wechseln. Ich habe den Debug-Modus aktiviert und nochmals auf "Updates anzeigen" geklickt. Anbei die Liste der daraus resultierenden Meldungen. Dummerweise kann ich damit nichts anfangen.


    GFB

  • Zitat

    Bevor ich es vergesse - ich hatte auch ein Backup der Dateien über den FTP-Server gemacht und wieder eingespielt.

    Davor alle Dateien auf dem Webspace gelöscht? Für mich sieht es noch nach einem Durcheinander von V3 und V4 aus.


    Protipp: Migration mit einer Kopie der Seite auf einer Subdomain in einer eigenen Datenbank durchführen, so bleibt die produktive V3 unberührt.


    Tipp 2: Erst auf 4.0.0 gehen. Wenn das Backend dann läuft, auf die aktuelle Version 4.0.6 updaten. Meinen Erfahrungen nach kommt es vor, dass sich ein eher suboptimaler Webspace bei dem relativ großen Versionssprung "verschluckt".

  • Einen Link zur Webseite habe ich hier noch nocht finden können um abzuschätzen, wieviel Aufwand eine Neugestaltung tatsächlich für dich wäre.

    Wenn ich die Fehler so betrachte und das Durcheinander zwischen J3 und Upgrade auf J4 sehe, empfehle ich dir eine Neuinstallation von Joomla4!


    Die Beiträge (wenn du so viele haben solltest, dass "copy and paste" nicht mehr vertretbar wäre) lassen sich über Plugins (Import /Export) bei Bedarf übernehmen. Beispiel hier: https://www.eshiol.it/joomla/j2xml/j2xml-3-9.html (für J4 bals vefügbar).


    Es macht den Eindruck, dass deine vorhandene J3-Version bereits mit diversen Fehler behaftet ist, welche du dir ganz oder zumindest teilweise auch in J4 mitnehmen würdest.


    Also, pack`s an und mach neu ;)

  • Moin,


    ich habe noch einmal über das Hosting die Datenbanktabellen gelöscht. Zudem habe ich über den FTP-Server den gesamten Inhalt gelöscht. Anschließend Datenbackup und über den FTP-Server die Ordnerstruktur wieder hochgeladen. Tadaaa: im Backend läuft wieder alles rund! Die Datenbankstruktur ist wieder aktuell und enthält keine Fehler mehr. Der Fehler, der das Chaos verursacht, befindet sich in diesem Fall eindeutig vor dem Bildschirm. Ich habe offenbar die Ordnerstruktur nicht bzw. vollständig beim ersten Einspielen der Backups gelöscht.


    Insofern: vielen, vielen Dank für die Hinweise!


    Jetzt kann ich mich noch einmal an das Update auf 4.0 heranwagen, weiß ja jetzt, was ich machen muss, wenn es wieder nicht klappen sollte ^^


    Nochmals DANKESCHÖN!


    GFB

  • Bitte Thema noch auf erledigt setzen.